We have moved to a new Sailfish OS Forum. Please start new discussions there.
1

[Bug] Why partly recovery changed account settings, even though it wasn't selected for recovery? [released]

asked 2014-02-09 16:41:49 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2014-02-09 16:41:49 +0300

  1. I reset my Jola phone and created manually some accounts.
  2. Then rsync my old .vault back to my phone and run a recovery for browser, messages, contact and phone. I checked twice that I didn't select "accounts", because I had problems with some of the accounts.
  3. After recovery my old accounts was recovered:
    • Mail account had old description and no mails, inbox or folders where shown in jolla-email
    • jolla-email won't sync anymore (even after reboot), until I killed messageserver5 (to restart it for debug in a terminal)
    • another xmpp account showed up again, which I didn't setup after reboot
    • if I open accounts.db in sqlitebrowser, the accounts have exactly the same ID like in my backup, even though I created them in a total different order

Can somebody reproduce this bug?

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by dez
close date 2014-03-20 13:25:54.770948

2 Answers

Sort by » oldest newest most voted
1

answered 2014-03-20 13:25:45 +0300

dez gravatar image

Fixed in 1.0.4.20

edit flag offensive delete publish link more
0

answered 2014-02-13 23:45:58 +0300

teun gravatar image

updated 2014-02-13 23:46:54 +0300

so I think it works as follows : when creating a backup you select what you want to be saved. restoring wil always result in restoring all content of a backup. so if you don't want to restore accounts you first will have to create a backup exluding the accounts

edit flag offensive delete publish link more

Question tools

Follow
1 follower

Stats

Asked: 2014-02-09 16:41:49 +0300

Seen: 145 times

Last updated: Mar 20 '14