Ask / Submit
3

Restart required to connect to Wireless WPA2 network

asked 2014-03-03 19:05:57 +0300

xxhell gravatar image

updated 2015-01-14 12:37:25 +0300

eric gravatar image

Sometimes when i add a new Wifi Hotspot that's secured with WPA2 i get an error stating that it cannot connect to that specific network. Initially i thought it was a limitation to the network types Jolla can connect (and i believe there are some, correct me if i'm wrong), but after i changed ISP i realised it is not the case. Initially i connected to the AP with its default settings, and it went fine. Did the same in my iPhone and it connected OK too. After i configured the new AP exactly with the same Wifi Network parmeters, my iPhone instantly picked up the network as it was my previous AP. In Jolla case, it didn't (and i believe it's normal because it registers the AP's MAC Address) and i believe it was fine till this point. I deleted the previous AP Wireless connection data (Forgot It) and tried to connect. Got the 'Sorry, cannot connect to this network' message. Disabled/Enabled Wifi and always the same message again. Finally i restarted my Jolla and tried to connect. It connected fine. Yesterday tried to connect to a new network and got the same message... and after a restart it connected OK. In conclusion, i believe that when you delete an Wifi Network the 'connman' service should be restarted each time a connection is forgot (to reload the list of configured network connections).

So, and as a suggestion, can't the Wifi Switch Start/Stop the 'connman' service instead of just disabling the wifi search feature?

Thanks in Advance, xxhell

edit retag flag offensive close delete

3 Answers

Sort by » oldest newest most voted
3

answered 2014-03-03 19:18:13 +0300

Xeno_PL gravatar image

I'm not sure, but probably stopping connman you'll disable all data connections (including GPRS/3G). In my case it was enough to restart connman via

devel-su
systemctl restart connman.service

to be able to probelry reconnect to the WiFI

edit flag offensive delete publish link more

Comments

Ok, then i believe that an alternate way of reading network config files must be thinked. Not all users have Developer Mode enabled or want to use the terminal. Anyway, gonna try your suggestion next time it occurs. Thx :)

xxhell ( 2014-03-03 19:28:12 +0300 )edit

@Xeno_PL For me restarting connman leads to all from the side gestures not working. Only restart restores the gestures afterwards.

PS. Sorry for the offtopic, but just sharing the experience.

zlatko ( 2014-03-03 20:47:54 +0300 )edit
1

answered 2014-03-04 10:41:59 +0300

llornkcor gravatar image

I have found that disabling and then re-enabling wlan after forgetting the AP will allow the connection to proceed, until we can get an update to fix this.

edit flag offensive delete publish link more

Comments

As i said above, that doesn't work in my case :(

xxhell ( 2014-03-04 12:30:54 +0300 )edit
0

answered 2014-03-04 10:03:47 +0300

tvicol gravatar image

Similar issue was reported by me here https://together.jolla.com/question/28410/unable-to-reconnect-to-forgotten-networks/

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2014-03-03 19:05:57 +0300

Seen: 976 times

Last updated: Mar 04 '14