Ask / Submit
19

Music player does not support apostrophe character ( ' ) in directory name

asked 2014-04-01 15:13:18 +0300

argontus gravatar image

updated 2014-04-02 07:52:02 +0300

Apparently apostrophe character ( ' ) is not supported by the music player, or the service that indexes media files on the phone. Tracks (in mp3 format) that are in a directory whose name contains an apostrophe are not shown in the media player even after restarting.

edit retag flag offensive close delete

Comments

Can you give us an example ?

fblm ( 2014-04-02 09:12:38 +0300 )edit

@fblm, create a directory in the Music directory in phone storage. Name the directory "Foobar's Greatest Album Ever". Open media player - the album is not shown in the album list, nor the artist/tracks. Restarting the phone does not fix the situation until the apostrophe is removed from the directory name.

argontus ( 2014-04-02 09:28:51 +0300 )edit

Sounds like a problem with tracker failing to index the folder for some reason. However, I can't confirm it myself; I have "Quanio5 - You Hadn't Been Born Yet" as a folder on my sdcard and all the tracks within are properly indexed by tracker (including album art, which is more than can be said of most of my albums, heh).

keithzg ( 2014-09-27 02:39:58 +0300 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2015-03-16 22:53:30 +0300

di_fun gravatar image

updated 2015-03-18 20:21:18 +0300

I run into it too. But not only for folder names, also for file names. I removed every single special charakter like ' # [ ] ( )ÖÄÜ and got apr. 75% of my mp3 files shown in Media Player after "tracker-control -es". Then I realized, that some MP3 Tags are damaged during copying the files from pc, for some reason. So I retagged the mp3 files and finally got all tracks shown in Media Player. Now I 've just probs with album artfiles (folder.jpg). Found this for album artfiles but not tried so far.

edit flag offensive delete publish link more

Comments

might be a prob related to the encoding of your tags. iso-8859-1 for id3v1.x and utf8 for id3v2.4.0 work for me with jolla = en. tracker will strip these chars when creating the md5sums (which it doesn't seem to do anymore nowadays hence no cover art shown unless you add it yourself) but you can have them in your tags, folder and file names.

veloxneb ( 2015-03-19 03:31:07 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2014-04-01 15:13:18 +0300

Seen: 330 times

Last updated: Mar 18 '15