We have moved to a new Sailfish OS Forum. Please start new discussions there.
30

Bug: Incorrect time stamp in texts received while phone was off

asked 2014-04-01 22:10:37 +0300

Louis gravatar image

updated 2015-01-28 21:41:56 +0300

Sometimes when I turn on my phone and type pin code then if I've got some incoming texts while it was powered down I then get these messages with incorrect time stamp. They will show up as it was sent a minute ago even if the messages was sent hours ago.

UPDATE 28/1-15

This bug is partly fixed. If I receive an sms while my Jolla is powered off I'll correct time stamp in conversations dialog, but still show wrong time stamp in the conversions overview. SW version: 1.1.1.27

edit retag flag offensive close delete

Comments

2

This is annoying. I use the sms date as reference very often, I trusted this worked out of the box.

Jolla, are you reacting to this?

c.la ( 2014-04-10 18:49:17 +0300 )edit

Just found out that this bug is still present after upgrading to 10.5.16.

Louis ( 2014-04-12 17:14:21 +0300 )edit

Still present in 1.0.7.16 too.

Louis ( 2014-06-14 17:54:21 +0300 )edit

https://together.jolla.com/question/15195/bug-cleared-missed-call-notification-reappearing/#post-id-50504 is probably related to this because the incorrect times probably cause that issue too.

Jolla, you are using a proper date/time library, aren't you? ;)

jval ( 2014-07-15 15:26:46 +0300 )edit

@Louis Which Sailfish OS version are you using? I couldn't reproduce this on 1.0.8.19

jiit ( 2014-07-18 14:17:59 +0300 )edit

1 Answer

Sort by » oldest newest most voted
7

answered 2014-10-20 15:48:00 +0300

tkenakka gravatar image

updated 2014-10-20 15:48:54 +0300

Thank you for reporting the issue. This has been identified by Jolla as a valid issue. Meanhwile, please compare what timestamps you have displayed in following two views for the same SMS

a) Messages main view, which shows you the list of message threads with different contacts

b) Message thread view, which is opened in the previous view by tapping the item

As you may know, the latest sms from a contact is displayed in both views.

BTW This problem should happen also if you use Flightmode to put your device offline and send messages to it, then disable Flightmode.

edit flag offensive delete publish link more

Comments

You're right. It's also present when using flight mode. And yes the time stamp for a delayed sms is the same in both the main view and the message thread.

Louis ( 2014-10-20 17:08:57 +0300 )edit

@Louis Thanks for the confirmation. For me the received time is displayed only in a), in b) i have the sent time, for this specific time I tested.

tkenakka ( 2014-10-24 16:02:54 +0300 )edit
2

For everyone's information,

according to Jolla an issue in the Messages main view handling of timestamp for the latest message in the SMS conversation has been identified and a solution should should become available in one of the upcoming updates - unfortunately not yet included to Update 1.1.0.38 (https://together.jolla.com/question/59874/release-notes-opt-in-upgrade-to-software-version-11038-uitukka/).

(The solved issue corresponds to "a)" item in my above post https://together.jolla.com/question/37307/bug-incorrect-time-stamp-in-smses-recieved-while-phone-was-off/#post-id-59618)

tkenakka ( 2014-10-28 10:34:39 +0300 )edit
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2014-04-01 22:10:37 +0300

Seen: 3,505 times

Last updated: Jan 28 '15