Ask / Submit
35

MMS issues? Hints for debugging and helping us to improve

asked 2014-04-11 13:03:28 +0300

Aard gravatar image

updated 2014-04-24 17:34:03 +0300

Update: We're rolling out a hotfix for MMS today, which should fix several of the major issues reported by you. Thanks for all the help so far! We're still collecting data, so please keep contacting us if you still have issues not fixed or not mentioned in the comments to this post.


With the current update we've published initial MMS support. Unfortunately, MMS is technically a bit of a dinosaur, and several operators have slightly incompatible custom implementations. As a result of this we're expecting issues with many operators outside of Finland -- but still decided to push the current implementation early, and try to fix issues faster than we could on our own with your feedback.

This post contains some notes for technically skilled users with developer mode enabled. We're working on a simple application automating some of those steps, which will be published at a later point to enable less skilled users to help us improving MMS as well.

So, if you have problems with MMS..

  1. Was it possible to send a MMS? Many operators only let you receive MMS once you sent at least one MMS from your phone.
  2. No luck? Check if the MMS settings (Settings->System->Mobile network->MMS access point) are correct for your operator. If they're not correct, please provide the output of the following commands, plus correct settings, if you have them:
    • dbus-send --system --print-reply --dest=org.ofono /ril_0 org.ofono.ConnectionManager.GetContexts for the connection settings
    • dbus-send --system --print-reply --dest=org.ofono /ril_0 org.ofono.SimManager.GetProperties for details about your network
  3. Still no luck? Try to get debug output while sending or receiving MMS. Before sending/receiving (or retrying to receive), as user nemo, do
    • pkill mms-engine
    • mms-engine -vkat and send us the output from the terminal, as well as the contents of /tmp/mms

Info collected should be sent to mms-debug@jolla.com. Please note that this address is designed to easily collect debug information for our engineers, and can't be used as MMS support hotline. If you write us, please do a short post here about which provider and which problem you faced as well, to reduce duplicate submissions as much as possible. We'll try to comment here, and most likely only contact you by mail if we need additional debug output.

edit retag flag offensive close delete

Comments

To care@jolla.com or here?

Morpog ( 2014-04-11 13:52:00 +0300 )edit

I cannot send MMSs with Vodafone IT. I gathered all info from points 2. and 3., which is the email address to report them?

donaggio ( 2014-04-11 13:55:26 +0300 )edit
7

Swisscom will not even let you send MMS when you use an unknown model of phone (e.g. the Jolla). I had the same with the N900 and fmms back then.

The solution is to call their hotline and kindly convince them that your handset is capable of MMS sending and receiving. They will then enable it for your phone. However, when you place your SIM card in another phone and put it back in the Jolla, you'd have to call the hotline again.

Venty ( 2014-04-11 14:05:18 +0300 )edit

Is it working for Swisscom after calling the hotline or are there some issues?

thwint ( 2014-04-11 14:26:31 +0300 )edit

My operator is saunalahti, but the mms settings defaulted to elisa. Manually changed them to saunalahtis mms settings, and i am now able to send mms. I am not, however, able to receive MMS. I only get an sms from the operator with a link to where i can have a look at the mms. But i guess this is an issue with saunalahti/elisa and not with the jolla...

plipp ( 2014-04-11 14:40:51 +0300 )edit

35 Answers

Sort by » oldest newest most voted
0

answered 2014-04-12 17:08:46 +0300

trashin gravatar image

updated 2014-04-12 23:02:26 +0300

Update: Users with iPhone4 and 5 I tested with had incorrect settings on their phones. Once these were corrected MMS messages from my Jolla came pouring in on their phones, all fine. When they sent MMS messages back to me they all worked fine too.

So: NO problems to report, please ignore/delete my email!

  1. Possible to send and receive MMS to myself. Not possible to receive or send to other devices on same network.

This is on OneCall / Network Norway in Norway.

Logs sent by email.

edit flag offensive delete publish link more

Comments

I have managed to send and recive MMS to others on OneCall/Network Norway. Using manual configuration derived from their android settings on their web page.

oyviaase ( 2014-04-12 20:59:11 +0300 )edit

Thanks oyviaase,

it always worked fine for me. Moral of my story: don't trust iPhone users having correct settings (see update above)........

trashin ( 2014-04-12 23:04:39 +0300 )edit

I can recive mms from Telenor Norway, but not from Chess Norway or Netcom Norway. And I can not send mms. This is on Chess Norway

robhel ( 2014-04-14 00:50:58 +0300 )edit

Was able to get receiving MMS to work on NetCom Norway by entering the manual settings here https://netcom.no/kundeservice/telefonoppsett/manuelt-oppsett but can not send.

electristan ( 2014-04-24 12:51:08 +0300 )edit
0

answered 2014-04-13 12:46:29 +0300

Rashed Albloushi gravatar image

updated 2014-04-16 07:38:14 +0300

The configuration for my country (United Arab Emirates) and for the service provider "Etisalat":

Connection name: Etisalat UAE MMS

APN: etisalat

Username: [empty]

Password: [empty]

Proxy address: 10.12.0.32

Proxy port: 8080

MMSC: http://mms/servlets/mms

edit flag offensive delete publish link more
0

answered 2014-04-13 19:09:26 +0300

pfbach gravatar image

Telenor in Norway

works out of the box for me.

Tele2 in Norway

Proxy-address: 193.12.40.14

Proxy-port: 8080

MMS message center: http://mmsc.tele2.no

edit flag offensive delete publish link more
0

answered 2014-04-14 23:31:59 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2014-04-14 23:31:59 +0300

BonoNL gravatar image

Vodafone Netherlands

MMS settings where set on office.vodafone.com, I changed it to live.vodafone.com. Didn't do the trick, all the other settings where fine.

Recieving went well, sending is the issue. I've mailed the output of the terminal.

edit flag offensive delete publish link more
0

answered 2014-04-15 21:20:29 +0300

Xeno_PL gravatar image

updated 2014-04-15 21:23:39 +0300

Nju Mobile (Poland) - sending works, downloading not tested yet.

Auto setup: provider misdetected as Aster

Manual setup:

apn: mms

Security

User: mms

Pass: mms

Proxy

Address: 192.186.006.104

Port: 8080

Message center address: http://mms.njumobile.pl

edit flag offensive delete publish link more
0

answered 2014-04-15 21:23:36 +0300

oenone gravatar image

updated 2014-04-15 21:24:52 +0300

MMS has been tested and does work both to send and recieve with Fido, (Canada). As a sub-brand, it is assumed that ROGERS (Canada) will also work, providing that the correct settings for ROGERS are set.

Devices used: Jolla, on Fido network <-> Blackberry Z10, on WIND network.

Settings used on Jolla, for Fido network:

Connection name: mms.fido.ca

Access point name: mms.fido.ca

Username: [blank]

Password: [blank]

Proxy address: 205.151.11.13

Proxy port: 80

MMS message centre address: http://mms.fido.ca

edit flag offensive delete publish link more
0

answered 2014-04-16 00:35:11 +0300

peter.woelflingseder gravatar image

Austrian 3 - drei.at

I had to configure MMS settings manually according to information provided by the operator as follows:

  • Connection name: 3MMS
  • APN / access point: drei.at
  • Username: [no username set]
  • Password: [no password set]
  • MMS server addresse: mmsc
  • Proxy address: 213.94.78.133
  • Proxy port: 8799

Sending of MMS tested successfully, terminal output sent to mms-debug@jolla.com

edit flag offensive delete publish link more
0

answered 2014-04-16 10:50:47 +0300

clovis86 gravatar image

Is there any way to retry to receive a MMS or only way is to ask sender to send it again ?
sending flawlessly but unable to receive one :( operator : free mobile in France

edit flag offensive delete publish link more
0

answered 2014-04-21 13:39:38 +0300

cocovina gravatar image

updated 2014-04-21 13:56:35 +0300

Hi there,

Can receive, but can't send MMS under O2 CZ (Telefónica Czech Republic).

  • ERROR: MMSC responded with 226

Settings seems to be OK. Does anyone have the same problem with O2 CZ? Any suggestions or advice? Debuging output sent to Jolla well as setting.

edit flag offensive delete publish link more

Comments

Yes, a lot of people have the same problem with many operators. Known issue and now we have to wait for the next update :)

TellienInTouch ( 2014-04-21 21:03:23 +0300 )edit
0

answered 2014-04-24 04:53:59 +0300

vascorsd gravatar image

Vodafone Portugal

Changed the default settings a little, seems to at least receive the MMS I had pending. Haven't tested sending yet.

name: Vodafone MMS
acces point: vas.vodafone.pt
user: vas
password: vas
proxy: 213.30.27.63
proxy port: 8799
message center: http://mms/servlets/mms

Have fun :)

edit flag offensive delete publish link more

Comments

Vodafone Netherlands

Only changed the message acces point name from live.vodafone.nl to live.vodafone.com and it works!

BonoNL ( 2014-06-21 00:31:30 +0300 )edit
Login/Signup to Answer

Question tools

Follow
20 followers

Stats

Asked: 2014-04-11 13:03:28 +0300

Seen: 9,197 times

Last updated: Jun 11 '17