Ask / Submit
25

[BUG] Stopwatch seconds shown wrong [released]

asked 2014-05-02 19:21:39 +0300

tmy gravatar image

updated 2017-12-28 15:00:11 +0300

When stopping (pressing "+" button) the stopwatch at full seconds, i.e. when the hundredths are "00", sometimes 1 too few seconds are shown.

For example, if i stop the watch at 1 second sharp, sometimes the stopwatch shows "00:00.00" instead of "00:01.00". This happens maybe 50% of attempts. Same applies for 2 seconds and higher. Not sure if minutes are affected.

Edit: Still happens in 1.0.8.19

Edit 2: Still not fixed in 1.1.0.39

Edit 3: Still present in 1.1.1.27

Edit 4: Not fixed in 2.1.0.11 either

Edit 5: Still present in 2.1.3.7

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by ApB
close date 2018-06-01 20:20:42.173765

Comments

1

true. this happens some times.

User ( 2014-05-02 19:31:50 +0300 )edit
1

After finally having the right timing to hit the + button at 1 second sharp, I can confirm this bug (happened 2 out of 5 times in my case). Well observed!

molan ( 2014-05-03 00:55:39 +0300 )edit
2

With the 50% occurrence rate I'd guess it's a rounding problem: 00:00.995 -- 00:00.999 might be incorrectly rounded to 00:00.00 instead of 00:01.00, while 00:01.000 -- 00:01.004 is rounded to 00:01.00.

tmy ( 2014-05-03 08:43:29 +0300 )edit

Still happens after update 7.

tmy ( 2014-06-10 19:11:45 +0300 )edit

I repeated it with Sailfish X 2.1.3.7 by stopping one second sharp. Then time was displayed 0:00.00 instead of 00:01.00.

alloj ( 2017-12-28 17:21:03 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2018-06-01 19:59:10 +0300

tmy gravatar image

Fixed in 2.2.0.29!

edit flag offensive delete publish link more

Question tools

Follow
3 followers

Stats

Asked: 2014-05-02 19:21:39 +0300

Seen: 512 times

Last updated: Jun 01 '18