Ask / Submit
15

Airplane icon displayed on homescreen but mode not activated

asked 2014-07-14 22:57:58 +0200

ced117 gravatar image

updated 2014-11-24 11:42:50 +0200

jiit gravatar image

After the 1.0.8.19 update, the airplane icon is displayed on the homescreen instead of the network signal icon. Also, the airplane mode is "not" activated...

Any ideas ?

edit retag flag offensive close delete

Comments

Oddly enough, I have an always present bluetooth icon, even with bluetooth off since the update.

paulvt ( 2014-07-15 00:04:06 +0200 )edit
1

I have also airplane mode icon there, stays there after reboots and enabling and disablíng the mode.

stimpson ( 2014-07-15 01:05:28 +0200 )edit

Updated to the new version yesterday & I did not have the problem until today morning. After a reboot, the bluetooth icon shows up on the homescreen when it is deactivated.

chsailor ( 2014-07-15 09:03:23 +0200 )edit

The flight-mode-icon-always-displayed thing happened to me last week on 1.0.7.16. I was hoping that yesterday's 1.0.8.19 update would solve it, but it hasn't. https://together.jolla.com/question/50296/flight-mode-icon-always-displayed/

DrCheeseCake ( 2014-07-15 12:07:17 +0200 )edit

I have had the flight mode icon on the screen since one of the first versions of Sailfish. Every time I hope that update will fix it but no luck. Seemed too minor to report a bug but I would still be glad to get rid of it.

Lauri Laanemets ( 2014-07-15 15:47:15 +0200 )edit

2 Answers

Sort by » oldest newest most voted
9

answered 2015-01-21 12:06:13 +0200

dez gravatar image

updated 2015-01-21 16:11:41 +0200

Now the root cause of the issue is unknown because it is rare and we did not observe it yet ourselves, also journal provided by @ced117 did not help, there is no useful information there. If somebody who has this issue is living near Helsinki and can come to the Jolla office (Ruoholahti) we can try to investigate the issue and fix it. Otherwise the only way I see now to investigate the issue is to wait until we will create remote assistance application.

Update #1: So, according to comments, if some application or component leaves mce cellular flag state as offline it results in "Airplane mode" displayed. One who observes this issue, has "Developer mode" on and able to execute commands in Terminal can try to execute there mcetool --enable-radio=cellular and check does it solve the issue,

And we will just change responsible component to take the radio state from connman instead of mce. Hopefully it'll help.

edit flag offensive delete publish link more

Comments

2

My steps to reproduce, if it helps:

  1. Run from terminal on the phone: mcetool --disable-radio=cellular
  2. After this mcetool return that Cellular: disabled
  3. Icon on home screen sets to Airplane
  4. But calls worked and everything works with network

If set flight-mode from Settings,then everything works as it should. I have latetst Sailfish 1.1.1.27

zaharov.andrei ( 2015-01-21 12:23:47 +0200 )edit

@zaharovandrei Thank you for the hint!

@spiiroin maybe you can comment on it?

dez ( 2015-01-21 13:31:06 +0200 )edit
3

The radio control in mce is inherited from Nokia devices like N9 & N900 - which had daemons listening to notifications from mce and turning appropriate radios on/off.

The cellular / networking daemons used in Jolla phone do not utilize these signals, so nothing happens if they are toggled on/off via mcetool.

The only exception to this - at least for now - is the "master" radio toggle, which mirrors (reverse of) OfflineMode property from connman, i.e.

  • mcetool --disable-radio=master -> OfflineMode=true -> airplane icon shown
  • mcetool --enable-radio=master -> OfflineMode=false -> airplane icon not shown

Also the reverse is true: Toggling the airplane mode from settings changes what mcetool reports for the master radio state.

spiiroin ( 2015-01-21 13:49:33 +0200 )edit

It solves the issue ! I thought I could never resee the holy Trapezium ! Several months with the plane... But it is mcetool instead of mce-tool.

smartiz ( 2015-01-21 14:41:47 +0200 )edit

@smartiz corrected tool name

dez ( 2015-01-21 16:12:09 +0200 )edit
0

answered 2014-07-19 10:03:04 +0200

ced117 gravatar image

updated 2015-12-01 08:20:37 +0200

I did a factory reset, so far it seems to work as usual.

@NuklearFart Had this issue and found a way to solve it (aside from doing a factory reset...)

Open a terminal and do this:

devel-su 
pkcon install mce-tools
mcetool --enable-radio=cellular

And, voila... ! :-)

edit flag offensive delete publish link more

Comments

Same here. All fine so far.

DrCheeseCake ( 2014-07-19 23:30:33 +0200 )edit
2

I don't think factory reset is the right solution for a bug !

smartiz ( 2014-09-07 19:25:06 +0200 )edit

@smartiz maybe not the right solution, but it's working.

ced117 ( 2014-09-13 10:02:42 +0200 )edit
1

@smartiz This is definitely not the right solution for developers but in the mean time it can help users. The main issue is that this issue reproducibility is extremely low (afaik) and no clues was found in available logs :/

dez ( 2014-09-22 22:56:31 +0200 )edit

I understand. I still have the airplane. Sometimes I can't even switch to flight mode or leave the flight mode, I have to reboot. Sometimes ambiances are mixed (up to three): the glowing color of one ambiance, the main background image of another and the covers' background of a third ! Changing ambiance often fails or it mixes them. It seems that the UI is messed up. Perhaps a problem of disk space, I'll try a btrfs balance.

smartiz ( 2014-09-22 23:42:22 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2014-07-14 22:57:58 +0200

Seen: 856 times

Last updated: Dec 01 '15