Ask / Submit
14

[BUG] Connecting to wrong WLAN with known SSID

asked 2014-08-27 22:17:24 +0300

SaimenSays gravatar image

updated 2017-02-11 19:55:41 +0300

Alex gravatar image

Some days ago I had a problem with two WLANs having the same SSID. If you have an ordinary router e.g. "FritzBox" the SSID from all these routers are the same. But I only have the key to one router. So if I'm somewhere outside, in a range of same named SSID, Jolla tries to connect to it. Understandably it fails with wrong key.

Maybe it is possible first to additionally check the MAC-Address before trying to connect.

The thread "add multiple WLAN-/Wifi-Networks with same SSID covers the proble the other way round. However, this bug is a different one.

edit retag flag offensive close delete

Comments

Just checked and at least on my device mobile data keeps itself connected if the device can't authenticate to wlan which has wrong authentication key.

tigeli ( 2014-08-30 01:42:27 +0300 )edit

Link to a duplicate (to see more comments on this topic): https://together.jolla.com/question/57852/wlan-networks-with-same-names/. By the way, I completely agree with this request. This is a bug that needs to be fixed.

Neo ( 2014-10-06 20:16:13 +0300 )edit
1

@Neo how would you know which access points are part the original network or if it's password has just been changed?

tigeli ( 2014-10-06 20:31:47 +0300 )edit
1

Why not saving also MAC address to each connection? Like it is done in MAC filter of Router? In my opinion it is also a security risk, if Jolla connects to a fake SSID and exchanges data. I'm not a network expert and I also heard about MAC-Spoofing, but it would be one more barrier.

SaimenSays ( 2014-10-06 20:46:39 +0300 )edit
1

@tigeli To be more specific, I have 2 problems with this issue: 1. the time spent to try to connect to the wrong router is too long (maybe because it tries more than once?) and 2. why is this happening on the screen of the phone (could it not happen without interfering with the screen)?

Neo ( 2014-10-06 20:58:07 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-08-28 12:33:21 +0300

chemist gravatar image

updated 2014-08-29 11:54:22 +0300

Change your fritzbox's SSID to something unique and you won't have this problem any more. Also change the preset password when you are there anyway.

Update:

You have to report the bug to the admin of the router.

edit flag offensive delete publish link more

Comments

4

This is not an acceptable solution! I'm not responsible for this router. I only have a key to get internet access. So I can't change the SSID.

Also it is not ok to close this thread! Because the bug is present and needs to be fixed!

SaimenSays ( 2014-08-28 18:43:06 +0300 )edit
4

I feel with you. But this is something completely unrelated to your phone. If people or even a manufacturer are dumb enough to leave a not-so-unique SSID on a router or even ship a router with it all clients are screwed. Even with checking the MAC this would only work with deactivating AP-roaming. So what do you want us to do? (It is not a bug it is misconfiguration of the router)

chemist ( 2014-08-29 10:48:02 +0300 )edit
5

Yes, this is not a bug of the phone. If your password only works on one of the wlans, it should have its own ssid. You have to report the bug to the admin of the router. And you are probably not the only one to have this problem on this router.

vbregier ( 2014-08-29 11:44:05 +0300 )edit
6

I really can't agree you, it is a bug! If phone checks mac address it won't try to connect! OR it can try to connect. But then it should switch over when it is really connected to WLAN and not as long as it is in the inquiry.

And also have a look at the other "add multiple WLAN-/Wifi-Networks with same SSID". If it is possible to connect to different WLANs with the same ID, the problem will occur anytime in this constellation.

By the way, I'm even short before leaving Jolla. Non of the problems I recognized are solved in the in the last half year. I'm really disapointed about the whole thing. Right now I use on my old N900 because it works much better after all. And I'm not the only one, as it can be read all over this forum. So you can ignore anything, but then close this forum and don't probagate that it is an open comunity!

SaimenSays ( 2014-08-29 19:45:08 +0300 )edit
4

i have the same opinion like Saimen. "report the bug to the router admin" - lol? sorry that's not a solution Every goddamn other OS supports multiple WLAN configs with the same SSID or uses another connection if auth fails. Sailfish doesn't do one of those two solutions....

btw the response to bug reports here on jolla together is very disappointing. you get a satisfying response very rarely, sometimes a silly answer like this or nothing at all

nightmare ( 2014-08-29 21:26:31 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2014-08-27 22:17:24 +0300

Seen: 523 times

Last updated: Feb 11 '17