We have moved to a new Sailfish OS Forum. Please start new discussions there.

Delay in incoming sms message (occasional issue) [answered]

asked 2014-10-07 20:38:12 +0300

statler gravatar image

updated 2014-10-10 07:40:02 +0300

Since summer has there occasionally appeared a significant delay in receiving incoming sms's. It is impossible to notice when the phone is not receiving messages as mobile network usually shows rather good 4G (or somewhat ok 3G) and therefore I assume the phone is connected to network. Some indication could be the level of wlan connection: if the alan connection shows weak status even I am at home where full availability exists, it is likely that booting the phone will improve both wean connection and bring incoming sms's (if there are any).

When this occurs is impossible to say. It may be that the phone somehow loses capability to receive messages right after I've sent one. On other occasions the phone may have been lying on the table all by itself for a few hours.

I have once been in situation where the problem solved itself. I had sent a couple of sms's at around 6 pm. Wondered a little as no responses came by the time I went into bed. In the morning the phone showed there were 3 new sms's, all of them had been received a little after 1 am while I was asleep and all of them had been sent before 8.30 pm.

If there's been a delay, it is possible to see easily. In the sms list the phone shows the time of receipt of the sms. When the sms is opened, below the message the date states when it has been sent.

I have not been able to try if it is possible to call my phone while sms's are circling around somewhere and not getting in.

I have noticed the problem with version and also with the I occasionally use mms's but not on a daily basis, not even weekly. I've had the same operator for years without having these issues, which are pretty new.

Has anyone else noticed anything like this? Any ideas what could cause it, I would not exclude the user from the list of possible reasons...

EDIT 10.10.2014: After a few days using only 3G it looks like the problem has disappeared (or at least gotten a lot more rare, an improvement anyway). As @penpen suggested, the 4G as a network is not yet exactly perfect and trying not to be hip and hot and to use the latest technology does have a positive impact of incoming old-school messages. Thank you for help!

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by statler
close date 2014-10-10 07:43:07.925189


I sent one or two international SMS's and immediately received notification that it had been delivered. I suspect that the issue you are facing could be a problem with your cellular provider. The delays maybe because of network congestion. It can also be due to connectivity issues. Suggest you contact your cellular service provider and ask them about this.

sifartech ( 2014-10-07 20:42:05 +0300 )edit

True, the issue may lie behind the network operator as well. They usually say they find no reason for misbehaviour, of course, but better ask anyway.

The only thing suggesting this might be out of operators hands is that the problem has started months after I switched to Jolla. So sms's have worked just fine until recent weeks, perhaps a couple of months ago. Could and would an operator make such updates it could impact on this?

I am a lazy phone user and I tend to sms within my own country (Finland) only.

statler ( 2014-10-07 21:07:34 +0300 )edit

Since I don't face any such issue, I cannot be sure that your problem is related with the phone. Anyway, the problem will be either with your phone software OR your network. Since you have already started investigating this issue, by posting here for clarifications on whether this is a phone issue, I'd also advise you to contact your service provider and insist that there is some network issue and you would like clarification on when it would be fixed. To be doubly sure, you could maybe also try switching to an old Nokia for a week and see if you face the same issue.

sifartech ( 2014-10-07 22:26:48 +0300 )edit

This happens also to me: https://together.jolla.com/question/58395/cannot-receive-sms-messages-instantly/

The messages always appear immediately when I call to someone. Please note: I have NO problems when I use _the_same_ SIM card (Operator: DNA) in my Galaxy S2. It feels like some service is sleeping until I make a call and then immediately processes the arrived messages.

Harakiri ( 2014-10-09 22:12:11 +0300 )edit

Addition to my previous comment: after a successful receive, the subsequent messages are received immediately. The issue usually triggers when the device is unused for many hours e.g. over night and no calls are made.

Harakiri ( 2014-10-09 22:26:56 +0300 )edit

1 Answer

Sort by » oldest newest most voted

answered 2014-10-08 01:13:59 +0300

penpen gravatar image

I think there reason is the same than with voice calls: current 4G (LTE) technology doesn't support SMS messages so the phone and network need to switch to 2G/3G to actually deliver the SMS message and it is complex and error prone ("LTE is designed as a pure packet switched system. Legacy circuit switched services are no longer supported."). More background: https://together.jolla.com/question/47765/4g-lte-bug-cannot-receive-call-diverted-to-voicemail/?answer=48381#post-id-48381)

edit flag offensive delete publish link more



This implies the problem could be solved by avoiding 4G and using 3G instead? Fantastic, can (and will) do! I'll get back when more experienced and have some level of certainy whether this was rhe solution or not. :)

statler ( 2014-10-08 05:52:13 +0300 )edit

Yes, try with "Prefer 3G" or "2G Only" to see if it helps. We wait for your results :)

penpen ( 2014-10-08 20:51:04 +0300 )edit

In my case this is not about 4G since I'm on 3G (at least that's what the indicator says). Moreover, I usually don't receive the messages AT ALL until I make a call.

Harakiri ( 2014-10-10 09:26:56 +0300 )edit

Question tools



Asked: 2014-10-07 20:38:12 +0300

Seen: 791 times

Last updated: Oct 10 '14