Ask / Submit
6

Alien Dalvik, how to stop autostart? [answered]

asked 2014-10-24 20:47:46 +0200

Luca gravatar image

updated 2014-11-03 21:33:36 +0200

molan gravatar image

Hi all, sorry if this is an old question but I didn't find it.

As you know, Alien Dalvik tools always start at boot time even if I don't start android app.

I tried to disable the service with:

        systemctl stop aliendalvik.service
        systemctl disable aliendalvik.service

but next boot it start again...

Who is starting it...?

Thanks

Luca

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by molan
close date 2014-11-03 21:36:35.385173

2 Answers

Sort by » oldest newest most voted
10

answered 2014-10-25 03:05:08 +0200

updated 2014-10-25 03:09:28 +0200

First, make sure you have nano installed on your Jolla. If it isn’t there, install it with:

pkcon install nano

Complete disabling (prevent Android apps to start)

devel-su 
<password> 
systemctl stop aliendalvik.service 
systemctl mask aliendalvik.service

To re-enable it:

# systemctl unmask aliendalvik.service
# systemctl start aliendalvik.service

Disabling the Alien Dalvik at startup (it will start when you want to)

From the terminal:

devel-su
<password>
nano /etc/systemd/system/nodroidavvio.service

In nano paste:

[Unit]
After=aliendalvik.service
Description=No Android al riavvio

[Service]
Type=oneshot
RemainAfterExit=no
ExecStart=/bin/systemctl stop aliendalvik.service

[Install]
WantedBy=multi-user.target

Close and save by pressing CTRL+X and within the terminal prompt:

# systemctl enable nodroidavvio.service

To re-enable the Alien Dalvik at startup:

# systemctl disable nodroidavvio.service

thanks to @iliveinpublic and @eugenio_g7 for the tips.

edit flag offensive delete publish link more

Comments

1

Thanks, at the moment I "masked" the service. Next I'll try to stop it at start up.

PS. I use "vi" .. :)

Luca ( 2014-10-25 11:00:30 +0200 )edit

Apparently, the 2nd option "Disabling the Alien Dalvik at startup (it will start when you want to)" is working, except when lipstick is restarted (manually or automatically): AlienDalvik is then running again.

objectifnul ( 2015-03-19 11:24:17 +0200 )edit
2

answered 2014-10-24 21:55:35 +0200

chemist gravatar image

iirc aliendalvik.service is started by the dependency of display.service to aliendalvik.path

edit flag offensive delete publish link more

Comments

hi, what does the display service do? should it be possible to stop it?

Luca ( 2014-10-25 00:03:05 +0200 )edit

it seems to be the meta service for the UI (see for yourself systemctl list-dependencies display.service), so to speak, NO -> bad idea to disable it

chemist ( 2014-10-25 02:52:36 +0200 )edit

Question tools

Follow
4 followers

Stats

Asked: 2014-10-24 20:47:46 +0200

Seen: 1,265 times

Last updated: Nov 03 '14