Ask / Submit

[request] please fix browser based wifi log in!

asked 2014-10-27 21:12:36 +0300

midnightoil gravatar image

updated 2016-08-17 11:07:23 +0300

jiit gravatar image

This has gone on far too long, and is one of the reasons why traveling with the Jolla is such a pain in the behind. So many hotels use browser based wifi auth, and it practically never works on the Jolla. I can't imagine that this is the most difficult thing in the world to fix, and would improve the real world usability of the Jolla for almost anyone who travels.

p.s. I composed this in a hotel with browser based auth, and submitted this via 3g on my jolla ... meanwhile my backup sony z3c and my friend's iphone connected to hotel wifi with no problems. last 6 hotels i've been to like this, the jolla wouldn't play but other phones would. it's particularly bad as my experience with mobile data whilst roaming abroad has been very poor at times

edit retag flag offensive close delete


I have just returned from a business trip to Germany (from UK) during which my only mobile device was a Jolla 1. I have to say I had a nightmare trying to connect to wifi networks at various locations, especially airports where I just couldn't connect. It's very emabarrassing when colleagues are happily connected with their 'iDevices' and trying to send you booking details or boarding passes. Travelling can be stressfull enough, I just need to be on a level playing field with my colleagues. Perhaps I was niaive to travel with just my Jolla!?

shandon ( 2018-04-27 10:43:21 +0300 )edit

This still seems to be broken based on my travel this week. Basically were it not for the spare iPhone I carry for just this purpose, I would have been unable to access the internet. Global data roaming is not something I have :(

DrDweeb ( 2019-01-27 14:03:43 +0300 )edit

2 Answers

Sort by » oldest newest most voted

answered 2014-10-27 22:25:18 +0300

Sthocs gravatar image

Duplicate of, isn't it?

As you can see, it will be fixed in update 10. In the meantime, maybe the workaround I provided there works for you too? (trying to play with the Wifi settings so that the connection is detected by the Jolla)

edit flag offensive delete publish link more


not exactly, as in my experience browser never connects to anything. cause may well be the same. will try your method later

midnightoil ( 2014-10-27 22:27:59 +0300 )edit

tried your trick. doesn't work for me.

midnightoil ( 2014-10-28 09:12:17 +0300 )edit

Indeed, if your never have the chance to log-in in the browser, it won't help. As @tigeli, I don't remember having problems to display the login pages. Hope update 10 will make it work better for you.

Sthocs ( 2014-10-28 12:36:11 +0300 )edit

answered 2014-10-28 08:34:49 +0300

tigeli gravatar image

Browser should still work if you have connectivity even in ready-state.

The last 10 hotspots I have been using with Jolla (and also tried out iPad/iPhone and Nexus 7 for comparison) have been working just fine. Also in some airports where i-products have failed my Jolla has succeeded... but that does not help you.

I can't tell which version you have running on your Jolla but lots of hotspot-stuff has been fixed in u9 and more will be included in u10 as well. However if you are running u9 and still having problems I would need ConnMan logs to debug this problem...

edit flag offensive delete publish link more


1.08 ... not at home atm so don't want to risk 1.1 (will wait until i get home or stable). last and only time i remember browser based log in working was one instance during 1.06 ... was surprised as I had previously assumed there was simply no support for it

midnightoil ( 2014-10-28 09:05:45 +0300 )edit
Login/Signup to Answer

Question tools



Asked: 2014-10-27 21:12:36 +0300

Seen: 343 times

Last updated: Oct 28 '14