Ask / Submit
17

What android version Jolla is compatible with?

asked 2014-11-28 08:08:27 +0300

Kari gravatar image

updated 2014-11-28 09:26:47 +0300

I downloaded from google play Polar Flow App and it fails to install.

There is also another post about the Polar flow in here

I studied the Polar support pages and according to them the application requires Android version 4.3 or higher - Is that the reason for the failing installation?

What about in the future is our Alien-Dalvik virtual engine be able to provide support for higher android versions than now?

Is the Android version issue also related to the Linux kernel that we currently have in SF OS? Will the coming kernel update help Jolla phone to accept and run android apps higher than it can support know?

What android version Jolla is currently compatible with?

edit retag flag offensive close delete

5 Answers

Sort by » oldest newest most voted
10

answered 2014-11-28 12:59:28 +0300

rainisto gravatar image

Afaik Alien-Dalvik matches 4.1.2, so if your app requires 4.3 then your out of luck.

edit flag offensive delete publish link more

Comments

3

Any plans for Jolla to keep upgrading the Alien-Dalvik towards higher and newer native Android versions?

Kari ( 2014-11-28 16:48:42 +0300 )edit
4

Jolla1 is android adaptation is 4.1.2 based and its not going to be updated for Jolla1.

I cannot comment on future products like tablet yet.

rainisto ( 2014-11-28 16:56:19 +0300 )edit
17

is there a reason why Jolla won't update the android adaptation for Jolla1 !?!

sirzero1997 ( 2014-11-29 00:48:02 +0300 )edit

What does Android support mean!? For me it means, it should be updated as any other app on the phone. I didn't use frequently as right now nothing is frequently here!

megalith ( 2016-03-14 11:59:13 +0300 )edit
2

@rainisto since Galaxy S4 Mini (same SoC) supports Android 4.4 so as JollaTablet does, wouldn't it be easier for Jolla to get the phone at the same level (patches, fixes, features...)

lpr ( 2016-03-20 17:12:41 +0300 )edit
8

answered 2014-11-28 13:14:04 +0300

smoku gravatar image

updated 2014-11-28 13:15:44 +0300

It reports version 4.1.2.

[nemo@Jolla ~]$ grep 'version.release\|model' /opt/alien/system/build.prop 
ro.build.version.release=4.1.2
ro.product.model=Jolla
edit flag offensive delete publish link more
7

answered 2016-08-31 12:11:29 +0300

Painkiller gravatar image

So Jolla C supports 4.4.4, why isn't this updated for the original Jolla phone also?

edit flag offensive delete publish link more
4

answered 2016-07-23 19:15:25 +0300

JollaC supports Android version 4.4.4

[nemo@Sailfish ~]$ grep 'version.release\|model' /opt/alien/system/build.prop
ro.product.model=Jolla C
ro.build.version.release=4.4.4
ro.product.model=Jolla
edit flag offensive delete publish link more

Comments

Is this why many apps are missing? That were available on jolla1.

yani ( 2016-07-23 20:25:57 +0300 )edit
3

answered 2014-11-28 08:33:25 +0300

On Alien Dalvik, there seems to be another related post. https://together.jolla.com/question/10407/what-is-the-support-lifetime-for-the-included-myriad-alien-dalvik/

Android version would be handy to know.... https://together.jolla.com/question/38844/dalvik-vm-android-version-number-after-upgrading/

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
10 followers

Stats

Asked: 2014-11-28 08:08:27 +0300

Seen: 5,231 times

Last updated: Aug 31 '16