Ask / Submit
8

[bug] browser constantly opens for auth [answered]

asked 2015-01-30 17:02:41 +0200

misc11 gravatar image

updated 2015-03-04 20:33:48 +0200

at university i use a wlan that is unencrypted. authentication is done through a webinterface you get forwarded to when trying to surf without login. i have saved the network so my jolla would automatically connect, so when i want to surf i only have to enter name/pw not also connect to the wlan in settings.

so now when im not logged in but the wlan is in reach. the browser constantly opens loading the login page. this sometimes happens in a period of 3-5 seconds. browser would pop up and i have to wait a while until its responding so i can close or minimize it (same behavior for both). this almost makes my jolla unusable (i actually mean it!).

so, any ideas?

also: this wouldnt be such a problem if jolla would support eduroam ;)

Update: still present in sfos v1.1.2.16

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by misc11
close date 2015-03-05 19:31:47.545911

Comments

1

eduroam is supported! Not in the UI of course, but at least it works. (I don't quite understand why there's still no support in the UI, it seems like it wouldn't be that difficult to add.)

nthn ( 2015-01-30 22:37:31 +0200 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2015-03-05 00:22:37 +0200

tigeli gravatar image

Jolla will open the captive portal every 5mins until the online check succeeds. We might change the behavirour in the future that it will opened only once.

edit flag offensive delete publish link more

Comments

i know it should only open every 5mins for when its trying to check my emails but there are times when its opening in really short intervalls (like i said 3-5 second).

misc11 ( 2015-03-05 07:42:59 +0200 )edit
2

answered 2015-03-05 19:31:31 +0200

misc11 gravatar image

i just realised you can deselect the auto-connect in the known networks list. this makes its easy to get around this without deleting the network. sorry i keot this up so long but i never realised that until today :)

edit flag offensive delete publish link more

Comments

"Deselect auto-connect"? Can you spare some details, please? Nothing happens when I tap on the dot next to the known network name. A long tap opens a context menu with only one entry, "Forget network". There is also "Edit" but only when in the range of that network and it does not have an "auto-connect" option anyway (Sailfish 1.1.9.28).

Forgetting the network is only a temporary solution, until the next time I actually log in to it. Then I will have to go back to Settings and forget it again.

My take on this is that if the OS connects to a WiFi but cannot get past the captive portal, so be it. Opening a browser and logging in should be my conscious decision. I do not want my phone to open a browser in my pocket every time I stop to fill up my car.

pichlo ( 2015-09-29 16:42:25 +0200 )edit
1

@pichlo

trying it again, i also cant "deselect" it. it worked before, so there must have been a change there. anyway, it works with the network im connected at the moment (active connection is colored - inactive is white). tapping the active connection once will make it white and the dot on the left side is no longer glowing - this means it will no longer connect to this network, but its still remembered, and tapping it once will re-enable it again.

yes, thats not a perfect solution because whenever you want to use the network you have to enable the network again, but well thats the world of captive portals. (they suck!)

anyway @tigeli posted in march 2015 that they might change that behaviour. since youre posting now i guess they havent changed it, yet...

misc11 ( 2015-09-29 16:59:18 +0200 )edit

Question tools

Follow
1 follower

Stats

Asked: 2015-01-30 17:02:41 +0200

Seen: 176 times

Last updated: Mar 05 '15