Ask / Submit
127

[bug] Browser - touch position & link problems

asked 2014-01-03 11:31:03 +0200

huuhaa gravatar image

updated 2014-07-25 10:51:00 +0200

jiit gravatar image

There are still some problems with Sailfish 1.0.2.5 browser when handling links. (Edit: Problem #2 has become more apparent and disturbing with 1.0.8.19.)

  1. Sometimes (not so often anymore) links are not working unless you restart browser.

  2. There are also problems with detecting touch point. Quite oten when I'm at page http://lite.ampparit.com and click on news link, browser selects the link which is 1 row upper / downer from the point I clicked. Most of times it selects right one though.

  3. When clicking link, browser asks too easilly what I want to do (open in new tab). I have to swipe back and click again to open it without new tab. This happens way too often.

edit retag flag offensive close delete

Comments

Yes! This is very, very annoying bug. Fortunately you can install Firefox via Android appstore.

LaruX ( 2014-01-03 12:37:26 +0200 )edit
2

Another bug: browsing history matches wrong names to links.

torcida ( 2014-01-03 13:06:14 +0200 )edit
1

There seems to be also earlier post on this subject

https://together.jolla.com/question/1115/bug-sometimes-the-browser-gets-into-a-state-when-all-links-are-unclickable/

Kari ( 2014-01-04 23:58:39 +0200 )edit

This is very annoying and makes the browser next to unusable in many cases. To be fixed ASAP! This happens for example on together.jolla.com!

vbmithr ( 2014-01-07 10:51:57 +0200 )edit

really sucks

tronicum ( 2014-03-23 19:16:32 +0200 )edit

2 Answers

Sort by » oldest newest most voted
15

answered 2014-08-06 17:43:22 +0200

veskuh gravatar image

updated 2014-08-06 17:44:31 +0200

Thanks for reporting this.

The problem 1 we have had long time and there has been many root causes leading to same problematic behaviour, we have closed all the root causes we have figured out and lately this has been very rare problem.

In update 8 we changed the code that controls toolbar behaviour, unfortunately it looks like that due to that change sometimes touch gets off by significant amount and thus triggers wrong links. We have worked on this and the problem should be gone in next update. Workaround that sometimes works is to rotate the device to landscape and then back to portrait, alternatively restarting browser should fix the state.

The time it takes to intrepret touch as long tap should be same as with Silica controls. Would it feel better if we added "Open link" to context menu so that if you accidentally trigger context menu instead of clicking link you could then open the link from the menu?

edit flag offensive delete publish link more

Comments

Yes, I think "Follow link" is a worthy option - it would also help with the current position bug and small links. One can hold touch and if the link is the one he really wanted can click on the option.

icebox ( 2014-08-06 23:06:26 +0200 )edit
1

I would like to have some "zoom in box" when i click some link which is close to other link, just like android Google chrome and please. add feature - open link to backround. I don't like when it alwyas fallows the link to the new tab :/. So, just like the Webcat "Open in New Tab" works :)

Makeclick ( 2014-08-07 08:34:23 +0200 )edit

What about the "Problem no. 2" here in the list (touch point)...? That's verry annoying!

torcida ( 2014-08-20 15:26:07 +0200 )edit
1

@torcida I was a bit unclear in my answer. The part that starts "In update 8 .. " was about problem 2. So in short: problem 2 should be gone in next update.

veskuh ( 2014-08-20 17:45:27 +0200 )edit

Great, thank you! :)

torcida ( 2014-08-24 03:04:16 +0200 )edit
3

answered 2014-09-16 21:50:09 +0200

kaljollak gravatar image

Unfortunately the “problem no.2” is still there, I have the Tahkalampi version and clicking the link/or field is setting browser frame offset. And then it seems that browser freeze...

edit flag offensive delete publish link more

Comments

2

Yes, no. 2 is still here, and @veskuh above saying "We have worked on this and the problem should be gone in next update" is referring to problem no. 2 and update 9, which should be coming in a few weeks. So they have fixed it, but it's not released yet.

Also, this is not an answer but a comment...

ssahla ( 2014-09-16 22:11:45 +0200 )edit

It's now few monts, instead of weeks, gone, and the issue is still there. Any updates?

AnaT ( 2014-12-14 20:39:40 +0200 )edit

@AnaT, this bug is fixed in update 9 (the opt-in update), so all users should get the fix once they get update 10 out.

ssahla ( 2014-12-14 21:03:37 +0200 )edit

I still have this issue in Vaarainjärvi. Most prominently in planets.nu page after entering into game (planets.nu is web version of the old vga planets game)

Celar ( 2015-01-29 16:33:33 +0200 )edit
Login/Signup to Answer

Question tools

Follow
12 followers

Stats

Asked: 2014-01-03 11:31:03 +0200

Seen: 1,241 times

Last updated: Sep 16 '14