Ask / Submit
58

Automatically connect to (known) wifi networks

asked 2014-01-04 21:53:03 +0300

martti gravatar image

updated 2015-01-14 12:36:26 +0300

eric gravatar image

It appears the device does not automatically connect to known wifi networks when they come within reach (e.g., when you get home) until it is woken up by double tapping the screen (no need to actually unlock, though).

edit retag flag offensive close delete

Comments

4

Isn't it a feature that it doesn't waste battery trying to find the right network until you actually use it? AFAIK switching between networks can be very costly battery-wise. I believe there is a setting where you can choose only to sync on WLAN.

Tanghus ( 2014-01-04 22:19:30 +0300 )edit
1

Why it should connect before you wake the device up? I don´t see a point connecting if the device is idle and doing only some email syncing. My previous phone worked same way, connected only when you were actually using it, and disconnected when screen lock.

finadeon ( 2014-01-04 22:35:14 +0300 )edit
9

I'm not on a data plan, so if the wifi is not connected I cannot receive IMs, emails, etc. I can understand why someone (e.g., both above commenters) would like to keep it off until the device is used, but would like to at least see it as an optional setting.

martti ( 2014-01-04 22:41:00 +0300 )edit
4

I also find this feature very useful. For example on n9 it's called background connections. Phone should switch from mobile data to WLAN as soon as known network can be reached.

lomo ( 2014-01-04 22:48:09 +0300 )edit

That is weird. The functionality described works for me. When I activate WIFI and Mobile networking the data connection switches between the two connections automatically. I only have setup my home WIFI hotspot but this works perfect.

barmeier ( 2014-01-04 23:51:57 +0300 )edit

2 Answers

Sort by » oldest newest most voted
7

answered 2014-02-17 22:27:13 +0300

llornkcor gravatar image

It is not a feature, but a bug that it does this, and will be fixed in a future update.

edit flag offensive delete publish link more

Comments

email sync depends it? I'm find email sync not work as expected

norguhtar ( 2014-02-18 08:51:22 +0300 )edit

Yes I think it is related to this problem https://together.jolla.com/question/500/bug-e-mail-synchronization-does-not-work-as-configured/

Neo ( 2014-02-18 13:49:50 +0300 )edit

Any ETA when this behaviour will be fixed or made as an option like on N9?

Nekron ( 2014-05-31 14:39:27 +0300 )edit
2

answered 2014-08-08 18:37:42 +0300

MarcG gravatar image

Whit the latest version 1.0.8.19 of Sailfish, there is a major avolution in the connection with WIFI or mobil network. But there are still problems. When I use my phone on my bicycle and I chose for mobile connection, the phone continue to ask for the wifi where he find a wifi connection. I suggest that he only need to connect with wifi when there is a known connection (with known password) Ore waiting longer before asking for a another connection?

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
7 followers

Stats

Asked: 2014-01-04 21:53:03 +0300

Seen: 651 times

Last updated: Aug 08 '14