Ask / Submit
9

MS Exchange and IMEI on SailfishOS 2.0

asked 2015-09-10 13:13:12 +0200

SlOrbA gravatar image

updated 2015-09-10 20:33:47 +0200

Is there change in Device id between SailfishOS 1.0 and 2.0? If there is what Device id will be used in future?

I understand that on the Tablet the IMEI as Device id is not feasible, but it feels like IMEI is not used on the Phone eighter. If so there is change in Device id and that change then effects on Exchange syncing as Exchange sees SailfishOS 2.0 phone as new device which needs also new permissions. The feeling comes from the fact that the minute Jolla Phone booted up as SailfishOS 2.0 installation the Exchange sync I'm using stopped working.

edit retag flag offensive close delete

Comments

Well, i actually bricked and factory-reseted my phone because of stupid me, so I recreated my Exchange account, and can't tell if you're right. I'll check that tomorrow and will let you know.

Direc ( 2015-09-10 17:19:36 +0200 )edit
4

I'm having the same issue. Syncing stopped working after updating and recreating account doesn't work anymore.

thaikone ( 2015-09-10 20:39:11 +0200 )edit

Same problem here. I set pin code and device lock code but I cannot add the account again. It has been working all the time with Jolla but now with 1.1.9.28 it stopped syncing. Strange.

Alexander ( 2015-09-14 10:28:17 +0200 )edit

Please also check that automatic time update is enabled. Clock skew could also explain that.

Other thing that could explain that behavior is poorly installed certificates. I had that issue once. Can you post the output of the following command here? Developer mode and terminal required, of course:
curl -kIv1 https://exchange.server.here.com

Direc ( 2015-09-14 19:17:14 +0200 )edit
1

I get the following with server identifications redacted.

  • Rebuilt URL to: https://exhange.server.here.com/
  • Trying 192.0.2.1...
  • Connected to exhange.server.here.com (192.0.2.1) port 443 (#0)
  • ALPN, offering http71.1
  • Cipher selection: ALL: !EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
  • successfully set certificate verify locations:
  • CAfile: /etc/pki/tls/certs/ca-bundle.crt CApath: none
  • TLSv1.2, TLS Unknown, Unknown (22):
  • TLSv1.2, TLS handshake, Client hello (1):
  • Unknown SSL protocol error in connection to exchange.server.here.com:443
  • Closing connection 0 curl: (35) Unknown SSL protocol error in connection to exchange.server.here.com:443
SlOrbA ( 2015-09-15 08:58:30 +0200 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2015-09-12 13:12:29 +0200

Direc gravatar image

I have my Jolla w/1.1.9.28 connected to my company Office 365, and I can confirm that the correct IMEI is reported to the server, and device identification number is "JP" and IMEI code (for example, let IMEI be 358123456789, then device ID is JP358123456789).

(Intrestingly; the info page tells me that my device operation system is "SailfishOS 1.0" and user agent is "SailfishOS/1.0-EAS-0.8.17" which should have been bumped to 2.0 by now, but I'll create new question for that. Also, it seems the Jolla phone has a model number: JP1301! Didn't know that!)

I have no idea about tablet ID number, but I'd guess it contains the serial number of the device...

What it comes to being not able to add Exchange account - especially company accounts - please check that PIN code and device lock code are both enabled, as company policy may prevent from letting such unprotected device connect.

edit flag offensive delete publish link more
2

answered 2015-10-13 11:50:41 +0200

tigeli gravatar image

A guess: the most secure protocol your server support is SSLv3? With 1.1.9.x the SSLv3 is not being supported anymore by default as it is insecure and outdated protocol. You/server administrator should allow TLSv1+ protocols to be used.

edit flag offensive delete publish link more

Comments

Unfortunately, I don't have a luck with TLS v1.0 (server have no support of TLS v1.1 or v1.2). User agent is SailfishOS/1.0-EAS-0.8.15, when I had last successful connection with company server before I upadated to 1.1.9.28.

PetrK ( 2015-10-29 12:17:13 +0200 )edit
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2015-09-10 13:13:12 +0200

Seen: 943 times

Last updated: Oct 13 '15