Ask / Submit
19

[Bug] 1.1.9.28 Alarm does not ring if phone is turned off [released]

asked 2015-09-10 13:42:14 +0200

rferrazz gravatar image

updated 2016-02-20 13:23:23 +0200

chemist gravatar image

Today i'm late to work because the alarm of my Jolla did not emit any sound. It seems that it does not ring when the phone is off.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by Holger
close date 2016-02-19 11:15:01.572533

Comments

Thank everyone for the feedback it does not even start when the phone is in silent mode. But for me it does not emit any sound when the music volume is 0 (i've tested it with a song from my collection, not with a ringtone)

rferrazz ( 2015-09-10 15:14:28 +0200 )edit

it seems that the alarm does not start when the phone is turned off and charging, can someone confirm that?

rferrazz ( 2015-09-16 08:04:45 +0200 )edit

I experienced that too, luckily I have flex working time..

JollaJulle ( 2015-09-16 08:46:48 +0200 )edit

On both charging and battery, when the phone is off there is no sound for the alarm. I didn't touch any settings or ambiences before testing. I just woke up with the same settings today, except that the phone was on.

Albeit I have seen such silent alarms once that the phone was on too, but a reboot solved that.

Alen ( 2015-09-16 10:11:00 +0200 )edit

6 Answers

Sort by » oldest newest most voted
6

answered 2015-09-16 11:26:55 +0200

Edz gravatar image

updated 2015-09-16 11:32:52 +0200

@jiit - Tested with my own ambience (Ambience-AllBlack) and tested with The First One ambience.

Works as it should with my own ambience, the alarm tone is Jolla's standard alarm.wav. The phone woke up 1 minute before the alarm was due to sound and on expiry of that minute, the alarm sounded at full volume and showed the alarm UI - 100% working.

A slightly different story with The First One ambience (of which all tones are .mp3 not .wav). The phone woke up 1 minute before the alarm was due to sound. Then the alarm UI was triggered but I did not hear any sound at all - not working.

My guess now is, the phone cannot play any .mp3 tones when the alarm is used this way, but .wav seems to work just fine. So, I set the standard Jolla alarm.wav within The First One ambience settings and waited. Sure enough, the phone wakes, then the alarm sounded as it should - 100% working.

So it appears that it is the file type that is chosen for the alarm that is the problem - it must be .wav not .mp3 - why I wonder?

(All tones for me are on the device, not the sdcard).

edit flag offensive delete publish link more

Comments

Same problem. I noticed when checking the sounds as quickly as possible after start up that the clock tone setting was 'no sound' (or similar) with the mp3 alarm tone appearing in a few seconds.

Having replaced the mp3 with a wav it now works. The file is installed on the phone's memory.

thepeckhambassplayer ( 2015-09-29 22:52:19 +0200 )edit
3

answered 2015-09-16 08:50:34 +0200

JollaJulle gravatar image

Alarm works perfectly if phone is not turned off, but when you turn phone off there is no sound in alarm. Phone wakes up correctly and shows alarm on screen but sound is missing. Ambiance setting was the same in both cases.

edit flag offensive delete publish link more
1

answered 2015-09-10 14:34:48 +0200

naytsyrhc gravatar image

I just tested that and can't reproduce it. I set an alarm for 13:30 and turned off the phone. At 13:30 the alarm was triggered.

Is it possible, that you turned the phone to some silent mode? As far as I read and understood the release notes I have the impression that it is now possible to totally silent the phone (even the alarm), which was not possible in SFOS1. Maybe someone at Jolla can clear things up on that.

But as an answer to your question I'd say it's maybe not a "real" bug, as it does confirmably work on at least my device. Maybe something else went wrong on yours.

Are there others out there willing to test that?

edit flag offensive delete publish link more

Comments

2

Hei,

I just tested it and I can confirm that it indeed does not sound. Nor does it vibrate. However; the alarm definitely goes off. Silently.

I am using my own Ambience with own ringtones.

LVPVS over.

LVPVS ( 2015-09-10 14:48:41 +0200 )edit

So this confirms that it is somehow possible to totally silent the phone now. Nice feature but of course "dangerous" if activated accidently ;-)

naytsyrhc ( 2015-09-10 14:51:04 +0200 )edit

My "First One" Ambience is the same. Silent as death while phone is off. LVPVS over.

LVPVS ( 2015-09-10 14:57:29 +0200 )edit

I checked it again with the both the volumes cranked totally up. The result is still the same. LVPVS over.

LVPVS ( 2015-09-10 15:08:13 +0200 )edit
3

And did you try an ambience where alarm tone is set to specific sound with action? The release notes state that now ambiences only change sounds if set so with action. Thus a silent ambience setting the alarm to no sound would turn off alarm and if the other ambience does not have an action for setting sound for alarm, switching back to this ambience would cause the alarm to still be without sound.

naytsyrhc ( 2015-09-10 16:10:25 +0200 )edit
1

answered 2016-02-19 11:13:26 +0200

Holger gravatar image

This has been dealed with in 2.0.0. So closing this question.

edit flag offensive delete publish link more
0

answered 2015-09-16 10:44:37 +0200

jiit gravatar image

updated 2015-09-16 11:31:30 +0200

rferrazz gravatar image

Can someone who reproduced this issue provide the following?:

  • Which ambiance?
  • What is the volume level on that ambience?
  • What is the ringtone volume?
  • Is there a ringtone defined for alarm? If so, is it a custom one or the default ringtone?
  • If custom, did you hear that custom one or the default ring tone when alarm went off (in case you hear a ringtone at some point)
  • Is it a recurring alarm, or is it set for one-time only?
  • What is your sound settings under Settings>Sounds and Feedback?

Thanks!

edit flag offensive delete publish link more

Comments

1
  • Custom ambiance
  • Max volume
  • Max ringtone volume
  • Alarm ringtone picked up from my music collection
  • when the phone is on i hear the right song
  • It is a recurring alarm (every day except sat and sun)
  • Ringtone to the max, alarm tone is a custom song, system sounds off, touch screen tones off, touch screen vibration on.
rferrazz ( 2015-09-16 11:07:35 +0200 )edit

Is the music collection on the device or on sd card?

Pekka Vuorela ( 2015-09-16 11:30:05 +0200 )edit

mine is on the device, i don't have an sd card right now

rferrazz ( 2015-09-16 11:32:19 +0200 )edit

@Pekka Vuorela - for me; all tones are on the device, NOT SD card.

Edz ( 2015-09-16 11:32:27 +0200 )edit
1

I think I've found the reason. I tried many different conditions with both custom/default ambiences, both custom/default alarm ringtones, both one-time/repeating alarms. I concluded that the alarm will ring only with default alarm ringtone no matter with a custom ambience or a default one, starred or non-starred.

It seems the phone can't play a custom sound when it's off even if the file is on the same root folder as the default sounds.

Alen ( 2015-09-16 13:21:29 +0200 )edit
0

answered 2015-09-17 13:00:25 +0200

JollaJulle gravatar image

Seems that alarms with new ambiances work but not with older TOH ambiances. All TOH:s you might have are crippled beacuse phone does not anymore function properly with them. Really poor testing , too much focus on tablet design..shame on you Jolla.

edit flag offensive delete publish link more

Question tools

Follow
7 followers

Stats

Asked: 2015-09-10 13:42:14 +0200

Seen: 997 times

Last updated: Feb 19 '16