Jolla and FastMail: two-way carddav sync?

asked 2015-10-21 23:48:35 +0200

Igor_Diminich gravatar image

updated 2015-10-21 23:49:07 +0200

My Jolla is connected to my FastMail's address book, but it only syncs FROM FastMail TO Jolla.

Any suggestions?

edit retag flag offensive close delete

Comments

If you can send me logs, I can investigate. The usual steps apply (requires developer-mode / ssh):

1) ensure /etc/systemd/journald.conf has RateLimitBurst=5000 and RateLimitInterval=10s then reboot device if you had to change those

2) restart sync daemon with extra debugging enabled:

 systemctl --user stop msyncd
 MSYNCD_LOGGING_LEVEL=8 devel-su -p msyncd

3) leave that running, open a new ssh terminal to collect logs:

 devel-su journalctl -af | grep carddav

4) trigger a sync via Settings | Accounts -> Longpress CardDAV account -> Sync.

Then send the logs (after redacting any personal information) from the second (journalctl) terminal to chris dot adams at jolla dot com and I will investigate what is happening in your case.

Thanks! Chris.

chris.adams ( 2015-10-22 10:04:20 +0200 )edit

@Igor_Diminich: Can you share what settings you used with Jolla to sync with fastmail's CardDav? I played guessing for a while with CalDAV and finally got it working, but haven't had any luck with CardDAV.

WhyNotHugo ( 2015-12-03 12:06:27 +0200 )edit

Is there a solution for this problem yet?

BonoNL ( 2016-08-21 16:53:39 +0200 )edit

If someone is willing to provide me with logs (steps described above, requires developer mode) I can investigate further - email them to chris dot adams at jolla dot com please. (If someone already has, and I didn't respond, please send them again - I may have somehow lost that data.)

chris.adams ( 2016-08-22 13:46:47 +0200 )edit

If I can get it to work :)

BonoNL ( 2016-08-22 23:53:15 +0200 )edit