Ask / Submit
60

[BUG] [Android messaging] Whatsapp messages arrive late

asked 2015-11-22 10:34:30 +0300

ex'ratt gravatar image

updated 2016-05-29 21:14:56 +0300

palikao gravatar image

I use the official WhatsApp client and all in all it works. Sometimes though, messages arrive not immediately, but up to half a day after they were send. That mostly happens when the message was send in the evening. It arrives the next morning after I leave the house. Sometimes the delay is few hours or minutes and sometimes it works as it should. Maybe Sailfish OS disconnects the data connection (WiFi/G3 etc) when it is not used and therefore cannot receive new messages? At least that is the only explanation I can come up with. Does anybody else experience this issue? Or is there anything in the preferences that I need to change?

Edit: I forgot to mention that I can force the messages to arrive by sending a message myself. If there are pending messages that haven't arrived yet and I send a message to someone (forcing WhatsApp to connect), then I will receive the pending messages right after I sent the message. Well, at least it happend this way some times. I cannot reliably test it, as I would have to know whether there are messages that haven't arrived yet.

edit retag flag offensive close delete

Comments

6

Happens to me sometimes as well. The issue is yet to be identified.

Mr.Pancake ( 2015-11-22 10:49:59 +0300 )edit

From my viewpoint it's related to this question: https://together.jolla.com/question/122595/my-jolla-have-intermittent-loss-of-connection-data-and-i-have-no-ideas/

I know, the question sounds idiotic, but may be answered by random tries: can you check if any other internet action (i. E. getting mails) is possible or not during the period when WA-messages are NOT receivable?

Robomike ( 2015-11-22 11:53:56 +0300 )edit

I can't identify these periods, as I usually do not know whether someone sent me a message. But I did not have any internet or connection problems - usually I check the whether forecast in the morning, which works, and some time later pending messages arrive. So my problem may be related, but isn't as bad as yours, as only WhatsApp seems to be affected by it.

ex'ratt ( 2015-11-22 12:21:32 +0300 )edit
3

My problem is near to yours. I run also the official WhatsApp client. My client is shown as running at the home screen but didn't receive any messages after an unspecific time. Sometimes, if I let it run as it is, WhatsApp receive messages hours or days after, sometimes not. So I frequently quit and restart WhatsApp to hold it active.

pema ( 2015-11-22 18:27:50 +0300 )edit
3

Im using WhatsApp ver 2.12.347. Same problem im getting. If i didn't get msgs, i need to reopen the app so that im getting plenty of messages at once. im waiting for WhatsApp Native Client.

Prakaash T ( 2015-11-23 05:25:16 +0300 )edit

7 Answers

Sort by » oldest newest most voted
16

answered 2015-12-26 15:11:45 +0300

palikao gravatar image

updated 2017-04-13 18:33:44 +0300

I was just looking for someone else who had the same problem.. Fortunately I'm not alone: the same.. WhatsApp doesn't (I don't know if "can't") receive messages constantly.. But.. many times I need to open it, or refresh contacts, or write a message just to "wake up" it..

I've noticed that it happens when switching between nets, mainly.. But.. It has begun from the latest versions.. like.. 2.12.380.. I suspect something related to the Android layer..

  • update (26-12-2015): I've tried using only 3G connection (parameters: Mobile Data ON, WLAN OFF), logging out from all WhatsApp web computers, and.. Messages arrive.. So.. I think it is a system problem towards some kind of recent Wi-Fis, related to the way they (System and those kind of recent Wi-Fis) communicate. Previosly I had another kind of Wi-Fi, older (at least 6 years), and I had no problems.. Emails (on stock app) arrive correctly.. (parameters: Mobile Data ON, WLAN ON) -> Jolla connects to the 2,4 GHz WiFi with 6 Mbit/s tx rate, always

  • When Jolla is plugged to the power network, notifications seem ok, messages arrive (parameters: Mobile Data ON, WLAN ON) -> Jolla connects to the 2,4 GHz WiFi with 6 Mbit/s tx rate, always

  • update (27-12-2015): no message during all the night (8-9 hours).. only opening WhatsApp messages arrived.. The same after 15 mins idle.. (parameters: Mobile Data ON, WLAN ON) -> Jolla connects to the 2,4 GHz WiFi with 6 Mbit/s tx rate, always

  • no message again when idle with only WLAN on, and only opening WhatsApp message arrive.. (parameters: Mobile Data OFF, WLAN ON) -> Jolla connects to the 2,4 GHz WiFi with 6 Mbit/s tx rate, always

  • update (01-01-2016): I've crossed this issue with some news about some kind of new WiFi.. And.. I've found that we're not alone.. On my "problematic" WiFi, WindowsPhones are not affected.. here the link of the problem: https://productforums.google.com/forum/m/#!category-topic/nexus/connecting-to-networks-and-devices/fslYqYrULto

My opinion (not technical) is that SailfishOS is ok with those parameters, but not the Android layer.. It seems that, with some WiFis, the Android layer doesn't receive the input or the needed data to get information, or to wake up.. It seems that the input signal on WLAN is "not enought" to receive messages on the Android layer when idle, or that the System doesn't "wake up" the Android layer properly..

It's like a "refreshing"/"switching"/"communicating" problem.. So.. Kind of compatibility problem, to be solved both SailfishOS side and WiFis side.

  • update (feb-2016): it seems that our live status (online/offline) appears always "online" to others.. Also when idle or closed. It becomes "offline" only when Android layer is stopped. So.. Messages arrive late cause that latency (communication for connection) problem when idle BUT our active status is always "online".. Crazy! It seems like outgoing data/signals are always on and incoming data/signals doesn't arrive.

  • update (apr-2016): WhatsApp calls are definitely worse on those kind of WiFis than on 3G/4G.. And that is crazy again, because those kind of WiFis are connected to a very fast net.

  • update (may-2016): v2.0.1.11 doesn't fix this issue.. Always the same behavior

  • update (late may-2016): it seems, refering to update (feb-2016), that the always-online-status appears when on 3G. So, when on WiFi, WhatsApp would work correctly about status (not always online) but doesn receive messages, while on 3G it receive messages instantly, but shows always online-status. I'm continuing thinking about a communication problem between Alien Dalvik and Network settings.

  • update (jan-2017): it's getting worse and worse!!! Now WhatsApp stops receiving notifications after some mins also on 3G/4G! Uhm.. Deep sleep function is not useful, sorry..

EDIT 2016-10: not yet solved (Sleep mode or Android bug) in 2.0.4

EDIT 2017-02: worse and worse (Deep Sleep mode) in 2.0.5

EDIT 2017-04: not yet solved (Deep Sleep mode) in 2.1.0.11

edit flag offensive delete publish link more

Comments

1

Hi, thanks for that test. Please keep us updated on whether it works reliably in the next weeks, only to make sure it's not just luck. For me it is kind of random whether messages arrive late or immediate, sometimes it just works even when I'm at home (using WiFi).

ex'ratt ( 2015-12-26 15:51:41 +0300 )edit
1

Now we have two Jolla phones at home. The first Jolla was not with SFOS 2.0 and here we have the trouble with WhatsApp. The second one was delivered with SFOS 2.0 and there are no problems with the messages by WhatsApp. We are using WhatsApp and BBM as messaging app(s) on the phones. With BBM there are no such problems on booth phones. To communicate with the web we are using WiFi connection, no mobile data. I think there is a problem with the WiFi power saving feature. See also these post by raketti

pema ( 2015-12-26 21:03:32 +0300 )edit

Uhm.. But that feature is not settable.. And.. With my previous WiFi (older) all was ok..

palikao ( 2015-12-26 22:38:08 +0300 )edit

Hi, im the author of this thread https://together.jolla.com/question/122595/my-jolla-have-intermittent-loss-of-connection-data-and-i-have-no-ideas/

Thank you for the test but this is a bug of 1.9 and 2.0 with björnträsket runs fine at least at this times... hope that someone in jolla read this and fix this annoying bug.

strobovalo ( 2015-12-28 23:24:08 +0300 )edit
1

Few days ago I turned of the WiFi connection of my phone. Today I received a message two hours later (and only because I opened up WhatsApp to write a message). Seems like this work-around isn't working for me, unfortunately.

ex'ratt ( 2015-12-30 21:41:04 +0300 )edit
4

answered 2016-05-07 16:33:27 +0300

facePlanted gravatar image

updated 2016-05-07 16:33:47 +0300

Same here, running latest Sailfish OS version and Whatsapp 2.16.54, incoming messages are delayed and I need to send a message to wake it up or close and reopen it.

Are there any fix ?

It looks like this issue is 7 months old, Whatsapp is a killer feature for me and my gf, otherwise we can't be _together_ ;)

edit flag offensive delete publish link more

Comments

I do a refresh under contacts. At least it's faster than close/reopen.

shining ( 2016-05-07 18:28:11 +0300 )edit

Hi there, good to know.

Forgot to mention, unrelated, but from today my Whatsapp CHATS page displays just the phone numbers, not the actual name in my address book.

Tried to restart Whatsapp, same.

Tried to refresh Whatsapp's contacts, same.

Tried to reboot the phone, got 'No network available' for 5 minutes, closes and opened Whatsapp 10 times, pressed the Connect to Internet -> Mobile data button 10 times, opened the 'Browser' app and it worked at first shot.

Closed and reopened Whatsapp again, same problem.

Closed and reopened Whatsapp again, it worked.

<rant>This is low priority, not that it looks like the devs here showed any interest in fixing the major (mainstream) messaging software on the planet's connectivity problems.</rant>

Sorry for the rant but while I have backed the Jolla phone on Kickstarter back in the day, I was never able to use it as my daily driver, nor backup phone.

I come from 2 years of Galaxy S4 and never had this problems with Whatsapp, happy user but it got stolen from me.

Again sorry for the rant but to me this means the difference between using an app which is advertised as working, and paying 3-400 euros to get a new phone, while the Jolla will be back to collect dust.

I also think that few blog posts which came up when googling 'jolla whatsapp' like this:

http://www.jollausers.com/2015/03/a-new-whatsapp-client-called-whastup-too-hit-sailfish-os-soon/

and this:

http://www.jollausers.com/2014/03/mitakuuluu-the-sailfish-whatsapp-client-got-a-major-update-line/

and the various stores, should be updated to reflect the current status of the app (Whatsapp on Jolla works but can't be trusted in real-time messaging usage) ... using Large Fonts.

This is about respect: I did my research and was given the impression that Whatsapp on the Jolla works ok.

I've cleaned my Jolla from dust, updated it, updated the apps, installed Whatsapp, used it for days until understanding that something was wrong.

Thank you.

facePlanted ( 2016-05-07 19:24:10 +0300 )edit
3

answered 2015-11-23 10:28:39 +0300

Am gravatar image

Sorry if this has already been mentioned but I used the following and whatsapp woks fine for me

https://jolla.zendesk.com/hc/en-us/articles/203442828-Setting-up-WhatsApp-for-Android-on-your-Jolla-device

edit flag offensive delete publish link more

Comments

That's what I did when I started to use WhatsApp - except the Zedge and ringtone stuff, because I use Android notifications instead. Thanks nevertheless :)

ex'ratt ( 2015-11-24 18:30:27 +0300 )edit
3

I have done my setting with these tutorial but my problem is not gone.

pema ( 2015-11-28 14:54:28 +0300 )edit
1

Sorry, but it's not the same matter :) those are settings for the app.. Here we are dealing with a problem of communication/connection..

palikao ( 2016-03-09 00:41:13 +0300 )edit
2

answered 2016-01-17 14:12:08 +0300

groxxorg gravatar image

I had the same issue. Almost all Android-Apps had problems on startup or were crashing. Some messengers didn't deliver messages for hours/days. For a while I managed this by constantly restarting Whatsapp etc. but then the situation became more problematical; all the Android-Apps didn't start anymore.

In short: First Android-Apps became buggy, later they didn't even start.

I solved the problem by reinstalling Android-Support. Like mentioned here, I installed schturman's Dalvik Cleanup and reinstalled Android-Support from Jolla-Store. This solved the problem for me. You have to have in mind, that all your data stored under ~/.android will be lost. If needed, you need to copy your pictures etc. manually before reinstalling Android-Support.

In my opinion, there is a problem with the cache but I can not explain in more detail.

edit flag offensive delete publish link more
1

answered 2016-01-03 15:12:34 +0300

amadeusxnet gravatar image

Okay guys, I haven't seen this post before I got a comment on my thread:

https://together.jolla.com/question/125683/bug-alien-dalvik-wi-fi-3g/

I closed it as a duplicate and I'm now linking the missing story here for you. For me it's Facebook Messenger who's messing it up. But for you it's Whatsapp.

edit flag offensive delete publish link more
1

answered 2016-06-01 01:29:02 +0300

Federico gravatar image

After reading palikao's answer with lots of testing and troubleshooting ideas, I tried adding a systemd service that pings a given host every 4 minutes to prevent the connection from going to sleep, and it seems to help: Whatsapp messages seem more timely (but that may only be placebo effect / confirmation bias).

Steps to follow: as root (devel-su), create the following files:

/etc/systemd/system/timedping.timer:

[Unit]
Description=runs every four minutes

[Timer]
OnCalendar=*:0/4 

[Install]
WantedBy=timers.target

/etc/systemd/system/timedping.service:

[Unit]
Description=sends a ping every 4 minutes

[Service]
ExecStart=/bin/ping -c 1 8.8.8.8

Enable the service with systemctl enable timedping.timer (still as root).

Warning: 8.8.8.8 is a google server. You may not want to let them know your IP address every four minutes; replace with a server of your choice.

Let me know if this works for you!

edit flag offensive delete publish link more

Comments

Did a similar config with cron months ago (because I'm not familiar with systemd): calling a script every 5 minutes, pinging my own server once and switching the pings answer to the LED via this MCE thing, so I can see that either network is lost or my server is down; but haven't noticed any effect to the WA messaging bug. I still found some messages arriving only after network changes from WLan to mobile or vice versa, although I could proof that the device has been online all the time.

Robomike ( 2016-06-01 14:41:37 +0300 )edit

@Federico Thank you! I will try! But I can't understand why android layer is ok on 3G/4G and not on some kind of WiFi! What changes?

palikao ( 2016-06-02 11:19:12 +0300 )edit

@palikao if it is really timeout-related, I guess that the timeout settings are different for the two networks.

Federico ( 2016-06-02 11:22:11 +0300 )edit

This seemed to help at first, but after some testing it seems that it doesn't solve the problem. :( I have installed an Android app that should send pings regularly (Website Monitor), to test if it changes if the pings start inside the Dalvik stack. Apparently, the pings don't start, which is strange. This seems to indicate that the problem is with Android background services more than with the network. Strange.

Federico ( 2016-06-05 00:00:46 +0300 )edit

@Federico Thank you, Fede!!Well.. I think it is something that deals with both Android layer and some kind of WiFi, That problem doesn't occur on 3G-4G!

palikao ( 2016-06-05 00:17:55 +0300 )edit
-1

answered 2016-01-02 12:03:29 +0300

richdb gravatar image

Why you all using the Android whatsapp? We have a Telephone with sailfishos, so why not use Whatsup? If I want to use Android applications, I should buy a Phone with Android on it. I did not even install the Android support, because it drain the battery and even make the phone more laggy. There a good native alternatives for Facebook, Instagram, Flickr, Whatsapp, Telegram, etc. Just take a look on openrepos.net.

edit flag offensive delete publish link more

Comments

2

maybe because you may get blocked by whatsapp if you use whatsup?

till ( 2016-01-02 13:11:58 +0300 )edit

Never been blocked (till now). And if there be more and more users, maybe the WA creators will make Whatsup an official client? But I still think the native Sailfish applications need more support. Why the heck should we support Android apps? Then you better can buy an Android phone.

richdb ( 2016-01-02 13:47:12 +0300 )edit

I was twice blocked by WhatsApp, because I had used Mitakuuluu and WhatsUp. Since then, I use Android WhatsApp :-(

peter-berlin ( 2016-01-02 14:32:57 +0300 )edit

Then I still am lucky. Or use Telegram, I try to get my friends on telegram, it not goes quick, but now and then one is starting to use Telegram. Most people are like sheeps, they using WA over here in the Netherlands, and nobody really know why ;-).

richdb ( 2016-01-02 15:43:26 +0300 )edit
1

Three times blocked and then banned by WhatsApp Inc. using WhatsUp.. I'm monitored by them..

palikao ( 2016-01-02 17:10:27 +0300 )edit
Login/Signup to Answer

Question tools

Follow
21 followers

Stats

Asked: 2015-11-22 10:34:30 +0300

Seen: 9,247 times

Last updated: Apr 13