Ask / Submit
3

Incorrect MMS settings for AT&T

asked 2016-03-02 19:35:19 +0300

tekk gravatar image

updated 2017-01-03 03:43:05 +0300

MMS is broken on AT&T for >2g at least. It seems like all information is wrong, from mmsc to proxy to port to (importantly) mnc and mcc. I can change all of them except the last 2 from settings, can I modify a file or package to get those right?

edit retag flag offensive close delete

3 Answers

Sort by » oldest newest most voted
5

answered 2016-08-11 15:58:51 +0300

slava gravatar image

The default settings are coming from here:

https://git.merproject.org/mer-core/mobile-broadband-provider-info

You are welcome to submit a merge request, or if it's too much trouble for you, post the right settings here (including MCC/MNC of your network) and chances are that somebody picks them up and updates MBPI database for you.

edit flag offensive delete publish link more

Comments

Hi @slava

Because registration is closed and require sending mail I report bug here and I hope you will fix it

In https://git.merproject.org/mer-core/mobile-broadband-provider-info/blob/master/mobile-broadband-provider-info/serviceproviders.xml there is section to delete from line 9784 to 9792. First of all it's a section for Orange, not for Aster. Second of all Aster doesn't exist anymore. Third of all I'm Orange user and this settings give me Aster apn for MMS which mean I can't send and receive MMSes. Of course I can edit apn on phone...

atlochowski ( 2016-08-15 15:28:15 +0300 )edit
3

answered 2016-08-19 15:20:04 +0300

slava gravatar image

I have merged the following settings for AT&T:

That's closer to what's suggested by their website:

https://www.att.com/esupport/article.html#!/wireless/KM1062162

and they have been verified by the actual customer, at least for MCC=310 MNC=410

edit flag offensive delete publish link more

Comments

I removed my answer as this one is certainly accurate and the internal default pulls this which is great! Thanks folks.

marxistvegan ( 2017-01-03 03:42:33 +0300 )edit
0

answered 2018-09-03 13:58:37 +0300

Eianz gravatar image

Seems like most of you at&t apn settings might not be updated try using these hope the problem get resolved

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2016-03-02 19:35:19 +0300

Seen: 303 times

Last updated: Sep 03 '18