Ask / Submit
3

[Jolla C] MTP timestamp weirdness [released]

asked 2016-08-01 16:26:36 +0300

DaveRo gravatar image

1 If I create a file in Linux (SuSE xfce) at time=t, then copy and paste it into onto my Jolla C (2.0.2.43) connected via MTP (mtp://[usb:001,006]/Mass storage/...) it displays the timestamp as t-1 hour (which happens to be the UT time here in the UK at the moment). The same file in the File Browser on the Jolla C correctly displays time=t. So that's OK.

2 A file created on the Jolla at time=t displays in the MTP window on Linux as time t-1 - and retains that time if copy+pasted into a Linux directory. That's not OK.

3 If the file created in Linux, as in 1, is copied straight back to another directory in Linux, its timestamp is t-1.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by alain
close date 2016-12-01 16:31:17.076936

Comments

T-2 here in Sweden. (Mageia Linux 5 Gnome)

vattuvarg ( 2016-08-01 17:20:22 +0300 )edit
2

I have created https://bugs.merproject.org/show_bug.cgi?id=1656 to track this issue.

chris.adams ( 2016-09-13 10:06:38 +0300 )edit

1 Answer

Sort by » oldest newest most voted
5

answered 2016-10-09 10:15:38 +0300

spiiroin gravatar image

Looks like neither libmtp nor gphoto2 can correctly handle mtp DateTimes expressed in utc_time. Starting from buteo-mtp-qt5 0.4.19 local_time+utc_offset format will be used instead of utc_time.

The fix should be included in 2.0.5 upgrade.

edit flag offensive delete publish link more

Comments

Thanks for the feedback here.

DaveRo ( 2016-10-09 10:38:43 +0300 )edit

Question tools

Follow
1 follower

Stats

Asked: 2016-08-01 16:26:36 +0300

Seen: 232 times

Last updated: Oct 09 '16