Ask / Submit
0

How to troubleshoot failing Exchange sending? [answered]

asked 2014-01-17 09:31:42 +0200

AnaT gravatar image

I just noticed I have a lot of unsent emails in my local (=in the device) Outbox of my Exchange account. How can I find out why they have failed?

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by AnaT
close date 2014-01-28 20:12:03.604382

Comments

Can you sync new emails ? Can be the password that changed or requires to be changed due to server policies.

We are working in improvement for the error messages.

VDVsx ( 2014-01-21 10:03:48 +0200 )edit

Yes, all folders but Outbox are synced wonderfully. On my Android device also sending works perfectly and the password hasn't changed for a long time.

AnaT ( 2014-01-21 13:44:55 +0200 )edit

Are the messages in the outbox with big attachments ? You can try to update from the app cover or combined inbox to see if they start sending again.

What if you write a new email, does it send ?

VDVsx ( 2014-01-21 17:16:35 +0200 )edit

Alright! I deleted all the mails from the outbox and I got one test mail sent. It could have been due to two rather long video clips I had in the Outbox but just removing those mails and updating the mailbox wasn't enough to get the mails left in the outbox to fly out. Is there a log file for the Exchange client?

AnaT ( 2014-01-21 18:40:28 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-01-22 08:41:03 +0200

VDVsx gravatar image

This is a known problem, we need better error reporting in this case, in case you want to look at EAS logs, enable logging, in:

.config/Nokia/activesync.conf

Enable file log and add a path for the log, like for example:

[FileLog]
Enabled=1
Path=/home/nemo/Documents/as.log

Reboot the device or restart the as-daemon process.

edit flag offensive delete publish link more

Comments

1

@AnaT - Something still needed here or can be closed ? Since there's https://together.jolla.com/question/16125/bug-failing-sending-of-exchange-mails-doesnt-create-an-error-message/ for better error reporting.

VDVsx ( 2014-01-28 10:39:08 +0200 )edit

Oh, sorry I forgot it! I'll close it right now.

AnaT ( 2014-01-28 20:11:05 +0200 )edit

Question tools

Follow
2 followers

Stats

Asked: 2014-01-17 09:31:42 +0200

Seen: 231 times

Last updated: Jan 17 '14