Ask / Submit
13

JOLLA1 - TOHKBD - SYSTEMD - PROBLEM ? [released]

asked 2017-09-02 00:15:30 +0200

devel-su gravatar image

updated 2017-10-11 18:57:07 +0200

Hello, everyone! Many TOHKBD owners who upgraded to 2.1.1.26 noticed that when you turn on or reboot with the installed half of TOHKBD, the Jolla1 "thinks for a long time" (about 2 minutes) and then boots up without any network connectivity. The forum says that this is caused by the system daemon after the update. This problem can be somehow solved?

Not working: mobile communication, wlan, bluetooth

UPD.: The problem continues to remain in version 2.1.2.3 inclusive!

image description image description image description image description image description image description image description

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by devel-su
close date 2017-11-21 14:08:57.837170

Comments

4

I'd like to add that although disconnecting the TOHKBD before booting up and then connecting it after the phone has fully booted upcircumvents the "no connections" issue, battery drain kicks in dramatically after doing so. I used HungerMeter to be sure, and the results were ~6h est. uptime (without) and ~2h uptime (with TOHKBD) until no-power shutdown. I didn't restart in between, and I didn't trigger any additional applications. Might be relevant - cheers.

Lutwolf ( 2017-09-02 16:41:08 +0200 )edit

True @Lutwolf, i can also confirm this issue.

ced117 ( 2017-09-03 11:39:59 +0200 )edit

@Akimov I confirm the problem with my Jolla1+TOHKBD, but I must add that my Jolla1 does not even ask for the PIN. As a consequence

  • The Icon for System, Cellular Network is missing
  • The phone can then not even make/take phone calls/messages, making itself completely useless...
  • ...if not rebooted without TOHKBD.
prometheos de+it ( 2017-09-03 15:51:47 +0200 )edit

I've read somewhere (most likely on TJ) that the startup order (and maybe more) has been changed, but I think that this issue is better solved by the original software developer crew of TOHKBD. I do not have any information whether @kimmoli and co. (I don't know who did what, thank you for the TOHKBD, and sorry for my lack of info) still work on that project. There doesn't seem to be an official TOHKBD info channel, so I hope those guys read our posts here ;)

  • cheers!
Lutwolf ( 2017-09-03 19:59:02 +0200 )edit
2

this is a known problem since the 1st 2.1.1 ea release and still not fixed.

release notes

another question

and a dupliicate q

My tohkbd2 is working on a J1 if I do a reboot after I attached the tohbd2. The installation of the tohkbd2 ambience don't finish, the reboot stops it and the tohkbd2 is working - BUT NO CONNECTIVITY!

I always reboot without tohkbd, attach it, do not install the ambience and can use the keyboard.

jolladiho ( 2017-09-04 14:30:38 +0200 )edit

1 Answer

Sort by » oldest newest most voted
4

answered 2017-11-21 14:07:29 +0200

devel-su gravatar image

The problem is solved with the last update of the utility for "TOHKBD 2". Thank you, Kimmo!

edit flag offensive delete publish link more

Comments

So what does one have to do? Can you please be a little bit more elaborate (e.g. which TOHkb2-utility from where?).

Background: I have a TOHkb2 lying around at home since summer, but never attached it, due to these network etc. issues.

olf ( 2017-11-21 19:43:31 +0200 )edit

Question tools

Follow
10 followers

Stats

Asked: 2017-09-02 00:15:30 +0200

Seen: 477 times

Last updated: Nov 21 '17