Ask / Submit
0

Systemctl warning after reboot [answered]

asked 2014-01-01 03:00:56 +0300

jsiren gravatar image

updated 2014-01-01 03:32:06 +0300

foss4ever gravatar image

I checked on the command line if tohd had been re-enabled by the latest software update. The command systemctl status tohd.service returned the expected result, but also the warning systemd: Warning: Unit file changed on disk, 'systemctl --system daemon-reload' recommended. I ran the command and the warning disappeared. I rebooted the phone, checked again, and the warning came back when running systemctl again. I haven't noticed this before the 1.0.2.5 update. I have tohd.service masked.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by jsiren
close date 2014-01-01 12:52:42.232579

1 Answer

Sort by » oldest newest most voted
1

answered 2014-01-01 03:29:04 +0300

foss4ever gravatar image

updated 2014-01-01 03:32:38 +0300

This is a warining given by systemctl that some services that are part of the "standard" set to be started on boot, have been masked (i.e. the respective unit-file has been changed). System behaved like this also before (i.e. in 1.0.1.12) and IMHO is nothing to be worried about (except the usual reminder that tinkering with system services, boot-up started daemons, etc in developer-mode might be risky).

Sailors might want to give a more detailed and knowledgable answer to this, but this is the same warning that I received when I masked tohd.service, and still I have had no other side-effects of it. Only that battery consumption has significantly been reduced ;)

edit flag offensive delete publish link more

Question tools

Follow
1 follower

Stats

Asked: 2014-01-01 03:00:56 +0300

Seen: 6,447 times

Last updated: Jan 01 '14