Ask / Submit

[bug] Bluetooth Keyboard PIN Pairing

Tracked by Jolla

asked 2018-06-29 00:15:21 +0300

r0kk3rz gravatar image

Something I just noticed when trying to pair a new bluetooth keyboard device.

The keyboard seems to prefer the sailfish device to generate the PIN Code to be entered on the keyboard, however there is no prompt on the sailfish device to input any code.

If you press 0000 [ enter ] after initiating the pair request then it does actually pair ok.

I imagine this is probably the case with any device expecting to input a code on the remote side

edit retag flag offensive close delete


ditto for my BT keyboard and tablet. I was following the instructions with the kayboard which prompted the enter the generated pin...when none was presented, i randomly tried 0000 and luckily it worked.

pigg ( 2018-06-29 09:21:50 +0300 )edit

Almost same here, but in my case 0000 doesn't work. I'm trying to pair a JP1 with Mouhijoki to a Logitech K760. I get "Pairing with ..." and a spinning busy symbol. Later it fails with "Problem with pairing The other device did not respond to the pairing request". But if instead of waiting I type some numbers on the keyboard and press enter, I get "Problem with pairing Problem with pairing authentication. The passcodes did not match."

Another phone with Lapuanjoki shows me the number and pairing works.

mijutu ( 2018-08-09 21:19:15 +0300 )edit

2 Answers

Sort by » oldest newest most voted

answered 2018-07-01 01:28:58 +0300

ExPLIT gravatar image

on my cheap chinese BT-Keyboard anything works fine. Sailfish show me the code, i enter the code an the keyboard and press Enter. Than the keyboard work

edit flag offensive delete publish link more


it does? i'll have to double check with some of my other sailfish devices then

r0kk3rz ( 2018-07-01 11:16:54 +0300 )edit

answered 2018-07-05 16:29:21 +0300

deloptes gravatar image

It has been discussed on many places in the forum. 2.1 Xperia X and 2.2 seem to use bluez5 and it has massive problems when it comes to pair with legacy BT devices (require 4 digit pin input). Reportedly most of the time this can be solved from the command line using bluetoothctl, but it seems there is no GUI for this functionality.

In many cases (I tested with my linux PC with PA11.1 and now PA11.99) A2DP profile is set only when you initiate connection request from the phone. I guess this might be also true for HFP, but on my older car the car is initiating the connection request as far as I know. HFP worked without any issue with a newer car model - don't know what audio system it has - I tested with KIA 2017.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools



Asked: 2018-06-29 00:15:21 +0300

Seen: 556 times

Last updated: Jul 05 '18