Ask / Submit
5

wrong APN for Salt Switzerland

asked 2018-07-21 20:19:25 +0300

Cmdr_Zod gravatar image

updated 2018-07-21 20:22:12 +0300

I recently inserted a Salt Switzerland prepay SIM into my Sailfish OS X device, but couldn't active the mobile data connection because the APN was wrong (I had to manually set it to "internet" in order to get a connection. I played a bit around with my different devices, and this is the result of my research:

  • Jolla1: Sets a Connection named "Internet Everywhere - Standard" with APN "mobileoffice3g". This doesn't work. Setting "internet" as APN works
  • Sailfish X: Sets a Connection named "Internet Everywhere - Standard" with APN "mobileoffice3g". This doesn't work. Setting "internet" as APN works.
  • Intex with Sailfish C firmware: Sets a Connection named "Internet Everywhere - Standard" with APN "mobileoffice3g". This doesn't work. Setting "internet" as APN works.
  • Intex with original firmware: The APN is named "click" which works (I can't tell if it would also work with a postpaid SIM. I manually set "internet" for testing, and this works as well.

It looks like Salt changed the APN in the past, and Jolla hasn't updated this in their firmware. How can I ensure this gets fixed in a future release?

edit retag flag offensive close delete

Comments

Same with povider KPN in Netherland. It says prepaid internet where it should say internet as apn. With the wrong setting roaming is unavailable.

BonoNL ( 2018-07-22 09:05:06 +0300 )edit
2

The relevant infos are stored here.

The best way would be making a pull request with the correct settings. I understand that this is not easy to do for everyone.

Maybe contact @atlochowski . He answered a similar request of mine.

michfu ( 2018-07-24 13:36:10 +0300 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2018-07-23 15:32:45 +0300

silta gravatar image

Three years ago I had the same problem with wrong APN settings for O2 Germany with JP1. It was working in Germany but roaming in Sweden wasn't possible. One can get the right settings for a lot of providers worldwide here http://bigfun.tripod.co.uk/

edit flag offensive delete publish link more
1

answered 2018-07-22 11:21:08 +0300

ghling gravatar image

I can confirm this issue as I was facing it myself (Xperia X with SFOS on the Salt network). If I recall correct, I was able to use the internet with the "mobileoffice3g" APN, but only 2G and 3G (the connection failed for 4G).

However, the way I understand how the APN settings work is that they are send to the device by the network operator the first time you log into the network. This would mean that Salt either has a misconfiguration on their side or the SFOS devices are somehow sending some wrong identification so the network things they are only capable of 3G and sends them the wrong settings.

edit flag offensive delete publish link more

Comments

That's what I was thinking too, but I used the same operator in a Samsung S8 and the settings where correctly pushed to that device. So the fault seems SailfishOS related.

BonoNL ( 2018-07-22 12:57:05 +0300 )edit
2

Yes, you do get the settings sent by SMS, but AFAIK only the first time, so if you for example buy the Sony Xperia and first use android to check out if the hardware works properly, you are lost once you flash Sailfish on the device. The same happens if you switch SIM cards and then put the card back into your phone again.

Cmdr_Zod ( 2018-07-22 22:15:01 +0300 )edit
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2018-07-21 20:19:25 +0300

Seen: 549 times

Last updated: Jul 23 '18