Ask / Submit
3

USB Not working [answered]

asked 2018-09-12 00:13:51 +0200

paescu23 gravatar image

updated 2018-11-08 23:40:24 +0200

rozgwi gravatar image

Hi, I have the newest Jolla Version, however my Computer is not recognizing the USB any longer. Still charging, but the computer is saying: The Device is could not be recognized. On the phone-USB-Settings, it keeps showing "Charging only", even if told to go to MTP Mode

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by rozgwi
close date 2018-11-08 23:42:59.711657

Comments

You are in developer mode?

depscribe ( 2018-09-12 01:39:45 +0200 )edit

@paescu23 Note that "The newest version" is always ambiguous, and there are minor and major differences in usb behavior between different devices -> Please specify exact sfos version and device type.

spiiroin ( 2018-09-12 07:10:18 +0200 )edit

For me is the same, since I updated my Sony Xperia X to the 2.2.0.29 (mouhijoki) the USB doesn't work in Windows neither in Linux and no I am not in Developer mode.

vicentpavel ( 2018-09-12 21:24:25 +0200 )edit

Same here, since the update to 2.2.1.18 (Nurmonjoki). I can't Access the storage on the device with an USB cable. Tried to install the Sony drivers for the Xperia X device and didn't help. I do now see a correct installed "MTP USB Device" in windows device manager, (used to be Xperia X)

Sailfishy ( 2018-10-19 13:24:25 +0200 )edit

Fixed my problem, just by rebooting the device. Incredible that I didn't simply thought of restarting.

Sailfishy ( 2018-10-24 11:43:24 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-09-16 22:26:51 +0200

WT.Sane gravatar image

Works here. Maybe my suggestions are a bit on the simple side:

  1. The Xperia X is rather picky with USB plugs. Try another one! The ones with the loose fit won't work reliably
  2. Try another USB-Port on your computer. Using the same port twice before reboot might sometimes not work with linux.
  3. Use developer mode to manually choose mtp.

Good luck! Wonko, Xperia X, Nurmonjoki, 2.2.1.18

edit flag offensive delete publish link more

Comments

Hi There, thanks for your suggestion 1) tried with different cables (no succes) 2) tried different ports also with different cables (no succes) 3) Installed Developer mode, but I only see an extra option for USB (developer mode) but no differences when used. Still can't access the storage on the device via USB

Sailfishy ( 2018-10-19 13:32:44 +0200 )edit

Except trying another computer I am out of suggestions. I am using a Thinkpad T470 with Windows 10 and a X220 with Linux Mint with my phone. Since there are some others with the same problem, a hardware issue seems unlikely...

I use USB-Stick-Utils from ferlanero (Great work!) to mount USB pen drives. That might have something to do with it. But that is a very, very wild guess.

https://openrepos.net/content/ferlanero/usb-stick-utils-automount-exfat-support

WT.Sane ( 2018-10-23 13:05:38 +0200 )edit
0

answered 2018-11-07 22:02:18 +0200

paescu23 gravatar image

updated 2018-11-07 23:41:07 +0200

Edz gravatar image

@WT.Sane , thanks for your help. Indeed it was the Xperia. I first thought it might be a driver issue that cannot be fixed with the reboot (I just had exactly this with my WLAN module). I finally changed the USB-Connector of my Xperia, and it worked again. Probably it was then a HW issue. By the way, changing was pretty easy and ordering the connector was cheap.

edit flag offensive delete publish link more

Question tools

Follow
2 followers

Stats

Asked: 2018-09-12 00:13:51 +0200

Seen: 273 times

Last updated: Nov 07