Ask / Submit
7

Microsoft Exchange support doesn't install [answered]

asked 2018-10-31 22:44:29 +0300

updated 2018-11-01 12:36:43 +0300

After upgrading my Jolla 1 to Sailfish 3.0.0.5, the Exchange Support was removed. I tried reinstalling it through the Store, but it won't do it. It just stays spinning for a few minutes and shows the text "Waiting..." and then goes back to the same state as before.

The first time I tried it, directly after the upgrade, it didn't do anything for at least 15 minutes, so I killed the store-client and packagekitd to get rid of the pending installation. I also got a "There is a problem with the store" message. Edit: as it seems, every failed attempt creates a notification in the event view.

I have not removed my exchange account before upgrading. I didn't read the release notes before, because I was too excited :) But I have removed it now, and rebooted since.

Edit: Additionally, and probably a bit unrelated, but I have noticed that the calendar and contacts from the Exchange account are still there after I removed it. I have expected this, because of this question. Also, the contacts are also linked to an XMPP account of our company, so that is actually good that they are still there.

Will I have the calendar and contacts twice after I re-add the account, (when the installation eventually works) and must I clean this up manually, or will it "just work"?

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by rozgwi
close date 2018-11-08 23:23:34.628739

Comments

I have the same issue. Didn't even have an exchange account setup on my device, so didn't install anything.

solisti ( 2018-10-31 22:59:38 +0300 )edit

Same here on the Xperia X. I missed the "Jolla Phone only" part of the upgrade instructions and removed the Exchange package via Jolla store. Now I can't reinstall it, the installation is "waiting" and then failing after some time.

ghling ( 2018-11-01 08:22:54 +0300 )edit

I have the same thing. I did remove exchange accounts prior to updating to SFOS 3. After updating I tried to add them but it seemed to hang after (I think ) successful authentication. I then rebooted and removed the exchange app. But are unable to install it again.

yomark ( 2018-11-01 10:44:18 +0300 )edit

1 Answer

Sort by » oldest newest most voted
4

answered 2018-11-01 13:51:22 +0300

xfade gravatar image

We identified the problem with Exchange support downloads and this should now be resolved. Please let us know if you still see problems downloading Exchange support.

edit flag offensive delete publish link more

Comments

It seems to be fixed now, thank you!

yomark ( 2018-11-01 17:35:04 +0300 )edit

Yes, it worked now, but only on the second try. Thank you!

JMairboeck ( 2018-11-01 19:15:04 +0300 )edit
1

Download works but the plugin is still broken as it was since the last X Updates. I cannot connect to our Company Exchange Server (Version 2016) and this becomes a real showstopper. I spoke to Helpdesk at our company. We looked into their logs - the problem seems on the phone. It was reported multiple times:

https://together.jolla.com/question/189700/sailfish-22118-cannot-create-e-mail-account-for-exchange-server-2016-activesync/

https://together.jolla.com/question/109512/cant-add-microsoft-exchange-account-since-11928-update/

The Android App will work. But really - if I want Android apps I buy an Android Phone.

sm-jolla ( 2018-11-10 15:15:59 +0300 )edit

Thanks, it seems to kind of work now. Not without a hitch though:

  • Changing the sync schedule to anything from the default breaks it again and I have to go through the whole process of removing the account, uninstalling Exchange, installing and adding the account again.
  • Even with the default sync schedule, my Exchange account never displays "Up to date" in the Email app main screen as it used to. Instead, it shows things like "Just now" and "3 minutes ago". Manual refresh does nothing at all.
  • Emails read and/or deleted on my Jolla still appear as unread in Outlook on the PC.
  • I can receive emails but not send.
pichlo ( 2018-11-12 11:56:46 +0300 )edit

Question tools

Follow
3 followers

Stats

Asked: 2018-10-31 22:44:29 +0300

Seen: 375 times

Last updated: Nov 01 '18