Ask / Submit
8

App and update system not working [not relevant]

asked 2014-01-24 21:15:24 +0200

SaimenSays gravatar image

updated 2014-01-30 03:40:23 +0200

foss4ever gravatar image

Hello out there,

today I have received my brand new phone, but nothing works as it should! Actually I'm very outraged :(

I'm not able to get any app. I read on Internet that I have to update to 1.0.2.5. But under product informationen it says that it is actual, so nothing to update. But it is 1.0.0.5 :( Further on internet there stands to do a restore to factory settings. But this does not help at all. Also it is not possible to enable "Developer mode", it rans in endles loop over hours, but no terminal is installed. By the way, Wlan is working, It is possible to browse on the Internet. Also Jolla account was generated and logged in.

How can I get out of this? It is very disapointing to buy a brand new phone wich does not work as it should!

edit retag flag offensive reopen delete

The question has been closed for the following reason "question is not relevant or outdated" by SaimenSays
close date 2018-07-09 11:20:03.989769

Comments

16 Answers

Sort by » oldest newest most voted
3

answered 2014-01-26 12:54:51 +0200

SaimenSays gravatar image

updated 2014-01-26 19:10:33 +0200

SUCCESS!

Finally I asked my neighbour to get his WLAN key. After a few tries to recieve update it worked. For all who have this problem, try different WLANS. Also browsing works well, store can have a problem with internet connection. Also 3G might not work.

And there is a progress bar during system update. Nobody tells me, that the picture of sailing ship on top gets lighter if download goes on. Cut of these designers hands. You can not imagine that this should be a progress bar if it hangs over hours without getting any piece lighter :(

Can anybody tell me the reason why store behaves diffrent then rest of internet connection?

Thank you all for the suggestions during this discussion!

edit flag offensive delete publish link more

Comments

It's kind of weird what lead to this behaviour. Running tcpdump/wireshark on the gateway could have brought up what is the problem in this case.

Sailor ( 2014-01-26 19:18:34 +0200 )edit

... and what a waste of time and effort! Why not do it properly from the start? You do need a proper connection for this or any phone, not like the Mickey Mouse connections available from the German providers.

karlefr ( 2014-01-26 20:08:52 +0200 )edit

Erm sorry - german mickey mouse provider connection or not - you last comment is - well I don't write that. Even a slow 2G is running and should be able to set up the jolla account (what would allow to enable developer mode and ssh to the Jolla and check the logs). The days where I had a pc as router are about 15 years ago. So: no fancy tcpdump/wireshark on the router, but listening in monitor mode would be possible.

masmrlar ( 2014-01-26 20:18:04 +0200 )edit

... and fancy enough - I had no connection problems with my provider and 3 different phones for the last few yeas - even with my mickey mouse provider....

masmrlar ( 2014-01-26 20:19:30 +0200 )edit

@masmrlar: Exactly my opinion. There must be anything different to other systems. None of my other phones/systems has such a problem. And manufacturer had to fix this as fast as possible! It's not a users duty, because so many of us are strugling with this daft update problem!

SaimenSays ( 2014-01-27 00:25:01 +0200 )edit
3

answered 2014-02-10 15:54:22 +0200

jovirkku gravatar image

Checklist to make updates work (updates = SailfishOS and application installs/updates)

The following steps should help to avoid some simple mistakes or problems.

  1. Check that your Jolla phone has a working Internet connection (either mobile or WLAN). Do this by browsing to a well know web site with Jolla browser.
  2. Make sure that your phone has correct date and time.
  3. Make sure that you have a valid and working Jolla account. Check it with a PC (or another non-Jolla device having Internet access). Sign it at account.jolla.com. Memorize your credentials if it worked. If it didn't, then use 'reset password' service at the same web site - only enter your email address which must be the same as used for the original registration of your Jolla account). You will get an email message with a link to the password service. The message also contains your Jolla account. Once you are signed in memorize your credentials. Now take your Jolla phone and visit Settings > Accounts > Jolla. Take 'Update sign-in credentials' in the pulldown menu. Finally, launch the Store application.
  4. Install an application from Store, e.g. Screenshot.
  5. Seek for SailfishOS updates in menu Settings > System > About product. Take "Check for update" in the pulldown menu. If their is an update available there will be an additional line of text "Update available" just under "Sailfish OS" in the list of About product details. Also the banner "System update available" is shown near the top of the screen for a short time. Tapping on that banner, or taking "Update device" in the pull down menu will start the guided download and install process.
  6. Follow the on-screen instructions for downloading and installing the update. It is best to connect a charger to the phone.
  7. During the download there is a progress indicator at the top of the display: a wave of light moves from left to right over the scenery.
  8. Initiate the install phase, as instructed. It will be complete when the phone restarts by itself. Never use the power key during this phase!
  9. Check at Settings > System > About product that the new SailfishOS is in the phone. If not, then restart from step 5.

Done!

edit flag offensive delete publish link more
2

answered 2014-01-29 21:21:37 +0200

stezz gravatar image

Hi @SaimenSays,

I am sorry you had troubles with your update and I am happy you managed to update at the end. There seem to be some reports of this bug but it is still unclear what is the cause of it. Our testing did not reveal this when we shipped the product and unfortunately we can't go back in time to fix the issue on 1.0.0.5.

New devices are shipping with newer software, however we produced a batch of devices with that version which are in stock and are getting shipped (and can't get reflashed before they arrive to you).

edit flag offensive delete publish link more

Comments

Actually good to know that the new devices are shipped with the new (latest?) system-version. If I remember correctly, there was a question in this forum abt that, so here we have an answer. Thanks ;)

foss4ever ( 2014-01-30 03:14:43 +0200 )edit

Hope the wifi download/update issue will be fixed soon, because it's quite annoying! Good to know you are aware of the issue.

Gabir ( 2014-01-31 15:05:10 +0200 )edit

@Gabir as said we don't see this in newer versions, however we can't go back in time and since to get the new version you have to update, if update is not working we have a bit of a chicken and egg problem.

stezz ( 2014-01-31 17:08:46 +0200 )edit

@stezz unfortunately the wifi issue (wifi working correctly except from dowloading system updates and from the jolla store) is still here with sailfish 1.0.3.8: can it be a provider issue in your opinion?

Gabir ( 2014-01-31 20:18:25 +0200 )edit

@stezz by the way, my internet provider for my home wifi network is infostrada, in Italy.

Gabir ( 2014-01-31 20:23:14 +0200 )edit
2

answered 2014-02-03 12:09:34 +0200

eric gravatar image

updated 2014-02-04 10:05:49 +0200

Here's a check-list and instructions to help you recover from non working store on 1.0.0.5 Software.

1 - Make sure your clock and date are up-to-date (If it is off in the past, the SSL cert will not be valid, so SSL connection will fail).

2 - Make sure you have a steady connection, preferably WLAN.

3 - In case you have skipped email installation from the startup wizzard, and installed it manually via store later, you will have to reset your device, using factory reset.

Hope this helps...

edit flag offensive delete publish link more

Comments

Can you please extend #1 to "clock and date is up-to-date"? I had the issue, that the network time fixed my Jollas time (and date), but not the year (or I just slipped to the wrong year - whatever). For shure - I could've seen that, but if you see the correct time and date (ex. Jan 29th or so), you don't check the year.... But I thing your hints should help (the date/time is the real issue due to ssl certs).

masmrlar ( 2014-02-04 10:04:04 +0200 )edit

@masmrlar: Thanks for pointing this out! Answer updated.

eric ( 2014-02-04 10:06:53 +0200 )edit
1

answered 2014-01-25 09:32:48 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2014-01-25 16:53:52 +0200

teun gravatar image

Just guessing here but try as follows , from complete factory reset, insert sim with working 3g internet. go through entire boot up proces including initial jolla account signin over 3g, not using the wifi connection. Skip installing the jolla essentials.. this will save some data.

So from the comments hereunder it is safe to assume it is some incompatibility between the Jolla and your wifi network / router. The wifi connection is buggy as there are several reports about this.

edit flag offensive delete publish link more

Comments

This post has made it. After doing same reset process multiple times before with wlan, now I get update notification after factory reset and working with 3G only!

Actually it is downloading for over 1 hour. My mobile internet buget may be empty. So it is loading with 64kbit only.

SaimenSays ( 2014-01-25 12:01:56 +0200 )edit

After waiting for over 2hours, I aborted downloading i over 3G. Then trying to download over WLAN. But also there is no download. On my traffic monitor in router I see there is an initial peek in Bandwith. But then after a few second nothing :(

SaimenSays ( 2014-01-25 14:32:58 +0200 )edit

loading with 64kbit can take up to 6 hours or more, just be patient! Anyway a 3G connection with only 64kb download speed is very unusual. I have a ~ 3MB download speed and it still took some time to get the download sorted. You should get a fast connection, or a fast WiFi connection and I am sure everything will be fine.

karlefr ( 2014-01-25 17:11:40 +0200 )edit

If he is from germany it is quite normal for some mobile providers to throttle the connection to absolut useless speeds.

Sailor ( 2014-01-25 17:31:48 +0200 )edit

Yes from germany... and yes it is throttled after 500MB per month. Waiting longer is literaly not a problem, but I don't see if it hangs or downloding is a very slow process. I tried it more then 20 times over WLAN now, Update causes traffic for 5 seconds, then no more traffic is down or uploaded.

SaimenSays ( 2014-01-25 18:04:43 +0200 )edit
0

answered 2014-01-24 21:50:34 +0200

foss4ever gravatar image

I'd suggest you contact Jolla Care using this: https://jolla.zendesk.com/forums or email them directly. Of course, you might get good answers from this forum too, but the Care is always there for you to solve issues with a new product.

edit flag offensive delete publish link more

Comments

I know this site. But I don't think to get any response over the weekend. It's very bad to have a new device in hand, but can't do anything better than a 10year old phone, like calling and writing sms :(

SaimenSays ( 2014-01-24 23:11:02 +0200 )edit

Then there is IRC-channel at freenode at #jollamobile channel from where I got help in my early days with the device (had some update installation and store problems).

foss4ever ( 2014-01-25 00:11:17 +0200 )edit
0

answered 2014-01-24 22:20:22 +0200

simo gravatar image

When I tried to update, it worked only on 8th try or something like that...

Jolla account needs to be active, and WLAN is suggested.

edit flag offensive delete publish link more

Comments

WLAN is working! I'm able to use browser. Also loged into account. Checked account by web login over laptop, from this seems to be okay. But neither Appstore, system update, nor enbaling developer mode gets any response. Is there any way to read out a log, what's going on there?

SaimenSays ( 2014-01-24 23:07:35 +0200 )edit

@SaimenSays If you can't enable dev-mode reading logs is a bit hard.. :P

foss4ever ( 2014-01-25 00:05:54 +0200 )edit

Do you have the file manager installed? Or can you install the file manager? Because if this is possible maybe we can send you the necessary rpm files for the devmode and you can install them by hand.

Sailor ( 2014-01-25 01:03:58 +0200 )edit

I can't install any app through appstore. Phone is out of the box, so file manager is not installed. If you tell me how to do install with out of the box phone, I sure will try that.

SaimenSays ( 2014-01-25 01:22:32 +0200 )edit

Was your phone able to connect TOH and download the ambience (snow white) from Jolla's server?

simo ( 2014-01-25 09:21:21 +0200 )edit
0

answered 2014-01-25 00:11:33 +0200

XiliX gravatar image

are you using a 802.11N wlan network? I have experienced trouble with that... Try setting your router to b+g only.

edit flag offensive delete publish link more

Comments

Set router to from "mixed" to "B+G only", but problem here at all :(

SaimenSays ( 2014-01-25 00:45:01 +0200 )edit
0

answered 2014-01-25 00:59:24 +0200

SaimenSays gravatar image

updated 2014-01-25 01:11:31 +0200

When I tell Jolla to search for Update manually it searches for minutes and then says it is already actual. But I think this message is not correct. It simply does not get any response from server?

Is it normal that a device delivered today, is programmed with month old firmware 1.0.0.5? It should be sold with up to date system, or is my phone the only one missed update on final clearance?

I tried get it working for 7 hours now. I know Jolla is bit of geek phone, had a N900 before. But this is to much! How can they sell so much devices if nobody can download any app? I'm thinking about sending back this bullshit! :(

Sorry for theese hard sentences, but it is worst device ever had struggled with!

edit flag offensive delete publish link more
0

answered 2014-01-25 01:42:41 +0200

Blown_ouT gravatar image

I had the same issue when i got my Jolla, tried several times to update... first when i power on the phone got in the store and install any app that I saw and the update notification came out. Tapping to update and the app store failed to load, then I reset the device, restarted it and again the same. Tried enabling and disabling the dev mode, updating in both and nothing. Resetting again and at last reset without even open the app store, without installing any app or entering in the menu even just waiting for the update notification to pop up, the miracle happened. I go in Events view and from there tap the update. I did that for both updates from 1.0.0.5 to 1.0.2.5

edit flag offensive delete publish link more

Comments

Late night yesturday I do what you said.Set the device back to factory settings. Restarted it, enterd Wlan lay, logged in to account, jumped over app installing. Then layed the device down over night...

...this morning nothing :(

SaimenSays ( 2014-01-25 11:03:09 +0200 )edit

does your imei number show up as registered device on your jolla account when you login to it on the web?

teun ( 2014-01-25 11:37:54 +0200 )edit

I guess I was lucky then... and I must say that the whole procedure only took me a few hours with all the restore. If no update notification is displayed suppose you have a problem with the account. To me the problem was that Jolla store would not start in order to update

Blown_ouT ( 2014-01-25 11:59:28 +0200 )edit

Yes, my IMEI is displayed on web account, so anything with WLAN connection and account registration seems to be okay. Need registration is anyway a very bad behavior for an open source phone. Why is it necessary to registrate to be able to download anything :(

SaimenSays ( 2014-01-25 13:17:22 +0200 )edit

Because there is closed software on the phone like alien dalvik which is not supposed to get to phones without proper registration.

Sailor ( 2014-01-25 13:29:22 +0200 )edit

Question tools

Follow
5 followers

Stats

Asked: 2014-01-24 21:15:24 +0200

Seen: 3,002 times

Last updated: Feb 10 '14