Ask / Submit
16

[3.0.3] [XperiaX] Battery drain when Bluetooth / WiFi on [answered]

Tracked by Jolla

asked 2019-05-06 08:15:45 +0300

ghling gravatar image

updated 2019-05-09 09:01:21 +0300

jiit gravatar image

After installing the EA upgrade 3.0.3, I'm experiencing massive battery drain when bluetooth and / or wifi is turned on. As soon as I enable bluetooth, the CPU is rarely reaching the sleeping state (it drops from usual 90% down to 10 - 20 %) and the amount of user idle threats increases. With that, the battery consumption increases rapidly (a fully charged battery lasts for 8 - 9 hours instead of 30) and the phone is notably warm all the time. Even turning off bluetooth does not seem to solve the issue until i reboot my phone.

With wifi, the problems are similar but a bit different. Here, the battery drain only occurs when connected to some wifis. If connected to my wifi at home or disconnected, everything is fine. But if the phone i connected to the wifi at my office, i experience the same battery drain as with the bluetooth case (again, low cpu sleep, high user idle). The only differences I see are related to signal strength, which is lower in my office.

Due to the bugs, I downgraded back to 3.0.2.8 since the current state of 3.0.3 (running out of battery in the afternoon) is unusable for me. There are some similar issues reported in the comments to the release notes and regarding bluetooth in older versions.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by ghling
close date 2019-05-24 08:41:57.476090

Comments

Interesting... After 3.0.3 the Wifi power drain got much lower, with 3.0.2 the battery drain was much higher for me. My Phone XA2 lasts for approx. 26-28 h with Wifi and BT turned on

ExPLIT ( 2019-05-07 00:24:57 +0300 )edit

Bluetooth consumes very high power on my xa2 too. https://together.jolla.com/question/204357/bugbluetooth-consumes-too-much-power/

xbt123ufo ( 2019-05-07 06:59:34 +0300 )edit

I have read that Jolla has made some adjustments to conman because of the issue (which from my understanding mainly affected XA2 devices). My assumption is that this changes may cause my issues, since I'm not having any troubles with 3.0.2. After downgrading again, the battery drain is gone and everything is back to normal on my Xperia X.

ghling ( 2019-05-07 07:47:53 +0300 )edit

Regarding WiFi and BT, the battery consumption is really low on my XA2, average drain is under 200mW. However, there's a significant difference between 4G and 3G power consumption. 4G uses approximately 2,5 times compared to 3G. With 4G the average consumption is a bit over 500mW on average. Note, this is on Elisa network, and it has been reported/commented that there may be differences between operators, so this may be something to look at/test also.

raketti ( 2019-05-12 13:28:28 +0300 )edit

I'm also facing issue with power drain on XA2. I'm on 3.0.3.9 release, but the issue was also present on 3.0.2.8. just after reboot, without any data connection nor wifi, nor bluetooth SystemDataScope tells me that the power drain il almost 1000mW. It's very high. It also show that the CPU is never i sleep mode...

I could try to downgrade and remove all new apps....

VincentB ( 2019-05-13 05:31:12 +0300 )edit

4 Answers

Sort by » oldest newest most voted
5

answered 2019-05-09 14:42:23 +0300

ghling gravatar image

updated 2019-05-09 14:43:05 +0300

This issue still exists in 3.0.3.9. After updating from 3.0.2.8 to 3.0.3.9, I experienced the battery drain again. In SystemDataScope I can see unusual low CPU sleep rates.

After soft-bricking my device during the downgrade, I can also confirm that it happens with a fresh install of SFOS. I flashed my phone with the latest 3.0.3.9 image and the issue appeared as soon as I enabled (and connected) bluetooth to my smartwatch and wifi.

edit flag offensive delete publish link more
2

answered 2019-05-10 08:08:54 +0300

ghling gravatar image

@Jolla: I can see you are tracking this issue. Please let me know if I can assist you in some way (logfiles, configuration adjustments, up- / downgrade of specific packages or whatever). Due to this bug I downgraded to 3.0.2.8 again, but I can always make another try.

edit flag offensive delete publish link more
0

answered 2019-05-12 10:48:28 +0300

tsecher gravatar image

As for me, massive battery drain even in 4G data mode since 3.0. My phone can't last one day, while it was able to run for 3 days before ! Moreover, I have random sms dysfunctions, but this is a subject for another thread. @Jolla: please address this huge regression.

edit flag offensive delete publish link more

Comments

I agree, I get high consumption since 3.0.2.8. It is not only related to Wifi. Even in plane mode, I sometimes gets consumption higher than 400mA.

Using Systemdatascope, I can see that without using the phone, CPU change suddenly, and time in sleep mode is higly reduced.

VincentB ( 2019-05-16 16:23:47 +0300 )edit
0

answered 2019-05-19 11:19:25 +0300

ghling gravatar image

A quick update on my issue: After the sync app for my smartwatch (Amazfish) was updated for 3.0.3, I upgraded again. Until now, I could not notice any battery drain within the last 24 hours. Since it mostly occur on my workplace, I can definitely tell if that solved the issue next week. I'll keep you updated.

edit flag offensive delete publish link more

Comments

It looks like the battery drain issues are gone now. So that was probably no issue of SFOS itself but of the sync daemon of my smartwatch, Amazfish.

Therefore, I'll close this issue. Sorry for the fuzz.

ghling ( 2019-05-24 08:41:38 +0300 )edit

Question tools

Follow
7 followers

Stats

Asked: 2019-05-06 08:15:45 +0300

Seen: 699 times

Last updated: May 19