We have moved to a new Sailfish OS Forum. Please start new discussions there.

Clipboard icon disappeared

asked 2014-02-06 18:48:02 +0200

ApB gravatar image

updated 2014-08-25 21:06:22 +0200

Even though i don't use the CNP functionality that much -or at all- i don't get the clipboard icon anymore on the top of the keyboard. Noticed it today but can't tell when it happened. It was there after the last update for sure (checked the clear clipboard functionality).

Anyone else getting this?

This is still happening as of A reboot fixes -or probably restarting malit.service- it but still not the way it should be. I managed to do it after scanning 2-3 bar/QR codes with Codereader.

edit retag flag offensive close delete


could there be a relation to this? https://together.jolla.com/question/24697/regression-copy-and-paste-broken/#comment-25228

Zandi ( 2014-02-07 01:01:11 +0200 )edit

I have the same problem. I tryed restarting maliit, and after the clipboard icon appears again, but with an old content, and the first time I try copying domething, it disappears again. Which is the copy/paste service? Lipstick?

magullo ( 2014-07-06 13:53:02 +0200 )edit

All of a sudden I have this problem too. Used to work without any problem.

Jörg ( 2014-09-14 14:11:46 +0200 )edit


restart malit service or reboot the phone. :)

ApB ( 2014-09-14 14:21:37 +0200 )edit

3 Answers

Sort by » oldest newest most voted

answered 2014-05-21 14:59:02 +0200

juiceme gravatar image

I just noted that I am unable to copy/paste any longer, the details of the problem are pretty much like with OP.

First I noticed I could not copy text any longer to the clipboard; I had a piece of text there that was pretty presistent, whatever I did, pasting to any application always pasted the same thing, I was unable to get anything else to the clipboard even as the selection seemed to work. (I was able to select text with long press and adjust the beginning and end markers)

Then I tried clearing the clipboard, by long press method. The clipboard was cleared and the icon disappeared.

Since then I have been unable to see the clipboard icon any longer, and the condition where my selection does not enter clipboard persists.

Is there some debug command I can try to see why my system is behaving like this?

edit flag offensive delete publish link more


OK, so as I got no advice on what should I try to debug this, I thought maybe restarting lipstick could fix it... Sending HANGUP to the lipstick process did it, now my copy/paste is again working like it should.

The question remains, though, why did it break in the first place?

juiceme ( 2014-05-27 07:10:20 +0200 )edit

answered 2014-02-06 19:17:37 +0200

richhanz gravatar image

And with a "clear clipboard" it disappears until you select.

edit flag offensive delete publish link more

answered 2014-02-07 14:26:19 +0200

Pekka Vuorela gravatar image

Are you sure there is something on the clipboard? Paste button is not shown if clipboard is empty.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools



Asked: 2014-02-06 18:48:02 +0200

Seen: 713 times

Last updated: Aug 25 '14