Ask / Submit
3

Call waiting disconnects second call [released]

asked 2014-02-09 21:16:31 +0200

vattuvarg gravatar image

updated 2014-02-18 11:49:00 +0200

My phone has call waiting activated in the settings. When the second call comes it gets disconnected with the rising-three-tone error signal (or SIT, i think). Is something misconfigured on my phone? Can I set things right somehow?

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by vattuvarg
close date 2015-10-06 11:34:06.902868

2 Answers

Sort by » oldest newest most voted
2

answered 2014-02-13 12:22:17 +0200

tkenakka gravatar image

updated 2014-02-13 12:23:16 +0200

Hi, potential reasons for the problem could be related to the device or operator network. For activating Call waiting on Jolla all that you should need to do is to enable it via Settings > Apps > Phone > Call waiting so that the icon lights up (and no error messages are displayed). Sounds like you have already done this. 1) An alternative way to check the service status using your phone is by sending a command *#43# using the dialler (Enter phone number > *#43# > Call). I recommend you to do this and to check what's the status for "voice" is enabled or disabled. 2) An another way to check is to insert the SIM card to a different manufacturer phone and check how it reports the Call waiting status, and if it works there.

These steps should give you clues if the problem is related to your specific phone or to the operator's network side service. If *#43# reports service as disabled, you may try rebooting and toggling the UI setting again, or enabling it via "calling" using command *43#. Additional reference: http://en.wikipedia.org/wiki/Call_waiting#Star_codes

edit flag offensive delete publish link more

Comments

Thanks for the good answer. According to *#43# voice is activated. The SIM-card works with call waiting in my old phone (Nokia 700).

vattuvarg ( 2014-02-13 13:11:58 +0200 )edit

Turned off call waiting with code, restarted the phone and started the service with the code. Checked, both with settings and and code, that the service is active. Now I just have to test it.

vattuvarg ( 2014-02-13 13:22:35 +0200 )edit

Good to hear. Also, could you please comment which SW version you had when the problem occurred (Settings > System > About product > Sailfish OS)

tkenakka ( 2014-02-13 13:26:25 +0200 )edit

Called my fiancee (she was out walking the dogs) and then asked one of my collegues to call me. No three-tone signal and the phone gave me the options for answering. I chose to park my fiancee and the call from my collegue came through just fine. Things seem to work now. I wonder why the service stopped working like that?

vattuvarg ( 2014-02-13 13:41:07 +0200 )edit

@tkenakka - Thanks and welcome to the jolla forum.

vattuvarg ( 2014-02-13 13:42:27 +0200 )edit
0

answered 2014-03-19 07:22:52 +0200

vattuvarg gravatar image

The Ohijärvi update (1.0.4.20) of march 2014 fixes this problem.

edit flag offensive delete publish link more

Question tools

Follow
2 followers

Stats

Asked: 2014-02-09 21:16:31 +0200

Seen: 797 times

Last updated: Mar 19 '14