We have moved to a new Sailfish OS Forum. Please start new discussions there.

4G - LTE on three.co.uk

asked 2014-02-13 20:19:48 +0300

m2 gravatar image

updated 2014-07-22 09:51:35 +0300

jiit gravatar image

Has anyone over here tried using your jolla on the 4G enabled by the post over here https://together.jolla.com/question/2135/enable-4g-lte/ on three.co.uk network operator in the UK?

edit retag flag offensive close delete



I have used it on O2, it worked fine, but no calls or sms as expected until LTE gets enabled officially.

cquence ( 2014-02-13 20:29:02 +0300 )edit

How do you switch between 4G and 3G? What happens when someone calls your number or sends you SMS while on 4G?

m2 ( 2014-02-16 20:37:28 +0300 )edit

I'm moving to Three next week with luck, and should I see 4G on my jolla in the next month or so I'll let you know.

PJW_2273 ( 2014-02-16 21:55:20 +0300 )edit

I have used a basic application found on openrepos.net to enable 4G. However this is only experimental and not usable in the sense of not being able to use your phone normally. 4G is not yet fully and officially supported so when using this application to switch to 4G you can only have a data connection to the network, no calls, no SMS.

cquence ( 2014-02-17 00:53:23 +0300 )edit

I have switched to 4G to simply test that data works OK and find out how fast it can be :) Then you switch back to 3G to have your phone functioning again. If someone sends you an SMS or tries to call you at the time you're on 4G, they will go to voicemail as if your phone were switched off. As I said, this is an experimental application so use it with caution. We have to be patient until the official update enables 4G on the phone.

cquence ( 2014-02-17 00:53:29 +0300 )edit

1 Answer

Sort by » oldest newest most voted

answered 2014-02-20 22:24:28 +0300

m2 gravatar image

updated 2014-02-21 12:26:35 +0300

I have managed to successfully use the 4G (Hatton Cross area) looking at the Coverage Map TW6 3RE I must have been connected to the BTS mast from Hounslow.

Howto: In System - Developer mode - Enable: Developer mode & Remote connection (so you can ssh to the phone over Wi-Fi)

ssh nemo@

[nemo@localhost ~]$ dbus-send --system --print-reply --dest=org.ofono /ril_0 org.ofono.RadioSettings.SetProperty string:"TechnologyPreference" variant:string:"lte"

you will get this msg. after the command and a 4G if you are in the area covered by 4G:

method return sender=:1.8 -> dest=:1.61 reply_serial=2

On three.co.uk SMS sending / receiving worked fine for me, but no calls (incoming or outgoing) as per the post over here why ;)

But I must say they brag about their network being build for internet, I had some poor speed results, see below:








When you come out of 4G area and have Tethering on the phone will behave unexpectedly showing network problem and only way out of that is reboot :(

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools



Asked: 2014-02-13 20:19:48 +0300

Seen: 818 times

Last updated: Feb 21 '14