We have moved to a new Sailfish OS Forum. Please start new discussions there.
0

Fastmail and Jolla [answered]

asked 2014-05-09 14:25:35 +0300

hnbv gravatar image

updated 2014-05-12 22:07:26 +0300

I cannot send mail when using Fastmail, mailclient just says "Error with sync".

I've set my account with using this

// After many removed & added accounts, I changed my password one more time. Now it works.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by hnbv
close date 2014-05-12 22:07:44.525409

Comments

The developers might love you more if you could give them some additional information. See this.

Jollabullad ( 2014-05-09 14:46:13 +0300 )edit

When I try to do that: " "SailfishKeyProvider_ini_read: unable to open file SailfishKeyProvider_storedKey(): error: no scheme or key found for provider/service"

hnbv ( 2014-05-09 17:21:26 +0300 )edit

FWIW: I use fastmail. On initial setup I had fat fingered the SMTP port (I found 995 in the settings, that's POP3S and of course wrong for sending mail)

Once I had the correct SMTP settings (SSL and 465), sending mail works just fine. Please verify your settings (including your password), try again and update your question. You should see the following in your logs when it works fine;

[13708] May 11 10:01:59 [Debug] Messaging :  Running action TransmitMessagesRequest 9693741187085 
[13708] May 11 10:01:59 [Debug] SMTP :  newConnection 
[13708] May 11 10:01:59 [Debug] SMTP :  Open SMTP connection 
[13708] May 11 10:01:59 [Debug] Messaging :  QMailTransport::Socket::Socket SET PROXY host= "" port= 0 
[13708] May 11 10:01:59 [Debug] Messaging :  Opening connection -  "mail.messagingengine.com" : 465  SSL 
[13708] May 11 10:02:01 [Debug] Messaging :  SMTP : connection established 
[13708] May 11 10:02:01 [Debug] Messaging :  SMTP : Secure connection established 
[13708] May 11 10:02:01 [Debug] SMTP :  Connected 
[13708] May 11 10:02:01 [Debug] SMTP :  RECV: "220 mail.messagingengine.com ESMTP ready" 
[13708] May 11 10:02:01 [Debug] SMTP :  SEND: EHLO [127.0.0.1] 
[13708] May 11 10:02:02 [Debug] SMTP :  RECV: "250-mail.messagingengine.com" 
[...]

and much more, but the important part is to get a connect and a reply to your EHLO.

pcfe ( 2014-05-11 11:07:08 +0300 )edit

I managed to get the log and I picked up following: Authentication required NeedsRegistration

hnbv ( 2014-05-12 03:18:06 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-05-09 15:17:58 +0300

molan gravatar image

I don't use Fastmail, but try following:

Email adress:xxxx@fastmail.fm Servertype: IMAP4 Username:xxxx@fastmail.fm Password: [yourpassword..] Server Address:mail.messagingengine.com Secure connection: SSL or TLS Port: 993 or 992


Servertype: SMTP Username:xxxx@fastmail.fm Password: [yourpassword..] Server Address:mail.messagingengine.com Secure connection: SSL or TLS Port: 587 or 465

I hope one of those settings works. Please let me know.

edit flag offensive delete publish link more

Comments

As you listed some settings with 'or', FWIW; I can confirm that 993 SSL for Incoming and 465 SSL for Outgoing work fine. I have not tried TLS as the Jolla UI is unclear if that means TLS (would be good) or STARTTLS (not what I want).

pcfe ( 2014-05-11 11:11:10 +0300 )edit

I have also set it up with imap port 993 SSL and smtp port 465 SSL. Works fine like this.

pvs ( 2014-05-11 22:44:38 +0300 )edit

Question tools

Follow
3 followers

Stats

Asked: 2014-05-09 14:25:35 +0300

Seen: 437 times

Last updated: May 12 '14