We have moved to a new Sailfish OS Forum. Please start new discussions there.

Auto-brightness not working.

asked 2013-12-28 02:26:49 +0300

Milo gravatar image

updated 2014-11-26 12:49:44 +0300

jiit gravatar image

It appears that the "adjust automatically" setting is not doing anything on my device. I have defined brightness on the display page to "max" with "adjust automatically" ticked on, but the display is not reacting to darkness or light in any way. Brightness of the display is constant, no matter if I'm in a dark room, or well luminated heaven.

There is probably a file somewhere in /sys which I could cat to see if the light sensor is actually working, but so far, I haven't been able to find it.

Edit: As said in the comments, the sensor seems to be working just fine, but the auto-brightness adjustment implementation just isn't aggressive enough to cause any real difference in brightness levels when switching between well lit room, sun light or eternal darkness (finland).

edit retag flag offensive close delete



csd hardware test app. For me in this test app, when running the Single Test -> L-Sensor (light sensor) test, the test fails as the difference is only 15 when the Pass criteria is 50. This is while testing in a well lit room, so maybe the L-Sensor requires calibrating - if I shine a torch on the L-Sensor it passes with flying colours (a difference of 18761!)

Milhouse ( 2013-12-29 00:19:59 +0300 )edit

Thank you mentioning that hardware test app.

I'm getting similiar results with that setup. Test fails in a well lit room with the difference of 18, and when using a torch, the difference is 18823. So yeah the L-sensor is definitely working...

Milo ( 2013-12-29 01:58:19 +0300 )edit

Raw ambient light sensor values seem to be here, in als_ch0 and als_ch1, populated only while the display is active (on):


The proximity sensor is event10, but this seems to be active whether the display is on or off. Not sure why it needs to be on when display is inactive/locked... future flip-to-silence feature, maybe? But then the proximity sensor would only need to be enabled during an alarm or incoming phone call... possibly another unnecessary battery drain?

Milhouse ( 2013-12-29 03:51:38 +0300 )edit

L-sensor definitely reacts to light sources.. Covered the raw data was 5 an 3 on ch0 and ch1. on well lit room they were 2678 and 1310 and when torched values peaked at 8393 and 1100. Still no visible difference in brightness when brigthness is set to max at different lightning conditions.

Milo ( 2013-12-29 13:05:37 +0300 )edit

The proximity sensor might be enabled by default because it was necessary in N9. The clock on its lock screen was shown when proximity sensor could breath freely, but when covered, the clock disappeared.

Milo ( 2013-12-29 13:06:55 +0300 )edit

3 Answers

Sort by » oldest newest most voted

answered 2014-03-18 18:37:01 +0300

spiiroin gravatar image

updated 2014-07-25 10:52:44 +0300

Milo gravatar image
  1. List item

At the moment there are 5 brightness levels that can be selected with the brightness slider.

When the "adjust automatically" is not selected, it just chooses between 20%, 40%, 60%, 80% and 100% points.

With "adjust automatically" it chooses between Minimum, Economy, Normal, Bright and Maximum ambient light profiles.

Due to directional nature of the ambient light sensor it has trouble telling apart truly dark environment from "there are lamps, but none of them are directly over the sensor" situations. To compensate for this the minimum applicable brightness grows with each step from Minimum to Maximum profile. Which also means there is not too much dynamic range left at the Maximum setting.

At "office lightning" conditions there is just a small difference between the profiles, which easily makes it look like the setting does nothing. If it gets darker, the Minimum and Economy will reach darker brightness values than the rest. If it gets brighter, the Maximum and Bright will reach full brightness earlier than the rest.

The profiles are configured in /etc/mce/20als-defaults.ini, at the [BrightnessDisplay] section. If you wish to edit them, make a copy with higher number in front, say "cp 20als-defaults.ini 90als-custom.ini". The files are processed in alnum order, latter files can override settings from earlier. Using a copy means you can easily get back to defaults and upgrades will not overwrite the custom data you want to keep. Also note that mce needs to be restarted (systemctl restart mce.service) before the modifications are taken into use.

But before starting to tinkering with that you might want to choose: the lowest automatic setting you feel comfortable with in normal lightning conditions.

edit flag offensive delete publish link more



It would be good to have some text describing chosen value under brightness slider.

Orzech ( 2014-04-08 02:23:22 +0300 )edit

answered 2013-12-28 02:41:14 +0300

simo gravatar image

For me it's been working fine, even getting the screen darker than the minimum brightness setting without automatic brightness. Also, I've tested the light sensor, it seems to be ok.

edit flag offensive delete publish link more

answered 2013-12-28 16:42:26 +0300

Milo gravatar image

Update: auto-brightness seems to work when brightness is set to something else than max.

edit flag offensive delete publish link more



not for me, at least not as much that I notice it. I set brightness to around 80% or so, and automatic brightness. Nevertheless it really starts to hurt when it gets darker around me.

MMx ( 2014-01-16 01:41:33 +0300 )edit

@MMx Yeah the brightness doesn't change as dramatically as it changes on N9...

Milo ( 2014-01-16 09:16:55 +0300 )edit

It isn't working for me too... I set brightness round 30-40% but the sensor doesn't work at all.

deedend ( 2014-02-26 10:08:29 +0300 )edit
Login/Signup to Answer

Question tools



Asked: 2013-12-28 02:26:49 +0300

Seen: 940 times

Last updated: Jul 25 '14