Ask / Submit
3

Native Email App Check Certificate Message

asked 2014-06-12 08:58:20 +0300

garrosh gravatar image

updated 2014-08-04 17:03:25 +0300

jiit gravatar image

Since the update to 1.0.7, one of my email accounts won't sync anymore with the error message that advises me to "check certificate". Unfortunately: 1. Mail (SMTP/IMAP) worked with 1.0.5 2. No clue where to check the certificate Any suggestions?

edit retag flag offensive close delete

Comments

Have you tried removing and adding account again?

magullo ( 2014-06-12 09:20:59 +0300 )edit

Not yet. My password is way too long... And I'm too lazy to retype it. Besides, it would still be interesting to know where I could verify/check the certificate in question. And then update it manually.

garrosh ( 2014-06-12 12:16:22 +0300 )edit

There is a new feature in the Settings App / Accounts. Scroll down to the bottom and "accept untrusted certificates".

hardcodes.de ( 2014-06-12 14:26:30 +0300 )edit

I've got the same problem and there should be no problem with my providers certificate. Checking "accept untrusted certificates" makes it work again, but it shouldn't be needed.

Tanghus ( 2014-06-12 15:02:20 +0300 )edit

I noticed the "accept untrusted certificates" feature, but this kinda defeats the purpose of certificates IMHO... Thing is, the mail provider didn't change their certificate, so something happened during/after the update.

garrosh ( 2014-06-12 15:05:56 +0300 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2014-06-13 01:35:31 +0300

idro gravatar image

I just check the certificate like Jolla said, retyping users and passwords , and everything works great don't be lazy guys.

edit flag offensive delete publish link more

Comments

You're absolutely right, lazy shouldn't be an argument. Anyway, I checked what the certificate really says and noticed, that I have added an (unnecessary) subdomain part to the mail server domain. This invalidated the certificate obviously (it was only issued for the domain.tld part). Anyway, what I'd still like to know: is there any place I can check a detailed error message? Something more specific than just "check certificate"? My issue is solved by now, but it would still be nice to know...

garrosh ( 2014-06-17 20:08:08 +0300 )edit

.....good question, unfortunately I don't know where you can find this error message.

idro ( 2014-06-18 10:55:04 +0300 )edit

@garrosh - if you enable qmf logging the SSL errors will be printed there.

in

/home/nemo/.config/QtProject/Messageserver.conf

enable file log and add a path for the log, like for example:

[FileLog]
Enabled=1
Path=/home/nemo/Documents/messageserver.log

Then reboot the device.

VDVsx ( 2014-07-15 09:24:18 +0300 )edit
0

answered 2014-06-15 18:34:18 +0300

VDVsx gravatar image

Email app now only accepts trusted certificates by default, if your certificate is not trusted or self-signed you need to enable mentioned option under account settings(accept untrusted certificates), when this task is done will be possible to upload your self-signed certificates to the device: https://together.jolla.com/question/1607/gui-to-addtrust-ssl-root-certsself-signed-certs/

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2014-06-12 08:58:20 +0300

Seen: 390 times

Last updated: Jun 15 '14