Ask / Submit

Call and People app is a blank, again!!! Help!

asked 2014-11-18 06:30:50 +0300

Makeclick gravatar image

updated 2014-12-25 22:41:41 +0300


Ok, so. I don't know how i managed to do this, but i think i did call, but there did not have any phone number :O and i just "kill swipe" and try to live my life.... but then.. this happened:

People app Call app

Same with google talk and facebook messenger plugins :/

I have tried all i can think of, but nothing helped: pkcon install jolla-contacts jolla-contacts-settings

i did get it working by start it with a Terminal, but not always... I can't recover my people app it will indigate with red ball. Please help! I use Uitukka


HI!! Again!!!! Now i'm using Vaarainjärvi!

Is my Jolla broken or??? Please, someone in Jolla??? How i can reset all my People and contacts without full reset!!!? Debian is easier to me, so please, help me!

Is there some Purge command? Should i use pkcon or other?

If i try to open it from terminal it give this: terminal screenshot

After this, People app open up and there is only facebook contacts, but all gmail contacts is gone.

edit retag flag offensive close delete


Something similar happened to my calendar when I reached a low memory race. The sqlite3 index got corrupted so I had to dump the calendar db to a sql file and from that sql dump create a new db file which I then moved over the old one.

ljo ( 2014-11-18 08:43:10 +0300 )edit

Can you please show the output produced by trying to run an application that accesses contacts from the terminal? For example, from a devel-su -p shell, run 'jolla-contacts'.

MattVogt ( 2014-11-18 09:40:32 +0300 )edit

Only with devel-su -p i get:

"Enjoy your privilages.
cat: /proc/883/environ: Lupa evätty (permission denied)
NOTICE: Env value ignored"

If i run it: Terminal

Makeclick ( 2014-11-18 10:21:32 +0300 )edit

@Makeclick: That output is from 'devel-su', telling you that your session has been granted access privileges. After that, you can run jolla-contacts and the output will hopefully indicate what the problem is.

MattVogt ( 2014-11-18 12:18:35 +0300 )edit

@MattVogt, the output in image supplied by @Makeclick through link in the previous comment indicate db corruption from what I can tell here too.

ljo ( 2014-11-18 12:27:33 +0300 )edit

1 Answer

Sort by » oldest newest most voted

answered 2015-01-10 19:04:36 +0300

Makeclick gravatar image

Ok, I got some answers from Jolla support, thank you Jorma for that! I paste it here, if someone try to sort this out. I will try this IF my phone do this again or I will send it to repair, because I think it's memory problem (hw).

Hope this will help someone!

Jorma (Jolla Service and Support) Dec 29 15:47


We could either A) try to find the problem, like suggested in, or else B) brutally clean up your contacts database (if you have all your contacts backed up to a safe place).

A) MattVogt gave the instruction to run the following command at the Terminal app - the outcome should reveal if there is something wrong with your contacts database:

devel-su -p jolla-contacts > /home/nemo/jolla-contacts.log 2>&1 You will need the remote connection (SSH) password to run this command. -It will not prompt for the password here due to the special redirection (system error to system output) at the end of the command - just type your SSH password and tap Enter. -After few seconds the Contacts app should pop up. Push it aside and return to Terminal. -Do Control-C there to stop the command (if still running). Close Terminal. Then move file jolla-contacts.log out from Phone Memory and send it to us, please. We would check what might be wrong in it.

B) If you sync your contacts with a cloud service (e.g. Google, MS xchange, etc.) and you have no local (unsynced) contacts in your phone then we could try the following: - Delete the account you use for syncing contacts (e.g. Google account) in Settings > Accounts [this is to ensure that no syncing will happen during the next steps] - Visit Settings > Apps > People. Pull down "Delete all contacts" - To ensure complete cleanup, do the following in Terminal app:

systemctl --user stop contactsd.service The following commands will delete your contacts database. Be sure to have your contacts elsewhere in a safe place. Do not give any other commands at this point as you have the super-user rights in effect.

devel-su rm -rf /home/nemo/.local/share/system/privileged/Contacts/qtcontacts-sqlite/* reboot I hope this helps.

Sincerely, Jolla Customer Care

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools



Asked: 2014-11-18 06:30:50 +0300

Seen: 573 times

Last updated: Jan 10 '15