We have moved to a new Sailfish OS Forum. Please start new discussions there.

The phone is locked after any call automatically [released]

Tracked by Jolla (In release)

asked 2013-12-30 15:19:51 +0300

Slawek gravatar image

updated 2017-04-21 18:51:26 +0300

cemoi71 gravatar image

The phone locks automatically after disconnect a phone call. It is ok when someone calls us, but when I call someone, and after the end I want to make another call, I have to unlock the device and swipe down to application screen and chose Phone app again. I think, the phone should not goes to lock automatically in such cases.

Edit (cemoi): Seems to be in my case in Sfos Never seen before...
What happens if lipstick is restarted then?
In my case, If the lipstick interface is restarted, then the issue disappears...
Could be involved with this bug?

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by cemoi71
close date 2017-08-31 01:43:11.073914



This should be an option.

The default of immediate locking the phone is driving me nuts on my other phone, especially when using phone as satnav in a car.

ortylp ( 2013-12-30 15:33:37 +0300 )edit

It looks like this problem: black screen on incoming and outgoing calls

Maybe put your votes there so the problem is being noticed faster.

BonoNL ( 2014-01-24 12:33:47 +0300 )edit

Happened to me exactly the same after the update to sfos

cemoi71 ( 2017-04-21 17:34:32 +0300 )edit

was at first reported as bug, changed to required function.
should be still handled as a bug.
For any required stuff should be a new thread dedicated for this.

cemoi71 ( 2017-04-21 17:40:34 +0300 )edit

That's really annoying that the device is locked after any calls. :-(

cemoi71 ( 2017-04-21 17:42:55 +0300 )edit

2 Answers

Sort by » oldest newest most voted

answered 2017-04-24 14:30:46 +0300

spiiroin gravatar image

The rule is something like: Whenever immediate locking is active, display is off and there is no call -> lock device.

Which should mean that the device gets locked in situations like: The other party ends the call while you have the phone at ear - display is already off and device gets locked when the call state changes from "active" to "none".

Still, while that would be expected, it probably is more like design oversight rather than something that was actively wanted.

Might be interesting to know if gets locked when you terminate the call from ui (i.e. display should be on when the call ends)? If it does, there are some unexpected issues somewhere.

edit flag offensive delete publish link more



i'm glad to see your answer.
interesting question that you have. now ican give you more info.
Phenomenon is reproducible with this different cases:

Case 1) Display is on then i give a call, then i put the phone on my ear and display turn black. After that, i put it away from ear, i may wait a little bit or speak with speaker. Then i stop the communication. Then after, It lock itself directly at the moment the phone bring the notification that the call is finished.

Case 2) i have the display on, at the moment i get call. I put the phone on my ear. display goes black. Then after i put it away from ear, and the call is stopped from me or the caller. After that, it lock itself at the moment where notification of the communication finished appeared.

Seems that it appears only with the conditions that i put it to my ear and display turn to black. And happens then exactly at the moment where the notification of communication is finished appears.
It don't happens if the display don't turn off by bringing near of the ear. How long is turned off is not the matter it could be 1 second or 2 hours...

Hope that my explanations are well done enough...
I have not the habit to describe with such typ of details...
thank you very much for the help and your interest on it.

cemoi71 ( 2017-04-25 00:05:42 +0300 )edit

Thanks for your precise descriptions, @cemoi71. Have you activated "Settings > Device lock > Automatic locking > No delay"? For now, until we figure out what do do, please consider selecting "Automatic locking > 5 minutes".

jovirkku ( 2017-04-28 13:57:28 +0300 )edit

@jovirkku thank you very much for answering.
yes the no delay is activated, because the 5 min delay is too long for me.
I wanted a 2 or 1 min to avoid my child going on my device if i forget to lock it. (screen saver time is relativ short too.)
Could you please report to your team that it would be fine that the lock delay options maybe lined up a little bit more to the screen-saver time? means be able to choose 1 or 2 minutes.
Currently i prefer more no delay to 5min. but 1 or 2 min would be better than the no delay.

cemoi71 ( 2017-04-28 15:06:02 +0300 )edit

answered 2017-08-31 01:42:52 +0300

cemoi71 gravatar image

Problem fixed in release Many thx Jolla team

edit flag offensive delete publish link more

Question tools



Asked: 2013-12-30 15:19:51 +0300

Seen: 888 times

Last updated: Aug 31 '17