Ask / Submit
14

Bug: USB PC connection on Mint [released]

asked 2013-12-24 22:57:06 +0300

msknight gravatar image

Not sure whether this is the phone or Mint ... however, other phones work.

I connenct the USB and put it in PC mode. The "Sailfish" device shows up in Nemo, but on clicking on it I get...

"The folder contents could not be displayed. Sorry, could not display all the contents of "Sailfish": Failed to get folder list: -1: Unspecified error"

Mint is 64bit cinnamon latest release.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by nthn
close date 2017-05-11 16:58:31.239554

Comments

Exactly the same error here on Mint 16 Cinnamon - can't mount Jolla .... (can mount N6 through USB on same PC without problem)

Manankanchu ( 2013-12-24 23:10:24 +0300 )edit

Please add in question title the Mint version, and without using 'latest version', as when this Q will be read 1 year from now today's 'latest version' won't be likely the latest one anymore, so use e.g. Mint 16 Cinnamon Edition 64bit.

simosagi ( 2013-12-25 09:59:45 +0300 )edit

I run Linux Mint 14 Nadia 32 bit - when i connect Jolla through USB i can't copy files. Folders and files will be ALWAYS copied to /home/nemo with size=0 and i can only delete them via bash.

hewi ( 2013-12-25 11:32:49 +0300 )edit
1

The same applies for my Ubuntu 13.10 64bit version.

thwint ( 2013-12-25 16:08:47 +0300 )edit

check out this guide https://wiki.archlinux.org/index.php/Mtp

igor ( 2013-12-27 18:24:26 +0300 )edit

10 Answers

Sort by » oldest newest most voted
4

answered 2014-01-05 22:03:56 +0300

cos gravatar image

updated 2014-01-05 22:41:17 +0300

thwint gravatar image

Same here on Mint 16. Looks like Mint's mtp support is broken. Either use WLAN+ssh to access files on device, or install alternative mtp client. I used simple-mtpfs which works nicely. I hope this is fixed soon by Mint developers.

edit flag offensive delete publish link more
2

answered 2014-04-08 17:21:11 +0300

Makeclick gravatar image

Easy fix :D... i don't know why but here you go... I use Ubuntu x64 and Asus G5 series.

You have USB3 port, right? Try plug Jolla there ;). Or try other USB holes. I got this working by pluging it in USB3 port. Tellnet recovery will ONLY working on USB2 (same laptop). Odd, but hope this will help.

edit flag offensive delete publish link more

Comments

1

Funny, tried USB2 ports on LinuxMint 16 / 64 without success (as many times before) - then tried USB3 port and immediately got 2 mounts (Jolla internal memory and SD card), after unplugging I plugged Jolla again into USB2 port and got both mounts again.

  • Copying from/to internal memory went perfectly
  • Copying from SD to PC went fine, copying to SD crashed the mount to SD

Funny thing - thanks for this hint !!

Manankanchu ( 2014-04-08 21:43:35 +0300 )edit

I have an older Thinkpad X220t laptop that doesn't have a USB3.0 port.

Slavov Welsinksi ( 2014-04-09 21:26:43 +0300 )edit

@Welsinki You got this same error? "The folder contents could not be displayed. Sorry, could not display all the contents of "Sailfish": Failed to get folder list: -1: Unspecified error" OS you using? Windows7? With Windows 7 it could take some time to install the MTP drivers, so be patient :). Look it from system management did it find that usb device? Is there some error or what? Lenovo says: Three USB 2.0 (one powered), so one is different (maybe).. try different USB holes and... be patient :). Hope i did help even a little.

Makeclick ( 2014-04-10 16:44:55 +0300 )edit

Oh wow, this actually worked! Thanks!

nthn ( 2014-04-10 17:12:10 +0300 )edit

@Makeclick No, I'm on Ubuntu 14.04. It just doesn't show up at all. I've tried every method described so far.

Slavov Welsinksi ( 2014-04-10 21:32:16 +0300 )edit
1

answered 2013-12-25 04:10:42 +0300

nander gravatar image

updated 2013-12-25 04:11:00 +0300

No issue on kubuntu - latest 64 bit. Mint may be the problem.

edit flag offensive delete publish link more
1

answered 2014-04-05 21:32:04 +0300

petros gravatar image

I have this issue with ubuntu 13.04 lately. I plugged my jolla, I choose pc connection but it doen't appear in my file manager! :-(

edit flag offensive delete publish link more
1

answered 2014-04-05 22:24:51 +0300

Slavov Welsinksi gravatar image

Same problem on Ubuntu 14.04 LTS release candidate. It worked yesterday but it's not working today after an update.

I've tried to see if it's an mtp problem but it's not, gMTP can't connect either.

edit flag offensive delete publish link more

Comments

1

It is a libmtp issue. Which means that all programs who use it don't work (like gMTP). All the mentioned distros where it does not work have an outdated/buggy version of libmtp.

Philippe De Swert ( 2014-04-06 14:50:50 +0300 )edit
1

answered 2014-04-06 01:08:17 +0300

tvicol gravatar image

Linux mint lmde with cinnamon works fine for me, no problems with usb.

edit flag offensive delete publish link more
1

answered 2014-04-08 09:39:08 +0300

je gravatar image

As far as I know all ubuntu and mint flavours based on debian. They mainly use packages from testing stage due to actuality. According the debian changelog there was no changes of the code of libmtp since august'13. By the way I am on debian testing with kde desktop and I can access my Jolla and copy files and music. So I do not believe in a buggy

But I have a suspicion. Probably some of you you use automount for removable media. Then the operating system try to mount Jolla. One correct me, but this is not possible because the Jolla device only support MTP, which does not support the mounting of a file system on a device (for more info please read this).

I think the automounting mechanism ist the reason why some of you get stuck. A comment would be nice if I am right or wrong.

edit flag offensive delete publish link more
0

answered 2013-12-27 16:26:55 +0300

barmeier gravatar image

Hi,

to copy music on your phone you can use banshee on Mint. The Jolla phone will show up as MP3 player in banshee and you can sync the phones music library with banshees music library.

Hope this helps.

edit flag offensive delete publish link more

Comments

Am using Banshee in Kubuntu 12.04 and the Jolla does indeed show up there with playlists and the music library (when in USB PC connection mode). But, how does the sync work? Especially with the external SD card not being recognized leading to space issues. A thread for itself, I guess.

Deonith ( 2014-02-07 01:06:00 +0300 )edit
0

answered 2014-01-05 15:11:56 +0300

barmeier gravatar image

Works for me since last update for Mint 15 LMDE.

edit flag offensive delete publish link more

Comments

I'm just going to load mint 16 on a laptop, and have since updated to 1.0.2.whatever, so I'll try it again today.

msknight ( 2014-01-05 15:17:52 +0300 )edit
0

answered 2014-04-05 22:57:36 +0300

Claudio gravatar image

I mounted my Jolla in the raspberry pi, Arch and Chakra Linux... maybe Mint use different usb handler?

edit flag offensive delete publish link more

Question tools

Follow
4 followers

Stats

Asked: 2013-12-24 22:57:06 +0300

Seen: 1,619 times

Last updated: Apr 08 '14