Ask / Submit
7

[BUG] No data connection after update RC 1.1.2.15 [released]

Tracked by Jolla (In progress)

asked 2015-02-19 17:05:09 +0300

kaulian gravatar image

updated 2015-02-25 21:59:06 +0300

chemist gravatar image

After upgrade to 1.1.2.15 data connection throught my Orange France provider is not available

The problem is in 3G or 4G. The connection failed and I have the ! symbole.

Despite the rmnet0 got an ip and route seems OK.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by chemist
close date 2015-02-25 21:59:38.956139

Comments

That s seem a DNS problem, i try to connect to my openvpn with SecureFishNet and connexion is successful

kaulian ( 2015-02-19 20:37:03 +0300 )edit

Same problem here (Orange), my data connection don't work after the upgrade. i have the symbol "!" I try to reboot, reboot connection, remove the sim and the battery. Help !

Cl2ment ( 2015-02-20 00:19:41 +0300 )edit

5 Answers

Sort by » oldest newest most voted
7

answered 2015-02-20 22:38:44 +0300

tigeli gravatar image

I think I found the problem (and fixed it), still waiting for @kaulian and @Cl2ment to confirm my fix.

edit flag offensive delete publish link more

Comments

2

@tigeli : Well done ! the problem is fixed for me ! Thank you very much for sending me a special rpm at 21:30 ! Great support from Jolla. Keep up the great work !

Cl2ment ( 2015-02-21 00:16:52 +0300 )edit
1

Nice! Looks like the early access to updates has already been useful :). Out of curiosity, was it (again) due to a weird configuration on Orange side?

Sthocs ( 2015-02-21 03:07:24 +0300 )edit

Same problem here. However dns trick seems to work

alexxy ( 2015-02-21 12:01:35 +0300 )edit

thanks @tigeli for the fix

kaulian ( 2015-02-24 20:49:51 +0300 )edit
3

answered 2015-02-20 11:08:56 +0300

kaulian gravatar image

In fact Yesterday, before reboot I tried some hack.

This morning when I see your comment i think some can resolv our problem.

So could you edit in root the file that begin by cellular in /var/lib/connman/

Between the lines IPv4 and IPv6, add that

Nameservers=80.67.169.40;

Then reboot (yesterday I only restart connman but that seems not efficiant)

The DNS server can by google (8.8.8.8) or other in this configuration it's FDN.fr DNS with no censurship :)

edit flag offensive delete publish link more

Comments

1

It works, thank you. :) But I think to change operator is a good thing.

Renault ( 2015-02-20 11:28:36 +0300 )edit

it would seem that the operator has some problems providing dns-server addresses through mobile data connections..

tigeli ( 2015-02-20 11:39:56 +0300 )edit

Yes but we don't have this issue with previous release and Orange is the BIG french operator

Do change something in connman, do you want more log to correct this bug ?

kaulian ( 2015-02-20 12:50:29 +0300 )edit

@kaulian Yes, I need logs or Orange sim with data enabled to look what's wrong with it. Can you install connman-tracing to your phone by "pkcon install connman-tracing" and reboot. Then try to reproduce the problem and send me (tigeli@jolla.com) the file connman.log which you can create with "journalctl -b >connman.log".

tigeli ( 2015-02-20 12:57:12 +0300 )edit

Done !! I keep connman-tracing for the moment, if you need more information

kaulian ( 2015-02-20 13:27:12 +0300 )edit
1

answered 2015-02-19 18:26:46 +0300

Renault gravatar image

Of course, I have this issue (see https://together.jolla.com/question/82037/release-notes-upgrade-112-yliaavanlampi-early-access/?answer=82068#post-id-82068).

It is another operator specific issue or more general ?

edit flag offensive delete publish link more

Comments

No my connection go perfect. I rebooted and the !symbol desappear for me.

Claudio Maradonna ( 2015-02-19 20:40:44 +0300 )edit

Hum, I have tested many reboot or change SIM and other advice : no change, I have the bug again.

Renault ( 2015-02-20 00:20:30 +0300 )edit

@Renault : same for me

Cl2ment ( 2015-02-20 00:29:39 +0300 )edit

Debug with Jolla team in progress ... seems to be a bug in ofono

kaulian ( 2015-02-20 15:47:44 +0300 )edit
1

answered 2015-02-24 14:18:41 +0300

Aard gravatar image

We are currently testing a fix for that internally. My current guess is that we'll publish an updated version of 1.1.2 tomorrow.

edit flag offensive delete publish link more

Comments

Does the fix also solve this issue: https://together.jolla.com/question/82037/release-notes-upgrade-112-yliaavanlampi-early-access/?answer=82426#post-id-82426

I'm not sure if there is similar issue as in this thread or separate one.

mastal ( 2015-02-24 14:46:33 +0300 )edit
0

answered 2015-02-20 09:52:29 +0300

Cl2ment gravatar image

updated 2015-02-20 21:30:45 +0300

Up ! Big problem here. No connection data since the update. Jolla, what can we do for solve the problem ???

edit flag offensive delete publish link more

Comments

3

if you need your connection, then unsubscribe from pre release. Not meant to be rude, I'm serious

c.la ( 2015-02-20 17:39:17 +0300 )edit
1

@c.la Thank you for the advice, it really helps us, I'm serious.....

Cl2ment ( 2015-02-20 19:18:51 +0300 )edit

@c.la you cannot downgrade - you'd need to fact. reset to revert back...

chemist ( 2015-02-21 03:29:55 +0300 )edit

There's a workaround suggestion in a comment above, or be patient until we publish the fix. We're currently testing it.

Aard ( 2015-02-24 15:14:27 +0300 )edit

@Aard : I have already tested the fix with @tigeli and since then my data works well : https://together.jolla.com/question/82147/bug-no-data-connection-after-update-rc-11215/?answer=82517#post-id-82517 And i confirm the fix because i sent the .rpm to another Jolla with the same problem, and the problem is fixed also. Thanks again for the support.

Cl2ment ( 2015-02-24 15:56:22 +0300 )edit

Question tools

Follow
2 followers

Stats

Asked: 2015-02-19 17:05:09 +0300

Seen: 1,364 times

Last updated: Feb 24 '15