Ask / Submit
13

[Feature request] Wait to load page in browser until connection established

Tracked by Jolla

asked 2015-02-27 15:17:45 +0200

Louis gravatar image

updated 2016-08-17 11:33:32 +0200

jiit gravatar image

In SailfishOS 1.1.2.x the pop-up to establish internet connection which ask for Mobile data/WLAN has been disabled for the browser while still active in other apps like the Mail.

When you try to load a website in the Sailfish browser and isn't connected to the internet you'll simply get a 404 - Page not found.

I suggest you re-enable the establish internet connection pop-up for the browser and make it wait to load the desired page until a connection has been established.

If you open the browser from minimized state and a page have previously been loaded, but an internet connection has not been established the connection notification should not pop up until you want to load a new page for better offline viewing.

edit retag flag offensive close delete

Comments

2

why to complicate this? If WiFi not available use mobile data. What is the problem with that? WiFi should always have the priority (or faster). Phone should be able to figure this out.

Vesa ( 2015-03-03 14:24:12 +0200 )edit

@Vesa, the problem is when you are not connected to data nor wifi, if you try to use the browser there is no popup that allows to connect fastly (it was the case before); you need to open the parameter app for that.

Vivien ( 2015-03-03 19:01:37 +0200 )edit

@Vesa

I don't want my phone to autoconnect to neither internet or GPS. The user should always get asked. This is both for privacy, security and economic reasons and one of the main reasons I brought a Jolla phone. Eg. if I'm aboard I don't want my phone to go crazy on mobile data if I've access to a WiFi hotspot, but hasn't typed the wifi password yet.

Louis ( 2015-03-09 12:20:39 +0200 )edit
1

Please... NO! We only just got rid of the damn thing. I much prefer the phone to automatically connect. If I've manually disabled connections, or no connections are available, just show an error. The solution is for quick toggles to be available in the Events View. Swipe up from bottom. Enable wifi/4g. Swipe up again to get back to the app.

bilgy_no1 ( 2015-03-09 20:58:29 +0200 )edit

@bilgy_no1 I would love to have jolla automatically connect to my preffered wifi network or turn on mobile network if needed but there is no such a thing here yet. You have either all time enabled wifi and mobile internet connection or you have no connection to the internet. There is only automatic switching between internet connection sources if both wifi and mobile are turned on...which in my case is very battery draining. In addition to that, event's view won't be available from the bottom swype of the screen in sfos 2.0 so it'll be atleast one swype more to accessing quick toggles.

Mądry ( 2015-03-09 22:25:38 +0200 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2015-03-09 17:56:54 +0200

Mądry gravatar image

updated 2015-03-09 19:23:21 +0200

As an old nokia N9 and N900 user I feel of it like a little step back. I loved the way the maemo5 and harmattan systems dealt with internet connections. You could set your prefered connections which would be automatically estabilished if the apps asked for it. The pop-up would come out if the chosen connections was unavailable. I chose the jolla phone as a replacement for my n9 because of those similarities to harmattan like the internet pop-up which doesn't exist in any other system iirc. The sailfish implementation lacks the automatic connection ability but it's still useful...or was :( Through those months of using Jolla I started to more often rely on the patch which adds system settings quick toggles to event's view but it was like a must for me. Not all aplications ask for internet connection bringing the pop-up and this inconsistency forced me to start toggling mobile internet/wifi manually more often. After updating to U11 the pop-up stoped appearing not only in browser but any other app which ealier would trigger it. Curious if something went wrong with process of updating I looked here to find out the so beloved by me core functionality has been disabled. I feel a little sad right now. I hoped it would be someday developed further. Now it is even more cut down version of my n9/00 which I truly loved for it's smartness.

tl;dr I like the internet connection pop-up. I would love it to be more developed and in the end brought back as fully working. Automatically connecting to internet jolla would my dream come true scenario ( of course with option of disabling this functionality and ability to prevent it from connecting to internet in background as it was done in nokia n9...but a little less buggy ).

edit flag offensive delete publish link more
1

answered 2015-03-03 14:11:47 +0200

Vivien gravatar image

It has also been disabled for android application! Moreover, there was the same problem with update to 1.0.4.20 (see https://together.jolla.com/question/33867/10420-internet-connection-menue-does-not-start-automatically/).

I think it's a bug, not a feature.

edit flag offensive delete publish link more

Comments

This ticket is not about the fact that the connection notification has been disabled in the browser, but about reintroducing it and wait to load a page until a connection has been established. As this ticket is "Tracked by Jolla" it's every likely that this might be introduced in a later release.

I've talked with developers on IRC and they told me that the connection notification has been disabled on purpose do to dysfunctions. I guess being unable to view a loaded page in offline mode without getting disturbed with the connection notification being shown again and again.

Louis ( 2015-03-09 11:59:34 +0200 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2015-02-27 15:17:45 +0200

Seen: 265 times

Last updated: Mar 09 '15