Ask / Submit

Calendar multiplies its calendar (-subscription)

asked 2015-08-26 23:24:15 +0300

nilOlin gravatar image

updated 2017-05-20 19:37:38 +0300

groxxorg gravatar image

Since about a week I have the very strange behavior that the calendar-subscription multiplies itself in 'manage calendars'. Resulting in having double, triple etc. entries in the calendar. The calendar used is a Google sync. The only way to get rid of it (for an hour or so) is to delete the Goggle account in settings and reinstall.

In the real Google calendar (website etc.) the entries are not doubled, tripled etc.

What is that?

edit retag flag offensive close delete



Thank you for this bug report. This is caused by a bug in our sync plugin. I believe that it will be fixed by which is aimed for 1.2.0 release.

chris.adams ( 2015-08-27 06:14:02 +0300 )edit

Unfortunately, this fix will not make the 1.2.0 release as we are still resolving some issues with it. It will make 1.2.1 instead.

chris.adams ( 2015-09-09 07:19:50 +0300 )edit

Unfortunately this bug is still present or again present in SFOS 2.1.1. The suggested solution (answer from @groxxorg) did solve it (at least for now).

naytsyrhc ( 2017-08-04 11:46:16 +0300 )edit

Also still existing in @chris.adams

JSEHV ( 2017-10-08 09:18:53 +0300 )edit

5 Answers

Sort by » oldest newest most voted

answered 2015-10-22 00:03:00 +0300

mattikbk gravatar image

I managed to remove the extra calendars by using the answer from :

sqlite3 /home/nemo/.local/share/system/privileged/Calendar/mkcal/db
SELECT * FROM Calendars;
DELETE FROM Components WHERE Notebook='<insert calendar id from the previous listing>';
DELETE FROM Calendars WHERE CalendarID='<insert calendar id from the previous listing>';
edit flag offensive delete publish link more

answered 2017-05-20 19:31:36 +0300

groxxorg gravatar image

updated 2017-05-20 21:48:05 +0300

Quick & Clean Solution: Sometimes my calendars also start to multiply themselves. The calendars are syncronized with my OwnCloud - there are no problems with that, only on my Jolla. Instead of deleting single superfluous calendar as mentioned above, you can delete all multiple calendars in a bunch by deleting the following file:

devel-su rm /home/nemo/.local/share/system/privileged/Calendar/mkcal/db

It works well; After a reboot everything looks healthy again. Your superfluous calendars will not show up, only the desired calendars will be displayed. I found the way to this solution here. (thx to @nomeata)

edit flag offensive delete publish link more


Thanks you for that solution. I will test it next time my calendar (on a owncloud too) will begin to mulitply itself!

VincentB ( 2017-05-22 17:37:46 +0300 )edit

Works for me. My calendar is synced from Baikal, not OwnCloud, so this is probably not related to a particular CalDAV server.

Yenya ( 2017-06-20 11:08:56 +0300 )edit

answered 2016-10-28 17:43:54 +0300

Conrad gravatar image

This looks to have become quite a bit worse since Fiskarsijoki/ a daily event I have on Google calendar is now repeated 14 times each day. Going to try the above deletion trick later to see if it can help manage things in the meantime.

edit flag offensive delete publish link more


Hello, before deleting the entries from the db, may you report the duplicated lines from Components table ? (sorting out something like SELECT * from Components if you don't have too many events stored in your calendar)

By increasing the verbosity in the log (, may you see your Google event being added when you trigger a sync, and may you find the server answer from the log ?

This may help to find out what is causing this…

Damien Caliste ( 2016-10-28 18:02:27 +0300 )edit

Will try to get you some examples and take a look at the log too.

Conrad ( 2016-10-28 18:05:27 +0300 )edit

@Conrad, thank you !

Damien Caliste ( 2016-10-28 18:16:07 +0300 )edit

So, some more data: my database was partly corrupt when I started sqlite3: queries would get results, but finish with "Error: database disk image is malformed". I .dumped it, .read into a new one and replaced the database, losing around a dozen items out of 8,000 in the Google calendar I'm getting the duplication in. An example of a problem event is a repeating daily meeting, where for every day the event repeats the calendar creates a new copy of the event. I have 55 copies of it from 55 days at one time of day; then someone changed it to another time of day and I've 14 copies of it from the 14 days since. Fields

  • notebook,type,summary,category,datestart,datestartlocal,starttimezone,hasduedate,dateenddue,dateendduelocal,endduetimezone,duration,classification,location,description,status,geolatitude,geolongitude,priority,resources,sequence,comments,attachments,contact,invitationstatus,recurid,recuridlocal,recuridtimezone,relatedto,transparency,localonly,percent,datecompleted,datecompletedlocal,completedtimezone,datedeleted,extra1,extra2,extra3

.. are the same for all 14 recent copies of this event, with values

  • xxx|Event|xxx||1477061100|1477064700|Europe/London|0|1477062000|1477065600|Europe/London|0|0|hangout|daily checkin|0|255.0|255.0|0||2|jolla-sociald:gcal-id:xxx_20161021T144500Z|||0|1477061100|1477064700|||0|0|0|0|0||1477668853|||0

(I replaced a few UIDs and private strings with "xxx").

3 rows of fields that do vary (again, with part of a UID replaced with 'x')

  • componentid,datecreated,datestamp,datelastmodified,url,uid,datedeleted
  • 15754|1477070720|1477070720|1477070720|urn:x-ical:xxxxxxxx-d951-4999-a902-636a88 ab1166|xxxxxxxx-d951-4999-a902-636a88ab1166|1477668853
  • 16008|1477137225|1477137225|1477137225|urn:x-ical:xxxxxxxx-d19e-4d49-89c2-2a80b3 c28d85|xxxxxxxx-d19e-4d49-89c2-2a80b3c28d85|1477668853
  • 16217|1477144993|1477144993|1477144993|urn:x-ical:xxxxxxxx-32a7-4256-ab3b-c81a05 636592|xxxxxxxx-32a7-4256-ab3b-c81a05636592|1477668853
Conrad ( 2016-10-28 20:22:29 +0300 )edit

Hmm that was difficult to format legibly! Will look into the logs next.

Conrad ( 2016-10-28 20:29:35 +0300 )edit

answered 2015-09-09 11:29:21 +0300

nilOlin gravatar image

Actually I found a solution for this: I reset my Jolla to the factory settings and started from scratch (incl. the suggested updates etc.). A bit of work but now the phone runs much smoother and faster, thus not only this calendar issue is solved. I suggest a few people her to do the same if their phone has issues.

edit flag offensive delete publish link more


I've tried this and it results in exactly the same problems after some time.

konstin ( 2016-10-28 17:57:43 +0300 )edit

answered 2015-09-09 17:20:24 +0300

AzP gravatar image

I believe this is a duplicate of:

edit flag offensive delete publish link more


Not sure. I thinks it is a bug too, might have the same source, but the behaviour described is different (I did not create an event on my jolla).

nilOlin ( 2015-09-09 17:23:45 +0300 )edit
Login/Signup to Answer

Question tools



Asked: 2015-08-26 23:24:15 +0300

Seen: 588 times

Last updated: May 20 '17