Calendar shows Facebook events I'm not attending or even actively rejected [released]

asked 2013-12-25 22:24:42 +0200

Nux gravatar image

updated 2013-12-25 22:32:46 +0200

Stskeeps gravatar image

When I open the calendar (original from Jolla) I see some Facebook events. This is nice for events I accepted, but the calendar also shows events I'm not attending or even actively rejected.

There is also no way to reject, nor remove events - nor directly, nor by opening Facebook. There isn't even "view on Facebook" button/link.

Ideally I this would work like this:

  1. In settings I would be able to choose which events are shown (only attending, attending and non-rejected, all).
  2. In calendar I should be able to go to Facebook.
  3. [optional] Have a menu option to reject or hide an event in the calender application. Would be nice, but optional if above will be implemented (the same goal would be achieved with a bit more steps).
edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by JSE
close date 2016-02-08 12:13:04.401625

Comments

1

My calendar is polluted by loads of undesired facebook events too. This needs a fix. :)

Orologiaio ( 2013-12-26 00:31:04 +0200 )edit

I would like to have that too! I want to sync contacts but not birthdays with facebook...so more detailed settings are required for this as you stated.

ttommila ( 2014-02-09 14:24:47 +0200 )edit

This is a huge issue for me since some not-so-computer-savvy friends have invited me to events that take place EVERY DAY between two dates, for the span of up to a year.

AzP ( 2014-06-09 14:25:21 +0200 )edit

With the newest Sailfish version, a Facebook event I first accepted ("Going"), and then declined ("Not going"), disappeared from my Jolla calendar. =) It did appear when I accepted, and I can still see my other Facebook events in the calendar. So maybe this got fixed? Edit: Tried with another events which I haven't accepted first, as those are also visible in Jolla calendar. I declined it and it also disappeared.

tajunta ( 2014-06-16 19:52:52 +0200 )edit

As tajunta wrote, this is fixed.

JSE ( 2016-02-08 12:12:47 +0200 )edit