We have moved to a new Sailfish OS Forum. Please start new discussions there.
0

Jolla C: media app content not showing when opened (takes a while)

asked 2016-07-28 14:03:59 +0300

t0mps0 gravatar image

updated 2016-07-28 20:04:07 +0300

palikao gravatar image

Wonder what's with the media app? I have few thousand mp3 tracks on my micro card and everytime I open media app, it first shows, that there's no content. After a while everything's loaded alright. Is this a bug?

edit retag flag offensive close delete

2 Answers

Sort by » oldest newest most voted
1

answered 2016-07-28 14:13:36 +0300

jota gravatar image

thats ok. There is a tracker background process, that collects the data. It takes some time. On console you can control it with tracker-control command. But there is no need to do it, until you have errors.

edit flag offensive delete publish link more
1

answered 2016-07-28 14:17:01 +0300

r0kk3rz gravatar image

updated 2016-07-28 14:17:10 +0300

When the Media App starts up it queries the tracker database for all of the media items and parses them all, which takes time, this isn't a bug its just how the thing is designed.

Other media players that use tracker don't exhibit this behavior because they're designed to lazy load from the database rather than load the whole thing at startup.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2016-07-28 14:03:59 +0300

Seen: 142 times

Last updated: Jul 28 '16