Ask / Submit
43

Show proper length of songs over one hour [released]

asked 2013-12-25 00:06:33 +0200

Jonni gravatar image

updated 2014-07-24 10:47:15 +0200

jiit gravatar image

Songs with longer duration than one hour are only showing the length in minutes over the last full hour. This causes a track of 62 minutes 49 seconds (1:02:49) be shown as 02:49 in the Media application. Also if the user scrolls the seek bar to over 59 minutes, 59 seconds the seek bar's value is shown counting from zero.

I have multiple mixes that are over 1 hour in my music library and it's confusing to see then listed as short tracks.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by JoHe
close date 2016-09-02 14:11:47.673229

Comments

Great that someone has reported this. I wouldn't say that this is a big problem. It is just a little bit annoying and I hope that it will be fixed sometime in the future. I can see how easy it is to not notice this bug when developing, and I only noticed it since I mostly listen to PODcasts.

k.gramner ( 2013-12-25 14:50:04 +0200 )edit

I also noticed that bug. I vote for this issue.

w32blaster ( 2013-12-30 08:28:29 +0200 )edit

Same bug in gallery

kelvan ( 2014-01-05 18:51:02 +0200 )edit
1

Just for completion here is a video demonstrating this bug: Video

Strahlex ( 2014-02-19 15:38:21 +0200 )edit

does anyone know when this was fixed? or was it even fixed?

chemist ( 2014-03-05 15:12:38 +0200 )edit

1 Answer

Sort by » oldest newest most voted
8

answered 2014-03-10 10:24:30 +0200

jovirkku gravatar image

There will be a fix to this in SailfishOS release 1.0.4.x.

edit flag offensive delete publish link more

Comments

Hurray! Thanks!

w32blaster ( 2014-03-11 15:45:28 +0200 )edit

Question tools

Follow
3 followers

Stats

Asked: 2013-12-25 00:06:33 +0200

Seen: 252 times

Last updated: Mar 10 '14