Ask / Submit
71

(2.0.2.X) Battery drain

asked 2016-07-31 15:43:11 +0300

malibu1106 gravatar image

updated 2016-09-29 15:42:22 +0300

Hi guys, are someone experiencing the same trouble with battery life since 2.0.2.48 ? When i go to sleep with something like 12/13% life, i wake up and the phone is off, Before update, i wasn't losing any percent of battery.

Am i the only one ? Thanks

EDIT : Still have this problem .. Didn't found the reason but this trouble seems to be more significant in sleep mode, to be honest, when i'm using the phone, the battery consumption doesn't surprise me. I'm using Jolla 1, but the problem seems to affect all devices on 2.0.2.48.

Is there a way to set the min and max cpu freq on Jolla 1 ? I remember on n900, with a higher max cpu freq, and a lower min cpu freq, you was able to win performance & battery life.

EDIT 29/09/16 : I saw a lot of people talking about flight mode, and in the "lost" changelog of 2.0.4 i remember i saw "Issue of battery draining in flight mode fixed" I want to precise that i never uses the flight mode.

edit retag flag offensive close delete

Comments

4

actually it feels like the battery life of my Jolla 1 improved since the update, but I didn't take any measurements

till ( 2016-07-31 15:52:46 +0300 )edit
4

nothing negative so far

pawel ( 2016-07-31 16:00:17 +0300 )edit
5

Had the same problem last night. However during the day I don't feel like my battery life is worse. EDIT: Tonight i put my phone on airplane mode, only dropped 2% overnight.

Shmet ( 2016-07-31 19:04:03 +0300 )edit

Battery life is good for me, no special issue with latest update. Maybe even a little bit better, but that's only a vague feeling.

Tofe ( 2016-08-01 10:58:22 +0300 )edit
5

Good battery life here, few calls, two email accouns syncing, internet browsing, some other usage and 1,5 hours video playback, I'm going to bed having battery at 67%.

goldenm ( 2016-08-01 23:25:56 +0300 )edit

18 Answers

Sort by » oldest newest most voted
15

answered 2016-08-01 20:41:13 +0300

Shmet gravatar image

updated 2016-08-02 12:33:03 +0300

Battery life is definitely worse for me too. 2 weeks ago I sent 2-3 texts in total and my battery lasted 7 days doing nothing and still had about 20% (I was bragging about it, so I remember).

Night after update I had 17%, next morning my phone was dead. Last night I put my phone on airplane mode, lost 2% overnight. Today I started using my phone at 82%, I have sent only 1 text and checked the clock a couple times. At time of writing my phone is at 54%, so I lost 27% in 12hours.

Theoretically on same usage as 2 weeks ago: now, after the update, I would last only 3-4 days instead of 7 days.

So, to answer your question: No, you are not alone.

EDIT: Done 2 days with a full battery, same usage as last week, when I lasted 4-5 days.

edit flag offensive delete publish link more

Comments

1

Yes, you are not alone. I have had fully charged phone today and anter 8 hours of almost idle (8 calls, 30 mins of wifi surfing) and now it is only 35percent left.

But probably this is because battery was charged only once for the very first time.

Andrej ( 2016-08-01 20:50:57 +0300 )edit

I lost 20% every night, without doing anything, no wifi, no data, no android, no bluetooth, just 2G ..

malibu1106 ( 2016-08-03 14:11:07 +0300 )edit

Yes, my Jolla tablet battery now goes from fully charged at 7am (powered off overnight charge) to shutdown at 2% battery at around afternoon if wifi left turned on. Light usage, about 40mins email / web browsing followed by idle with wifi on.

Tried yesterday - switched to airplane mode after 40mins use as above. Only other use for day was gallery for 15mins. Battery was at 4% by midnight. Before upgrade to 2.0.2.48 normally I could get 2 days between charges with much more frequent use.

Phone also upgraded to 2.0.2.48 and no problems. Battery life normal.

Still love my Jolla tablet and phone!!

ricardo ( 2016-08-04 10:26:31 +0300 )edit

If someone knows a good application with details for battery consumption ? I need to find what is killing my battery life .. i tried battery monitor, but it seems to just show the current load. Any idea?

malibu1106 ( 2016-08-04 13:14:46 +0300 )edit
1

there are charge monitor, hunger meter and battery log applications

Andrej ( 2016-08-04 13:18:44 +0300 )edit
9

answered 2016-08-22 09:12:54 +0300

juhlii gravatar image

Before Aurajoki I didn't have to charge my Jolla Phone more than once a week. Now I can barely manage three days. Note: I use it "only as a phone": calls and sms, 2g network (data off), wifi off 99,5% of the time, no data syncing.

edit flag offensive delete publish link more

Comments

2

2.02.50 didn't fix it, so I'm downgrading to Taalojärvi and wait for a decent fix for the huge battery drain of 30% per day with practically zero usage.

juhlii ( 2016-09-04 11:15:06 +0300 )edit
2

Same with mine one with 2.02.51. Battery drain of 16 % even with 2G over night. Hopefully Jolla does something and very fast. ASAP. As like this it is very dffiicult to assure Jolla C (and Jolla 1) to be superior. Jolla, pls. hurry up!

N9Sailfish ( 2016-09-06 08:45:34 +0300 )edit

also flashed jp1301 back to 2.0.1.11 for long battery life. 2.0.2.xxea needs to be fixed!

jolladiho ( 2016-09-06 14:33:52 +0300 )edit
8

answered 2016-08-24 11:04:10 +0300

aleeex87 gravatar image

I can also confirm the issue. With Aurajoki it goes from fully charged to zero in less then 48 hours with about 10 minutes of calls and wifi, data,3g turned off.

edit flag offensive delete publish link more

Comments

1

Yes same for me with Jolla 1, battery drain is dramatic.

richie ( 2016-10-04 09:30:40 +0300 )edit
7

answered 2016-09-19 14:36:06 +0300

Piotr gravatar image

Can confirm. Yesterday morning I've had 70%, almost no activity (like 2 SMS, 15 minutes of surfing the web, a short phonecall or two) and today morning it had 4%. Today after 4 hours of usage (some web, some e-mail - but not a lot - and about 40 minutes calls) I'm almost at 60%. At the end of the day it will be dead. On previous build I had to charge it once per 2-3 days of usage. No it looks like I will have to charge it every 12h.

IMHO this should be fixed ASAP.

PS That's my first bigger problem with Jolla in almost two years. Great job btw. I love this phone. :)

edit flag offensive delete publish link more

Comments

1

I can confirm the unacceptable bug in this, but I thinka fix would come with a feature update which could be a while. I in the mean time had to downgrade , after which I can say with all boldness that the battery drain is nonexistent on 2.0.1.10. Will gladly remain there till this is fixed. Need I remind anybody that jolla's spare batteries aren't available ?

DameCENO ( 2016-09-19 16:42:50 +0300 )edit

Update: 39 minutes of uptime (33% battery) and I noticed in top that messageserver5 eats CPU like crazy. Opened apps: sms, phone. Almost no activity from reboot til now.

And Jolla got a bit hot. How to downgrade? :) ::edit I can see there a topic about messageserver5 going crazy

Piotr ( 2016-09-19 17:09:23 +0300 )edit

To safely downgrade as I did since there were reports of bootloop: First to all apply all patches

Then if you updated powermenu2 uninstall it as it is dependent on 2.0.2

Then run these commands in your terminal app

ssu release 2.0.1.11

version --dup

sync

reboot

With it am back to 2.0.1.11 and free from this silly bug

DameCENO ( 2016-09-19 17:48:48 +0300 )edit
6

answered 2016-09-06 11:57:15 +0300

nthn gravatar image

updated 2016-09-08 11:56:01 +0300

I have solved/worked around the battery drain by forcing powersaving mode to be on all the time. You can enable powersaving mode by installing Powersave Settings from OpenRepos and then finding it in Settings. There is also a terminal command to do this but I forgot what it is, and it's easier with buttons in the ui anyway.

So, it seems like something was enabled/disabled in the recent update which is disabled/enabled respectively in powersaving mode.

Edit: unfortunately I have to say the battery troubles came back yesterday after changing absolutely nothing at all, so this seems to have been a fluke.

edit flag offensive delete publish link more

Comments

1

I can confirm your last edit: battery trouble always comes back randomly.

jolladiho ( 2016-09-08 14:32:13 +0300 )edit
3

answered 2016-08-24 11:26:23 +0300

matusala gravatar image

updated 2016-08-24 11:27:35 +0300

I had 2.0.1.11 installed on my nexus 4 too. With my usage it lasted me 2 days. Now when i updated it to 2.0.2.48 battery life got worse! I have 2 nexus 4 one does not have screen. It's always connected to wifi so i can ssh to it. (kind of like experimental phone :D ) yesterday i charged it to 100% after 15 hours for this moment it's at 80%. On android it would be ~90-92 % in the same situation. Sailfish OS is much lighter then Android and it does not have Google services which drains the battery (at least i have nothing from google running on my phone) and battery life is still worse then on android :( That's pretty bad. Jolla must fix this problem. Also 25% CPU usage when sleeping is still problem for me on 2.0.1.11 and 2.0.2.48. It seems they did not fix this problem. I was going to buy Jolla phone to help this company but i do not think that i want a phone with this kind of software support :( It's very sad :(

edit flag offensive delete publish link more
3

answered 2016-08-28 21:40:08 +0300

Sakke gravatar image

Hi malibu1106. It's very unfortunate to hear that you're having issues with your Jolla Phone. I'm also running Sailfish 2.0.2.48, but haven't had any issues related to battery life etc.

I'd recommend that you give a try to apps called Lighthouse and Charge Monitor since you can find if something is taking up your cpu/ram and therefore your battery. Both of these can be found on Jolla store for Jolla Phone 1.

Scaling CPU governors and frequencies

You need to have developer mode activated and root access to perform these operations. Since you're using root in this "operation", be extra careful and be aware that this may avoid your warranty if something goes wrong. I recommend that you have a backup before you do anything. All the commands and important directory paths are bolded.

  • First open Terminal and enter command devel-su and after that enter your password (assumed that developer mode is activated and SSH password been set). You have now root access on your phone.
  • Now you'll need to locate /sys/devices/system/cpu/cpu0/cpufreq/ (remember that /sys/ is in the root directory not in nemo. From nemo you can move to root directory by entering command cd .. two times and you should see the slash / instead of nemo)
  • You can search available frequencies by entering command: cat scaling_available_frequencies or if you prefer: cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies, after that you'll be having a list of valid frequencies.
  • If you want to lower your CPU's max freq type command: echo "your new frequency" > scaling_max_freq (remember that frequency number must be found on scaling_available_frequencies list in order to work properly). For example: echo "384000" > scaling_max_freq
  • If you want to set the minimum freq then type: echo "your new frequency" > scaling_min_freq
  • You may also want to scale the governor your CPU is using. You can do this by first checking available governors: cat scaling_available_governors
  • You can change your governor by entering echo "your new governor" > scaling_governor

I'm not sure whether those CPU frequencies will be back at default after rebooting the phone, but at least governor will be default (ondemand).

I hope these will help you!

edit flag offensive delete publish link more

Comments

Hi Sakke, first a big thanks to you for this detailed answer ! Second, please excuse my english ;)

I tried to find something special with DataSystemScope ( Thanks rinigus for this great app ) On graphics, i didn't saw anything .. See : Graphics

I tried to switch governors and frequencies like you explained me, i have one question for that, do you know if governors mode are independant of written frequencies ? I mean if a user modified frequency can be "erased" after switching of governor ?

I set the min freq on the lowest, and the max freq to 864000, my battery life seems really best, no drain this night ! The only trouble is that sometimes the phone become to slow for some apps.

Is there a way to create shortcuts for changing frequencies in one click ?

Anyway, thanks a lot for this really good answer Sakke. I hope you understood all what i written :D Malibu1106.

malibu1106 ( 2016-08-30 11:09:07 +0300 )edit

Governors don't make any changes to the frequencies that you have edited. For instance, if you edit scaling_max_freq to 864000, there's no way that governor could get it higher. Governors are just scaling how the CPU is handling with the given frequencies, and how the timer in governor should work. You can read more about governors from here and about the governor modes from here. So answer for your question is: no, changing governor won't change given scaling_max_freq values if you have changed them.

Ps. you can try governor called interactive. In my opinion it's maybe the best one; not sure about "performance" governor. You can also try to put scaling_max_freq around 1 GHz speed, and see how the battery life is then. Have you found out what is taking up your battery?

Yes, there's a way to create shortcuts, or at least I think so. It could be an app where you can change governor and clocks etc. However, I'm not a right person to tell you how you could do this by yourself since I'm not an app developer.

Sakke ( 2016-08-30 17:10:04 +0300 )edit
1

If there was built in option for this in Settings...

zlutor ( 2016-09-09 20:41:25 +0300 )edit

I have changed the scaling_governor to "powersave", the same result, 16% lost during the night....

manu007 ( 2016-09-16 23:47:32 +0300 )edit
1

I answer to myself, with scaling_governor to powersave, the operating is very slow, then I returned to "ondemand" option, but I noticied that the consumption is less, only 10% this morning and now, after a normal usage (viber, SMS, calendar, etc...), from 11:30 to now 17:30, 5%.

manu007 ( 2016-09-19 18:25:57 +0300 )edit
3

answered 2016-08-29 14:17:22 +0300

codeandcreate gravatar image

Just my 2 cent to this problem; i noticed, that if i used flight mode the cpu goes to sleep mode. if i reboot, all is normal again. so i reboot every morning to get proper powersaving :(

(Jolla C)

edit flag offensive delete publish link more
3

answered 2016-09-09 19:26:25 +0300

DameCENO gravatar image

updated 2016-09-09 19:28:49 +0300

Well I am sad to say nothing seems to help with this weird battery drain since this update, on standby on 2.1.0.11 overnight I had an impressive 2 % battery drop overnight, yesterday night it dropped from 50% to 38% this morning. Even the little routine that seems to help after each update when I notice battery drain (running as root systemctl stop tohd.service and systemctl mask tohd.service) has zero effect on this alarming battery drain. Since spare batteries aren't forthcoming, this bug is simple unacceptable. I think it is ssu re 2.1.0.11 to downgrade right? Until this is fixed, any addition or improvement in this SFOS release is not worth this insane battery drain

edit flag offensive delete publish link more

Comments

try disabling any xmpp accounts, such as facebookchat. another problem on my jolla is that sometimes msyncd prevents the cpu from entering sleep state. killing msyncd helps in such situations. it restarts automatically after killing it, so no problem with email sync should occur.

till ( 2016-09-09 23:57:31 +0300 )edit
2

answered 2016-09-08 14:42:45 +0300

jolladiho gravatar image

updated 2016-09-08 14:44:37 +0300

BTW same 2.0.2.xx problem here: https://together.jolla.com/question/139036/intex-aqua-fish-battery-life/

And I do not think, that this question is answered!

edit flag offensive delete publish link more

Comments

3
Login/Signup to Answer

Question tools

Follow
25 followers

Stats

Asked: 2016-07-31 15:43:11 +0300

Seen: 8,127 times

Last updated: Oct 06 '16