We have moved to a new Sailfish OS Forum. Please start new discussions there.

FingerTerm display flashing

asked 2014-01-12 23:08:46 +0300

onurati gravatar image

updated 2014-01-13 14:53:31 +0300

lk gravatar image

Terminal screen flashes brightly if the backspace key is pressed when the bash command line is empty, i.e. if there's nothing to delete. This may be disturbing especially if the phone is used in darkness.

Interestingly enough, this does not seem to happen in the same session again if the About menu is displayed once.

Fingerterm version is 1.0.3, SailfishOS is

edit retag flag offensive close delete



I'd assume that that is the visible bell. It should be there by default, but an idea is that the user should be able to disable it. That it goes away after the About dialog seems to me is the real bug.

Mohjive ( 2014-01-13 00:14:44 +0300 )edit

2 Answers

Sort by » oldest newest most voted

answered 2018-08-11 13:05:52 +0300

Spam Hunter gravatar image

updated 2018-08-12 04:17:31 +0300

@t4k1t - if this did work, it doesn't work any more. Strange that a settings.ini file makes no difference when edited, I have no idea why.


So, I have come up with another solution. Using Terminal, navigate to;


Look for line 90, it looks like this;

color: bellTimer.running ? "#ffffff" : bgcolor

Change the hex colour letters of 'ffffff' to 6 x zero; '000000', so it looks like this;

color: bellTimer.running ? "#000000" : bgcolor

or simply,

color: bgcolor

also, as suggested by Mohjive, a subtle shade to keep visual bell visible but in a dimmer shade,

 color: bellTimer.running ? "#303030" : bgcolor

Save your changes and open FingerTerm again to test, the 'visual bell' should no longer flash.

Somewhat related; more on FingerTerm stuff by me, here;


edit flag offensive delete publish link more



@Edz amazing thanks! Now I can use the terminal in low light!

jakob ( 2018-08-11 13:42:03 +0300 )edit

Maybe change to something other than black, but still dark, like #303030. That way you’ll still see the bell, but not be blinded by the flash.

Mohjive ( 2018-08-11 20:15:25 +0300 )edit

Nice idea @Mohjive

Spam Hunter ( 2018-08-11 21:02:20 +0300 )edit

Use ToeTerm from OpenRepos. The bell effect is toned down and it is better than Fingerterm also in every other concievable way.

bocephus ( 2018-08-12 10:54:35 +0300 )edit

@bocephus: not the keyboard imo. I don't like the enlarged control keys (return, arrows and so on), but that is my personal preference :)

Mohjive ( 2018-08-12 11:00:48 +0300 )edit

answered 2014-01-14 18:32:48 +0300

t4k1t gravatar image

That is the visual bell. If it annoys you that much you can open up /home/nemo/.config/FingerTerm/settings.ini and set visualBell=false.

edit flag offensive delete publish link more



Hey, thanks. Does it work for you? My settings.ini is overwritten each time I start FingerTerm, hence modifying that file doesn't really help here. Besides I get two identical [%General] sections.

onurati ( 2014-01-14 22:17:52 +0300 )edit

You're right the settings are overwritten on every start. This very much looks like a bug to me - According to fingerterm's doc it should only be created on first run.

t4k1t ( 2014-01-15 20:37:52 +0300 )edit

Still same behaviour, with exactly the same symptoms. Please, let's have an option to turn visualBell Off, or at least make FingerTerm respect the values in settings.ini, instead of just blindingly overwriting it ... FingerTerm version 1.1.14.

viking ( 2015-06-17 23:20:25 +0300 )edit

In Sailfish 2.0 this behavior still has not changed. It would be nice if it could be fixed.

exel232 ( 2015-10-30 01:44:57 +0300 )edit

Experiencing same flashing behavior in Sailfish 2.2 . Tried setting both visualBell=false and bellAlert=falsebut no change of behavior. Tried looking in https://git.merproject.org/mer-core/fingerterm but couldn't find any clues.

jakob ( 2018-08-11 12:20:05 +0300 )edit
Login/Signup to Answer

Question tools



Asked: 2014-01-12 23:08:46 +0300

Seen: 858 times

Last updated: Aug 12 '18