Ask / Submit
7

Cannot receive nor make calls in 4G on Aurajoki [answered]

asked 2016-09-12 21:54:18 +0300

AnaT gravatar image

updated 2016-09-12 21:58:28 +0300

After updating to 2.0.2.51, I haven't been able to receive nor make calls when the phone is connected to a 4G network. All incoming calls get automatically redirected to voice mail, and all outbound calls fail with the normal network not availabe tone. Data transfer and SMS work fine, though. If I change to 3 or 2G, all calls work perfectly. Before the update I didn't have any issues with 4G. This seems very much like this two years old bug: https://together.jolla.com/question/47765/4g-lte-bug-cannot-receive-call-diverted-to-voicemail/

Any idea, on what I could do for this? My carrier is Tele Finland (Sonera).

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by AnaT
close date 2016-09-16 22:53:28.154347

Comments

1
6

I have created an internal bug JB#36263 to track this issue. I will ask our telephony expert if he has any ideas about what could cause this, or what extra information he might need from you to debug the issue further.

chris.adams ( 2016-09-13 09:30:10 +0300 )edit

But I have intex aquafish which I have updated to 2.0.2.51 and I connect to the 4g n/w and there are no issues with calls

dillihifi ( 2016-09-13 11:05:40 +0300 )edit
2

@AnaT if you are familiar with using the shell, you can post the output of dbus-send --system --print-reply --dest=org.ofono /ril_0 org.ofono.RadioSettings.GetProperties?

till ( 2016-09-13 11:41:04 +0300 )edit
1

I've probably hit this as well, I have no DIY-patches installed. Unable to receive calls and SMS, although yesterday I was able to make a call. But a friend told me they tried to call, and there is no sign of it in call history.

Acce ( 2016-09-13 22:11:04 +0300 )edit

1 Answer

Sort by » oldest newest most voted
10

answered 2016-09-13 20:57:19 +0300

AnaT gravatar image

updated 2016-09-17 13:21:59 +0300

OK, the reason was ofono version installed as part of More network modes patch (thanks for the hint, @till). Although I had the patch disabled during and after the update, the ofono version was still the one supplied by coderus_ofono repository. To revert back to Jolla's version of ofono, I had to take these steps:

First on Warehouse app:

  1. disable repository coderus_ofono

Then on terminal:

  1. devel-su
  2. pkcon remove sailfishos-more-network-modes
  3. pkcon refresh
  4. pkcon install ofono
  5. reboot
edit flag offensive delete publish link more

Comments

2

good to hear. seems that the patch is missing some sort of uninstall-dependency for ofono

till ( 2016-09-14 00:59:48 +0300 )edit

Question tools

Follow
5 followers

Stats

Asked: 2016-09-12 21:54:18 +0300

Seen: 872 times

Last updated: Sep 17 '16