Ask / Submit
74

[bug] Jolla C, could not receive sms/phone call

Tracked by Jolla

asked 2016-09-17 02:10:41 +0200

Whippler gravatar image

updated 2017-09-30 13:21:24 +0200

BonoNL gravatar image

So earlier today i was supposed to get couple sms messages that the item i ordered is ready for pick up, but never received them and had to rely on the email notifications. And later on i missed a call that never ringed or showed up on the phone.

So i asked a friend to call me. It booped normally on his end as if waiting for answering the call. But on my end nothing happened, Jolla C never ringed.

after rebooting the device i got the sms messages. and calls started working, pretty serious bug, missed my pizza too :/

sonera in finland, data on 4G, sometimes dropping to 3g.

Update 26/4/2017: Still not fixed in 2.1.0.11

Update: 16/7/2017: I did play around with two aqua fishes and find-my-jolla app. did send the magic word from both devices to the other. While i was able to send sms and the other one did receive, mine did not receive a single one untill reboot.

Update 30-09-2017 In my case it was fixed with the 2.1.1.26 update. Can we confirm that it has been fixed so we can close this question?

edit retag flag offensive close delete

Comments

Country, carrier, technology (3G, 4G?)

ossi1967 ( 2016-09-17 08:09:34 +0200 )edit
8

I have the exact same issue with my Jolla C, though I have observed it only with calls and not messages. I have at least three confirmed cases where the other party tried to call me and it looked like it was ringing on its side, but nothing showed up on my phone. Not even a missed call notification, it's like the call never happened. I was reluctant to report it until now because I wanted to eliminate the chance of an app or a patch etc. interfering... I have removed scumstopper app and removed all network change settings from Situations app to see if it would help, but the problem with this bug is you cannot reliably reproduce it or be sure it has gone away. Please Jolla, pay attention to this issue because it certainly is a showstopper....

thisisme ( 2016-09-17 15:14:56 +0200 )edit
1

I have the same on Aqua Fish, both on 2.0.2.48 and 51 versions

x1f ( 2016-09-19 13:48:54 +0200 )edit
1

It did happen for me with 2.0.5.6 on a Jolla C. I only noticed, when my Mom called me on the landline at home, asking me if I was okee and why I would neither answer to calls or SMS text messages.

The Jolla C had an uptime of ~10 days by then and I think I at least disabled SIM card 2 in that period.

I'm using Swisscom (4G enabled) in SIM1 and SIM2 is 3AT card, but only enabled when I go to Austria.

Venty ( 2016-12-12 15:01:15 +0200 )edit
2

I can't understand how this is not treated as a release showstopper by Jolla...

thisisme ( 2016-12-12 19:01:27 +0200 )edit

26 Answers

Sort by » oldest newest most voted
15

answered 2016-09-17 16:02:51 +0200

updated 2016-09-17 16:04:49 +0200

Same for me as reported here where chris said:

We are investigating this internally, JB#35780 - we believe that there is an issue with rild.

edit flag offensive delete publish link more

Comments

5

Thanks for that, I'm glad they're already investigating it!

thisisme ( 2016-09-17 16:15:04 +0200 )edit
7

answered 2016-12-07 18:15:16 +0200

cuh7b5 gravatar image

updated 2016-12-07 18:19:12 +0200

On Jolla C with Sailfish 2.0.5.6, the problem still exists. I had an incoming phone call, ended it then I could not dial nor did I receive calls or sms'es. ril_log was enabled.

ril_log and the journalctl outputs:

ril_log.log

journalctl.log

Just a small addition: I dialled a number but nothing happened on the GUI. Then after about ten seconds there was a tone in the phone, like the one when a dialling fails.

edit flag offensive delete publish link more

Comments

exactly same as me!

TMavica ( 2016-12-17 12:05:36 +0200 )edit
2

Thank you @cuh7b5 for your logs. They will be checked.

jovirkku ( 2016-12-17 21:30:08 +0200 )edit
3

I wonder how many users are still facing this issue with 2.0.5.6. It is at least @cuh7b5 and @TMavica. How about @mvdm, @MJolla, @Moshroom, @babydoc056, @3r00k5, @louisbob, @itdoesntmatt ? Anyone else?

jovirkku ( 2016-12-18 14:16:12 +0200 )edit
2

Yes, still an issue, so I'm using my phone in 3G. I sent my logs to Jolla 2 months ago and got the response 'We have updated the developer team regarding this case. And, it seems to be something known. We added the details to the case there.'

Marco ( 2016-12-18 14:24:22 +0200 )edit

no problem for me so far but as said i use only one sim and set prefered 4g and select manually operator.

MVDM

mvdm ( 2016-12-19 09:54:29 +0200 )edit
7

answered 2016-12-09 10:28:33 +0200

mvdm gravatar image

updated 2016-12-09 10:52:02 +0200

I reopen it because it is'nt solved.(see https://together.jolla.com/users/6848/cuh7b5/)

for me it happend not because i use only one sim in my jolla C and set manually proximus as operator.

On the day i use simscout and see that sim1 works well....

Can jolla confirm status of this- can we have trust in our jolla to make calls ...

I really proud to use this product but if we do'nt see if we are offline, people can use it ...

Can someone give me de command to see de ofono package it like there's the problem ...

i found it pkcon get-details ofono :

i have ofono-1.17+git36.1-1.48.1 ;-)

Thanks.

mvdm

edit flag offensive delete publish link more

Comments

3

I agree! This is a critical problem affecting the core functions of the phone (i.e. the device is totally unreliable). This should be handled with high priority. Jolla guys, please give us some feedback, pls!

cuh7b5 ( 2016-12-09 10:35:29 +0200 )edit
1

I have ofono-1.17+git36.1+patch1-1.48.1.armv7hl installed on my Jolla C. Problem exists.

cuh7b5 ( 2016-12-09 11:15:48 +0200 )edit
3

answered 2017-07-24 19:25:55 +0200

ghling gravatar image

updated 2017-07-24 19:27:48 +0200

Does anyone know if this is fixed with 2.1.1 or at least the promised work-around was included which tells you when the bug occurred and you have to restart your phone? I haven't found anything about it in the release notes, yet it is one of the major issues currently for me.

Edit: I may just answer my own question: From the changelog for droid-config-l500d:

[l500d] Ask user to reboot device after rild restart.

edit flag offensive delete publish link more

Comments

So is it fixed or not in 2.1.1.24?

louisbob ( 2017-08-19 13:40:37 +0200 )edit

+ 1 for this - a big show stopper. Considering to pay 300+ € for Xperia ... if the bug is there, it will be a pitty

Can someone provide an answer please?

deloptes ( 2017-09-30 01:33:17 +0200 )edit

I didn't experience the issue at least since upgrading to 2.1.1.26. Nevertheless, at least the phone seems to notify you when you need to reboot it because the rild service failed. I've seen the notification a few times as false-negative directly after a reboot, so at least it seems to work.

ghling ( 2017-09-30 16:36:59 +0200 )edit

Thank you once again. Very important to know! I need to read more about rild - no idea what it was. Some background: I bought Intex AquaFish and tested it for some time, but my wife broke her phone and "confiscated" the AquaFish - so cool color and size etc :) She became a beta tester and for the past >1y the issue appeared twice. (Yesterday the second time) I need a business reliability. So my plan is to upgrade the AquaFish to 2.1 and buy the Sony Xperia. I'll test the Xperia X during the weekend, when risk is low and I am also not sure that it offers full range of services required for the replacement of my Nokia N9.

Anyway thank you very much and kind regards

deloptes ( 2017-09-30 17:41:29 +0200 )edit
2

answered 2016-09-30 17:59:13 +0200

For whom ever have this bugs, please provide log file for help debug

In terminal, type this command then reboot setprop persist.radio.ril_log_enabled 1

When the bugs happened, means you can dial or receive call, check /data/misc/radio/ril_log and send to Jolla in anyway

PS: Keep look at the file become too large size

edit flag offensive delete publish link more

Comments

I've enabled the log on Friday and try to call every few hours, but so far everything keeps working.... No clue how to reproduce it, but I'll keep trying!

Marco ( 2016-10-03 20:19:52 +0200 )edit
1

Just before rebooting my phone for the 2.0.4 release, I got a call. After this call my phone stopped responding to new calls. I've submitted a support request on zendesk with the logfiles (30108)

Marco ( 2016-10-05 13:10:18 +0200 )edit
2

answered 2016-10-26 12:54:17 +0200

itdoesntmatt gravatar image

i am experiencing the same. it is such an horrible bug. made me discuss with people for not recalling them. fix it or i will have to ditch sailfish

edit flag offensive delete publish link more
2

answered 2016-11-28 10:43:05 +0200

cuh7b5 gravatar image

updated 2016-11-28 15:56:46 +0200

I have updated to 2.0.5.6 a week ago, the problem did not occur since then on my Jolla C. Anyone can confirm that the bug is solved? I see that ofono has been updated.

edit flag offensive delete publish link more

Comments

still present in 2.0.4.14 =(

mvdm ( 2016-11-28 15:07:52 +0200 )edit

2.0.5.x is newer than 2.0.4.x...

cuh7b5 ( 2016-11-28 16:31:10 +0200 )edit
2

The problem still exists on 2.0.5.6. :(

cuh7b5 ( 2016-12-05 10:21:36 +0200 )edit
2

answered 2017-03-08 10:13:39 +0200

cuh7b5 gravatar image

Still no joy. Jolla C, "Prefer 3G", manual network selection, Telekom Hungary. Ril log and journal log:

ril_log_3G.txt, journal_3G.txt

Jolla, please do something!!!

edit flag offensive delete publish link more
1

answered 2016-09-20 03:56:09 +0200

vinbk22 gravatar image

is the same problem: https://together.jolla.com/question/143701/bug-phone-app-freezes-on-jolla-c-20251/

edit flag offensive delete publish link more

Comments

1

Yeah same with Intex https://together.jolla.com/question/143088/intex-call-missing-phone-app-not-working/ In Finland also but operator is DNA

MJolla ( 2016-09-21 12:20:47 +0200 )edit
1

answered 2016-10-11 18:10:53 +0200

For someone request, I post in here also. This is the log of ofono rild , that about this bugs happened, I used this Ofono logger . Maybe this can help Jolla to figure out whats the problem.

Ofono Log file

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
25 followers

Stats

Asked: 2016-09-17 02:10:41 +0200

Seen: 4,945 times

Last updated: Nov 10