Ask / Submit
17

No *speaker* when taking calls (Sailfish X) [duplicate]

asked 2017-10-12 22:26:43 +0200

NevilClavain gravatar image

updated 2017-10-12 22:53:51 +0200

olf gravatar image

I am not able to put the call on speaker when calling or taking calls. If I press the speaker it lights up but nothing else happends. Is this happening to anyone else?

edit retag flag offensive reopen delete

The question has been closed for the following reason "duplicate question" by Direc
close date 2017-10-31 18:38:23.753959

Comments

I just finished a call and noted almost the same thing: the switch toggles, but speaker volume is hardly increased at all, enen at maximum volume. The tone, however, changes, so I think the audio routing works and the volume is the issue...

Direc ( 2017-10-12 23:13:23 +0200 )edit
3

I can activate it and it definitely does switch to the speaker mode - but the maximum volume is much lower than on the Jolla C. Filled an issue about that:

https://together.jolla.com/question/169291/xperia-x-speakerphone-volume-too-low/

MartinK ( 2017-10-13 03:20:08 +0200 )edit

I noticed same

MJolla ( 2017-10-30 20:07:19 +0200 )edit

1 Answer

Sort by » oldest newest most voted
4

answered 2017-11-27 18:17:24 +0200

Pasko gravatar image

updated 2017-11-28 00:24:21 +0200

Hi. I'm reposting this answer from the other issue opened by @MartinK :D

I also think this question is not duplicated: this one deals with speaker not switching on/off while the others complain about low speakerphone volume.

The speaker of my Xperia didn't switch on during a call when tapping the appropriate button. After the changes explained below it did switch on when required to do it (I can actually set the volume).

I think I solved this issue by manually editing as root the following file:

vi /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf

And then changing line 108, changing "switch = mute" to "switch = on" so that the [Element Speaker] section looks like this:

   .....................
    [Element Speaker]
    required-any = any
    switch = on
    volume = merge
    override-map.1 = all
    override-map.2 = all-left,all-right

    [Element Desktop Speaker]
    .....................

Please be careful while editing and make a backup copy of the original file. After this, you may reboot or restart pulseaudio service (as nemo user) with:

systemctl --user restart pulseaudio

and try to make a phone call with the speaker on.....

Regards.

edit flag offensive delete publish link more

Comments

Could you try if this produces an echo towards the other side (towards the caller)? I remember Jolla saying that the volume of the built-in speaker is currently reduced to prevent echos as the noise reduction mechanism is not yet fully functional in the Xperia X hardware adaption (apparently as well on AOSP). So I'm wondering if the external speaker is currently disabled due to the same reasons.

ghling ( 2017-11-28 09:22:00 +0200 )edit
1

Hi.

I've been using it for a while without problems, but will give it a spin again and report back here ASAP. :D

Regards.

UPDATE: After trying for a while I can certainly hear the echo (I'm on the other side of the communication). I think it can be mitigated by reducing the volume..... which is not very useful if you're willing to use the external loudspeaker. I also think the loudspeaker is disabled on purpose by Jolla instead of the volume reduced as they said. :D

I also didn't notice the echo at first because I use it to call to IVR machines and they usually can't complain about echo. :D

Pasko ( 2017-11-28 10:08:39 +0200 )edit
1

Thank you for checking. I suspect as well that Jolla disabled the feature due to the echo. Unfortunately it seems this is a hardware adaptation issue as it is present in AOSP as well, so Jolla can't really do much about it but hope that Sony will fix this.

ghling ( 2017-11-28 20:35:00 +0200 )edit

I edited the file as instructed, rebooted pulseaudio, and have now rebooted my phone a few times already, but it seems that the speaker is not enabled after all. At least I can't notice any difference in speaker volume...

Direc ( 2017-12-05 08:55:54 +0200 )edit

Hi @Direc

You may want to try the following steps and see if you notice the difference:

1.- Make a call (hopefully a free phone number, for instance to an 800-XXX number)

2.- When the call is established, activate the speaker in the phone app.

3.- Now, pump up the volume with the volume rocker.

4.- Finally disconnect/reconnect the speaker in the phone app to see if you notice the difference...

My guess is that the volume is adjusted 'online' that is: when the external speaker is active.

I hope this helps.

Best regards.

Pasko ( 2017-12-05 13:00:39 +0200 )edit

Question tools

Follow
3 followers

Stats

Asked: 2017-10-12 22:26:43 +0200

Seen: 341 times

Last updated: Nov 28